summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-06-12 23:28:27 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-06-12 23:28:27 +0000
commit4a3b04c47ecfc4dd123c8f2ed20f07fc70918a7b (patch)
tree36f41daa93e0b52a2520aa7be21b9afa21336191 /net-im
parentStable on amd64 wrt security bug 181385 (diff)
downloadgentoo-2-4a3b04c47ecfc4dd123c8f2ed20f07fc70918a7b.tar.gz
gentoo-2-4a3b04c47ecfc4dd123c8f2ed20f07fc70918a7b.tar.bz2
gentoo-2-4a3b04c47ecfc4dd123c8f2ed20f07fc70918a7b.zip
version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/ChangeLog7
-rw-r--r--net-im/mcabber/files/digest-mcabber-0.9.23
-rw-r--r--net-im/mcabber/mcabber-0.9.2.ebuild85
3 files changed, 94 insertions, 1 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index c7571985e6cd..bb6a88b9a5ea 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/mcabber
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.14 2007/05/06 11:45:59 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.15 2007/06/12 23:28:27 wschlich Exp $
+
+*mcabber-0.9.2 (12 Jun 2007)
+
+ 12 Jun 2007; Wolfram Schlich <wschlich@gentoo.org> +mcabber-0.9.2.ebuild:
+ version bump
06 May 2007; Marius Mauch <genone@gentoo.org> mcabber-0.7.4.ebuild,
mcabber-0.7.6.ebuild, mcabber-0.7.8.ebuild, mcabber-0.8.2.ebuild,
diff --git a/net-im/mcabber/files/digest-mcabber-0.9.2 b/net-im/mcabber/files/digest-mcabber-0.9.2
new file mode 100644
index 000000000000..be8e642de9d7
--- /dev/null
+++ b/net-im/mcabber/files/digest-mcabber-0.9.2
@@ -0,0 +1,3 @@
+MD5 08e148f35fb7451bc14e84e97c405de5 mcabber-0.9.2.tar.bz2 435686
+RMD160 0953318e2e83ae442ee36bff74e4ab56a6e9fc0c mcabber-0.9.2.tar.bz2 435686
+SHA256 9333d7b4764ffd8267bf3e26cc8c28772bee53a2edf389ccf4f438ea970cdfc7 mcabber-0.9.2.tar.bz2 435686
diff --git a/net-im/mcabber/mcabber-0.9.2.ebuild b/net-im/mcabber/mcabber-0.9.2.ebuild
new file mode 100644
index 000000000000..3b91c5941302
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.9.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.2.ebuild,v 1.1 2007/06/12 23:28:27 wschlich Exp $
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
+SRC_URI="http://www.lilotux.net/~mikael/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ssl crypt"
+
+LANGS="de en fr nl pl uk ru"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )
+ >=dev-libs/glib-2.0.0
+ sys-libs/ncurses"
+
+src_compile() {
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_with ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ ! use linguas_${i} && rm -rf ${D}/usr/share/${PN}/help/${i}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
+ dodoc doc/README_PGP.txt
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins ${S}/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe ${S}/contrib/*.{pl,py,rb}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe ${S}/contrib/events/*
+}
+
+pkg_postinst() {
+ elog
+ elog "MCabber requires you to create a subdirectory .mcabber in your home"
+ elog "directory and to place a configuration file there."
+ elog "An example mcabberrc was installed as part of the documentation."
+ elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+ elog "following commands:"
+ elog
+ elog " mkdir -p ~/.mcabber"
+ elog " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ elog
+ elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ elog
+ elog "As of MCabber version 0.8.2, there is also a wizard script"
+ elog "with which you can create all necessary configuration options."
+ elog "To use it, simply execute the following command:"
+ elog
+ elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
+ elog
+ elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ elog "manual page (section 1) for more information."
+ elog
+ elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ elog "See README_PGP.txt for details."
+ elog
+ elog "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
+ elog
+}