summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-18 20:08:09 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-18 20:08:09 +0000
commit7bd0aedd9ef78accd3bd16251e2a659774892be9 (patch)
tree43259e72ad32596ae6889f139af9f8b9224ea3ed /net-im
parentVersion bump. (diff)
downloadgentoo-2-7bd0aedd9ef78accd3bd16251e2a659774892be9.tar.gz
gentoo-2-7bd0aedd9ef78accd3bd16251e2a659774892be9.tar.bz2
gentoo-2-7bd0aedd9ef78accd3bd16251e2a659774892be9.zip
Bump to 2.26.2. Bug fixes and translation updates.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/empathy/ChangeLog8
-rw-r--r--net-im/empathy/empathy-2.26.2.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/net-im/empathy/ChangeLog b/net-im/empathy/ChangeLog
index db34d4f600d6..bfc231758fb0 100644
--- a/net-im/empathy/ChangeLog
+++ b/net-im/empathy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/empathy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/ChangeLog,v 1.38 2009/05/15 20:56:47 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/ChangeLog,v 1.39 2009/05/18 20:08:09 eva Exp $
+
+*empathy-2.26.2 (18 May 2009)
+
+ 18 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +empathy-2.26.2.ebuild:
+ Bump to 2.26.2. Bug fixes and translation updates.
15 May 2009; Tobias Klausmann <klausman@gentoo.org> empathy-2.26.1.ebuild:
Keyworded on alpha, bug #269314
diff --git a/net-im/empathy/empathy-2.26.2.ebuild b/net-im/empathy/empathy-2.26.2.ebuild
new file mode 100644
index 000000000000..f40de6543a6b
--- /dev/null
+++ b/net-im/empathy/empathy-2.26.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/empathy-2.26.2.ebuild,v 1.1 2009/05/18 20:08:09 eva Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="Telepathy client and library using GTK+"
+HOMEPAGE="http://live.gnome.org/Empathy"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="applet doc python spell test"
+
+# FIXME: libnotify & libcanberra hard deps
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.14.0
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=dev-libs/dbus-glib-0.51
+ >=gnome-extra/evolution-data-server-1.2
+ >=net-libs/telepathy-glib-0.7.23
+ >=net-im/telepathy-mission-control-4.61
+ >=media-libs/libcanberra-0.4
+ >=x11-libs/libnotify-0.4.4
+
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ net-libs/telepathy-farsight
+ dev-libs/libxml2
+
+ applet? ( >=gnome-base/gnome-panel-2.10 )
+ spell? (
+ app-text/enchant
+ app-text/iso-codes )
+ python? (
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pygtk-2 )"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.16
+ test? ( >=dev-libs/check-0.9.4 )
+ dev-libs/libxslt
+ virtual/python
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+DOCS="CONTRIBUTORS AUTHORS ChangeLog NEWS README"
+
+# FIXME: Tests are broken, upstream bug #576785
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable debug)
+ $(use_enable spell)
+ $(use_enable python)
+ $(use_enable applet megaphone)
+ $(use_enable applet nothere)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Doc is broken
+ epatch "${FILESDIR}/${PN}-2.26.1-fix-doc.patch"
+
+ # Remove hard enabled -Werror (see AM_MAINTAINER_MODE), bug 218687
+ sed -i "s:-Werror::g" configure || die "sed 1 failed"
+
+ # FIXME: report upstream their package is broken
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed 2 failed"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check || die "emake check failed."
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ echo
+ elog "Empathy needs telepathy's connection managers to use any IM protocol."
+ elog "You will need to install connection managers yourself."
+ elog "MSN: net-voip/telepathy-butterfly"
+ elog "Jabber and Gtalk: net-voip/telepathy-gabble"
+ elog "IRC: net-irc/telepathy-idle"
+ elog "Link-local XMPP: net-irc/telepathy-salut"
+ echo
+}