summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2013-02-18 08:25:51 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2013-02-18 08:25:51 +0000
commite510426ed9d910466624143ec588c5f3d2a28ce9 (patch)
treeaa67b95dbb7c82469dc2b7c89e67a7a9567ea258 /net-irc/anope
parentFix comment: iff = if and only if. (diff)
downloadgentoo-2-e510426ed9d910466624143ec588c5f3d2a28ce9.tar.gz
gentoo-2-e510426ed9d910466624143ec588c5f3d2a28ce9.tar.bz2
gentoo-2-e510426ed9d910466624143ec588c5f3d2a28ce9.zip
Fixing init script to ensure /run directory exists, fixing #448464
(Portage version: 2.2.0_alpha163/cvs/Linux i686, signed Manifest commit with key 15AE484C)
Diffstat (limited to 'net-irc/anope')
-rw-r--r--net-irc/anope/ChangeLog10
-rw-r--r--net-irc/anope/anope-1.8.7-r1.ebuild (renamed from net-irc/anope/anope-1.8.7.ebuild)6
-rw-r--r--net-irc/anope/files/anope-init.d17
3 files changed, 20 insertions, 13 deletions
diff --git a/net-irc/anope/ChangeLog b/net-irc/anope/ChangeLog
index 9a598e86bd7e..b72ae54c8db2 100644
--- a/net-irc/anope/ChangeLog
+++ b/net-irc/anope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/anope
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.21 2012/07/01 21:07:35 binki Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.22 2013/02/18 08:25:51 gurligebis Exp $
+
+*anope-1.8.7-r1 (18 Feb 2013)
+
+ 18 Feb 2013; <gurligebis@gentoo.org> -anope-1.8.7.ebuild,
+ +anope-1.8.7-r1.ebuild, files/anope-init.d:
+ Fixing init script to ensure /run directory exists, fixing #448464
01 Jul 2012; Nathan Phillip Brink <binki@gentoo.org> anope-1.8.7.ebuild:
Ensure that /var/lib/anope/backups directory exists so that database backups
diff --git a/net-irc/anope/anope-1.8.7.ebuild b/net-irc/anope/anope-1.8.7-r1.ebuild
index a1829fcf0191..6ca2cfc24159 100644
--- a/net-irc/anope/anope-1.8.7.ebuild
+++ b/net-irc/anope/anope-1.8.7-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.8.7.ebuild,v 1.3 2012/07/01 21:07:35 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.8.7-r1.ebuild,v 1.1 2013/02/18 08:25:51 gurligebis Exp $
EAPI=4
-inherit autotools eutils multilib versionator
+inherit autotools eutils multilib versionator user
DESCRIPTION="Anope IRC Services"
HOMEPAGE="http://www.anope.org"
diff --git a/net-irc/anope/files/anope-init.d b/net-irc/anope/files/anope-init.d
index a7a529626dd5..66e6ecf11a8c 100644
--- a/net-irc/anope/files/anope-init.d
+++ b/net-irc/anope/files/anope-init.d
@@ -1,33 +1,34 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/files/anope-init.d,v 1.1 2011/12/28 20:25:48 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/files/anope-init.d,v 1.2 2013/02/18 08:25:51 gurligebis Exp $
+
+PIDFILE=/run/anope/services.pid
extra_started_commands="reload"
-depend() {
- use net mysql ircd
- provide irc-services
+start_pre() {
+ checkpath -o ${ANOPE_USER} -d "$(dirname $PIDFILE)"
}
start() {
ebegin "Starting Anope IRC Services"
start-stop-daemon --start --exec /usr/bin/services \
- --user ${ANOPE_USER} --pidfile /var/run/anope/services.pid \
+ --user ${ANOPE_USER} --pidfile ${PIDFILE} \
-- ${ANOPE_OPTS}
eend $?
}
stop() {
ebegin "Stopping Anope IRC Services"
- start-stop-daemon --stop --pidfile /var/run/anope/services.pid
+ start-stop-daemon --stop --pidfile ${PIDFILE}
eend $?
}
reload() {
ebegin "Reloading Anope IRC Services"
start-stop-daemon --signal USR2 --exec /usr/bin/services \
- --pidfile /var/run/anope/services.pid
+ --pidfile ${PIDFILE}
eend $?
}