summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElfyn McBratney <beu@gentoo.org>2005-09-04 06:08:56 +0000
committerElfyn McBratney <beu@gentoo.org>2005-09-04 06:08:56 +0000
commit5b325eabde36121c62e09bd7c4b7c4d6799db494 (patch)
tree0b9aa51adabcb18f7e0b7a557dba8b824e868dd3 /net-irc/atheme
parentftpnew{user,group} needs to be in a pkg_ func not a src_ func (diff)
downloadgentoo-2-5b325eabde36121c62e09bd7c4b7c4d6799db494.tar.gz
gentoo-2-5b325eabde36121c62e09bd7c4b7c4d6799db494.tar.bz2
gentoo-2-5b325eabde36121c62e09bd7c4b7c4d6799db494.zip
New package.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-irc/atheme')
-rw-r--r--net-irc/atheme/ChangeLog12
-rw-r--r--net-irc/atheme/Manifest6
-rw-r--r--net-irc/atheme/atheme-0.2.2.ebuild53
-rw-r--r--net-irc/atheme/files/digest-atheme-0.2.21
-rw-r--r--net-irc/atheme/files/make-postgresql-support-optional.patch99
-rw-r--r--net-irc/atheme/files/makefile-DESTDIR-support.patch145
-rw-r--r--net-irc/atheme/metadata.xml10
7 files changed, 326 insertions, 0 deletions
diff --git a/net-irc/atheme/ChangeLog b/net-irc/atheme/ChangeLog
new file mode 100644
index 000000000000..3055dce42a8e
--- /dev/null
+++ b/net-irc/atheme/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-irc/atheme
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme/ChangeLog,v 1.1 2005/09/04 06:08:56 beu Exp $
+
+*atheme-0.2.2 (04 Sep 2005)
+
+ 04 Sep 2005; Elfyn McBratney <beu@gentoo.org>
+ +files/make-postgresql-support-optional.patch,
+ +files/makefile-DESTDIR-support.patch, +metadata.xml,
+ +atheme-0.2.2.ebuild:
+ New ebuild.
+
diff --git a/net-irc/atheme/Manifest b/net-irc/atheme/Manifest
new file mode 100644
index 000000000000..6c7eb025d05c
--- /dev/null
+++ b/net-irc/atheme/Manifest
@@ -0,0 +1,6 @@
+MD5 4c1fea5a65a108b583fcfada2a528d36 atheme-0.2.2.ebuild 1342
+MD5 768955ffa40609049cdfead22879443d metadata.xml 261
+MD5 58c136b33f252609db9de33f23fc499d ChangeLog 336
+MD5 d9426639feac91a74b80c4f246c53f31 files/digest-atheme-0.2.2 61
+MD5 1f482d7cb73e4f059c00fbb18a9eed9e files/makefile-DESTDIR-support.patch 4529
+MD5 fe5c707d98c7536cfde95e9fcbe5117e files/make-postgresql-support-optional.patch 3008
diff --git a/net-irc/atheme/atheme-0.2.2.ebuild b/net-irc/atheme/atheme-0.2.2.ebuild
new file mode 100644
index 000000000000..1b8b7335e19f
--- /dev/null
+++ b/net-irc/atheme/atheme-0.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme/atheme-0.2.2.ebuild,v 1.1 2005/09/04 06:08:56 beu Exp $
+
+inherit eutils
+
+DESCRIPTION="A portable, secure set of open source, and modular IRC services"
+HOMEPAGE="http://atheme.org/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="largenet postgres"
+
+DEPEND=">=sys-devel/autoconf-2.59"
+RDEPEND="postgres? ( dev-db/postgresql )"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd '${S}' failed"
+
+ epatch ${FILESDIR}/make-postgresql-support-optional.patch \
+ || die "epacth failed"
+ epatch ${FILESDIR}/makefile-DESTDIR-support.patch \
+ || die "epatch failed"
+}
+
+src_compile() {
+ autoreconf -i || die "autoreconf failed"
+ ./configure \
+ --prefix=/var/lib/atheme \
+ `use_with postgresql` \
+ `use_with largenet large-net` \
+ || die "configure failed"
+
+ make DESTDIR="${D}" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "emake install failed"
+ cp "${D}"/var/lib/atheme/etc/{example,atheme}.conf || die "cp failed"
+ dodoc ChangeLog INSTALL README || die "dodoc failed"
+ dodoc doc/{example_module.c,LICENSE,POSTGRESQL,RELEASE,ROADMAP} \
+ || die "dodoc failed"
+ rm -rf "${D}"/var/lib/atheme/doc
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Don't forget to edit /var/lib/atheme/etc/atheme.conf!"
+ einfo
+}
diff --git a/net-irc/atheme/files/digest-atheme-0.2.2 b/net-irc/atheme/files/digest-atheme-0.2.2
new file mode 100644
index 000000000000..daeb6e502230
--- /dev/null
+++ b/net-irc/atheme/files/digest-atheme-0.2.2
@@ -0,0 +1 @@
+MD5 3e66bd34992d0b14f7d898a9b207c430 atheme-0.2.2.tgz 297623
diff --git a/net-irc/atheme/files/make-postgresql-support-optional.patch b/net-irc/atheme/files/make-postgresql-support-optional.patch
new file mode 100644
index 000000000000..edd0d2a9939b
--- /dev/null
+++ b/net-irc/atheme/files/make-postgresql-support-optional.patch
@@ -0,0 +1,99 @@
+diff -Nup -r atheme-0.2.2/configure.ac atheme-0.2.2.patched/configure.ac
+--- atheme-0.2.2/configure.ac 2005-09-03 21:17:30.000000000 +0000
++++ atheme-0.2.2.patched/configure.ac 2005-09-04 02:16:20.000000000 +0000
+@@ -95,43 +95,61 @@ echo " "
+
+ POSTGRESQL="yes"
+
+-AC_MSG_CHECKING(for PostgreSQL include directory)
+-if test -d /usr/include/pgsql ; then
+- pg_inc_dir="/usr/include/pgsql"
+-elif test -f /usr/local/include/libpq-fe.h ; then
+-# kludge for freebsd ports, found on liveharmony boxes. --nenolod
+- pg_inc_dir="/usr/local/include"
+- LDFLAGS="-L/usr/local/lib"
+-elif test -d /usr/include/postgresql ; then
+- pg_inc_dir="/usr/include/postgresql"
+-elif test -d /usr/local/psql/include ; then
+- pg_inc_dir="/usr/local/psql/include"
+-elif test -d /usr/local/include/postgresql ; then
+- pg_inc_dir="/usr/local/include/postgresql"
+-elif test -d /usr/local/pgsql/include ; then
+- pg_inc_dir="/usr/local/include/psql"
+-elif test -d /usr/local/include/psql ; then
+- pg_inc_dir="/usr/local/include/psql"
+-elif test -d /opt/psql/include ; then
+- pg_inc_dir="/opt/psql/include"
+-else
+- pg_inc_dir="no"
+- PQLIB=""
+- POSTGRESQL="no"
+-fi
++AC_ARG_WITH(postgresql,
++AC_HELP_STRING([--with-postgresql],[ Enables PostgreSQL backend support.]),
++[
++ case "$withval" in
++ yes|no)
++ POSTGRESQL="$withval"
++ ;;
++ *)
++ AC_MSG_ERROR([Invalid argument to --with-postgresql (expecting either 'yes' or 'no')])
++ ;;
++ esac
++])
+
+-POSTGRESQL_C=""
++AC_MSG_CHECKING([whether to enable PostgreSQL backend support])
++AC_MSG_RESULT($POSTGRESQL)
+
+-AC_MSG_RESULT($pg_inc_dir)
++if test "x$POSTGRESQL" = xyes; then
++ AC_MSG_CHECKING(for PostgreSQL include directory)
++ if test -d /usr/include/pgsql ; then
++ pg_inc_dir="/usr/include/pgsql"
++ elif test -f /usr/local/include/libpq-fe.h ; then
++ # kludge for freebsd ports, found on liveharmony boxes. --nenolod
++ pg_inc_dir="/usr/local/include"
++ LDFLAGS="-L/usr/local/lib"
++ elif test -d /usr/include/postgresql ; then
++ pg_inc_dir="/usr/include/postgresql"
++ elif test -d /usr/local/psql/include ; then
++ pg_inc_dir="/usr/local/psql/include"
++ elif test -d /usr/local/include/postgresql ; then
++ pg_inc_dir="/usr/local/include/postgresql"
++ elif test -d /usr/local/pgsql/include ; then
++ pg_inc_dir="/usr/local/include/psql"
++ elif test -d /usr/local/include/psql ; then
++ pg_inc_dir="/usr/local/include/psql"
++ elif test -d /opt/psql/include ; then
++ pg_inc_dir="/opt/psql/include"
++ else
++ pg_inc_dir="no"
++ PQLIB=""
++ POSTGRESQL="no"
++ fi
+
+-if test "$pg_inc_dir" != "no"; then
+- AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
+- PGINC="-I$pg_inc_dir"
+- AC_CHECK_LIB(pq, PQconnectdb, PQLIB="-lpq")
+- POSTGRESQL_C="postgresql.c"
+- ])
+-else
+- POSTGRESQL="no"
++ POSTGRESQL_C=""
++
++ AC_MSG_RESULT($pg_inc_dir)
++
++ if test "$pg_inc_dir" != "no"; then
++ AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
++ PGINC="-I$pg_inc_dir"
++ AC_CHECK_LIB(pq, PQconnectdb, PQLIB="-lpq")
++ POSTGRESQL_C="postgresql.c"
++ ])
++ else
++ POSTGRESQL="no"
++ fi
+ fi
+
+ AC_SUBST(POSTGRESQL_C)
diff --git a/net-irc/atheme/files/makefile-DESTDIR-support.patch b/net-irc/atheme/files/makefile-DESTDIR-support.patch
new file mode 100644
index 000000000000..43ce6ba4e24a
--- /dev/null
+++ b/net-irc/atheme/files/makefile-DESTDIR-support.patch
@@ -0,0 +1,145 @@
+diff -Nup -r atheme-0.2.2/backend/Makefile.in atheme-0.2.2.patched/backend/Makefile.in
+--- atheme-0.2.2/backend/Makefile.in 2005-09-03 21:17:28.000000000 +0000
++++ atheme-0.2.2.patched/backend/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2005/09/04 06:08:56 beu Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -36,8 +38,8 @@ all: protocols
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/backend
+- ${INSTALL} -m 755 *.so ${PREFIX}/backend
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/backend
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/backend
+
+ protocols: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/contrib/Makefile.in atheme-0.2.2.patched/contrib/Makefile.in
+--- atheme-0.2.2/contrib/Makefile.in 2005-09-03 21:17:29.000000000 +0000
++++ atheme-0.2.2.patched/contrib/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2005/09/04 06:08:56 beu Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -38,8 +40,8 @@ all: protocols
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/contrib
+- ${INSTALL} -m 755 *.so ${PREFIX}/contrib
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/contrib
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/contrib
+
+ protocols: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/modules/Makefile.in atheme-0.2.2.patched/modules/Makefile.in
+--- atheme-0.2.2/modules/Makefile.in 2005-09-03 21:17:30.000000000 +0000
++++ atheme-0.2.2.patched/modules/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2005/09/04 06:08:56 beu Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -36,8 +38,8 @@ all: modules
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/modules
+- ${INSTALL} -m 755 *.so ${PREFIX}/modules
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/modules
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/modules
+
+ modules: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/protocol/Makefile.in atheme-0.2.2.patched/protocol/Makefile.in
+--- atheme-0.2.2/protocol/Makefile.in 2005-09-03 21:17:29.000000000 +0000
++++ atheme-0.2.2.patched/protocol/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2005/09/04 06:08:56 beu Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -49,8 +51,8 @@ all: protocols
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/protocol
+- ${INSTALL} -m 755 *.so ${PREFIX}/protocol
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/protocol
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/protocol
+
+ protocols: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/src/Makefile.in atheme-0.2.2.patched/src/Makefile.in
+--- atheme-0.2.2/src/Makefile.in 2005-09-03 21:17:29.000000000 +0000
++++ atheme-0.2.2.patched/src/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2005/09/04 06:08:56 beu Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -70,27 +72,27 @@ atheme: $(OBJS)
+ $(MV) version.c version.c.last
+
+ install: build
+- $(INSTALL) -m 755 -d $(PREFIX)
+- $(INSTALL) -m 755 -d $(PREFIX)/bin
+- $(INSTALL) -m 755 -d $(PREFIX)/etc
+- $(INSTALL) -m 755 -d $(PREFIX)/var
+- $(INSTALL) -m 755 -c $(BIN) $(PREFIX)/bin
+- $(INSTALL) -m 640 -c ../dist/example.conf $(PREFIX)/etc
+- $(INSTALL) -m 640 -c ../dist/example-traditional.conf $(PREFIX)/etc
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)/etc
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)/var
++ $(INSTALL) -m 755 -c $(BIN) $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -m 640 -c ../dist/example.conf $(DESTDIR)$(PREFIX)/etc
++ $(INSTALL) -m 640 -c ../dist/example-traditional.conf $(DESTDIR)$(PREFIX)/etc
+ if [ ! -r $(PREFIX)/etc/atheme.db ]; then \
+- $(INSTALL) -m 640 -c ../dist/atheme.db $(PREFIX)/etc ; \
++ $(INSTALL) -m 640 -c ../dist/atheme.db $(DESTDIR)$(PREFIX)/etc ; \
+ fi
+ if [ ! -r $(PREFIX)/etc/atheme.chk ]; then \
+- $(INSTALL) -m 640 -c ../dist/atheme.chk $(PREFIX)/etc ; \
++ $(INSTALL) -m 640 -c ../dist/atheme.chk $(DESTDIR)$(PREFIX)/etc ; \
+ fi
+ if [ -e $(PREFIX)/doc ]; then \
+- $(RM) -rf $(PREFIX)/doc ; \
++ $(RM) -rf $(DESTDIR)$(PREFIX)/doc ; \
+ fi
+ if [ -e $(PREFIX)/help ]; then \
+- $(RM) -rf $(PREFIX)/help ; \
++ $(RM) -rf $(DESTDIR)$(PREFIX)/help ; \
+ fi
+- $(CP) -R ../doc $(PREFIX)
+- $(CP) -R ../help $(PREFIX)
++ $(CP) -R ../doc $(DESTDIR)$(PREFIX)
++ $(CP) -R ../help $(DESTDIR)$(PREFIX)
+
+ @echo "----------------------------------------------------------------"
+ @echo ">>> Remember to cd to ${PREFIX} and edit your config file.";
diff --git a/net-irc/atheme/metadata.xml b/net-irc/atheme/metadata.xml
new file mode 100644
index 000000000000..d94c9ed21b2e
--- /dev/null
+++ b/net-irc/atheme/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer>
+ <email>beu@gentoo.org</email>
+ <name>Elfyn McBratney</name>
+ </maintainer>
+ <herd>net-irc</herd>
+</pkgmetadata>