summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-04-03 21:41:12 +0000
committerSven Wegener <swegener@gentoo.org>2005-04-03 21:41:12 +0000
commit98a94b9336471cd89ede0114547e79a204998e29 (patch)
tree0758b0279935fafa79b273f4b6299c169df7cd8f /net-irc/bnc/bnc-2.9.3-r2.ebuild
parentFix arts detection (#62304). Cleanup. (diff)
downloadgentoo-2-98a94b9336471cd89ede0114547e79a204998e29.tar.gz
gentoo-2-98a94b9336471cd89ede0114547e79a204998e29.tar.bz2
gentoo-2-98a94b9336471cd89ede0114547e79a204998e29.zip
Two revision bumps. One for distributing the fix for bug #87463. And the other one for testing the ssl USE flag.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-irc/bnc/bnc-2.9.3-r2.ebuild')
-rw-r--r--net-irc/bnc/bnc-2.9.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/bnc/bnc-2.9.3-r2.ebuild b/net-irc/bnc/bnc-2.9.3-r2.ebuild
new file mode 100644
index 000000000000..35581f7743d8
--- /dev/null
+++ b/net-irc/bnc/bnc-2.9.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.9.3-r2.ebuild,v 1.1 2005/04/03 21:41:12 swegener Exp $
+
+inherit eutils
+
+MY_P=${P/-/}
+DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
+HOMEPAGE="http://gotbnc.com/"
+SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e s:./mkpasswd:/usr/bin/bncmkpasswd: ${S}/bncsetup || die
+}
+
+src_compile() {
+ econf $(use_with ssl) || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ mv mkpasswd bncmkpasswd
+}
+
+src_install() {
+ dobin bnc bncchk bncsetup bncmkpasswd || die "dobin failed"
+ dodoc ChangeLog README example.conf motd
+}
+
+pkg_postinst() {
+ einfo "You can find an example motd/conf file here:"
+ einfo " /usr/share/doc/${PF}/{example.conf,motd}.gz"
+}