summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-08-05 23:10:27 +0000
committerSven Wegener <swegener@gentoo.org>2004-08-05 23:10:27 +0000
commit54fe87b75e6945b6c4e9deff0a8190d34b4b7ab6 (patch)
tree0c459199bfb215431451905781d38fc437a18d0d /net-irc/cwirc/cwirc-1.8.8.ebuild
parentRemoved large files from FILESDIR. Marked 1.6.16 stable on x86. (Manifest rec... (diff)
downloadgentoo-2-54fe87b75e6945b6c4e9deff0a8190d34b4b7ab6.tar.gz
gentoo-2-54fe87b75e6945b6c4e9deff0a8190d34b4b7ab6.tar.bz2
gentoo-2-54fe87b75e6945b6c4e9deff0a8190d34b4b7ab6.zip
Version bump.
Diffstat (limited to 'net-irc/cwirc/cwirc-1.8.8.ebuild')
-rw-r--r--net-irc/cwirc/cwirc-1.8.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-irc/cwirc/cwirc-1.8.8.ebuild b/net-irc/cwirc/cwirc-1.8.8.ebuild
new file mode 100644
index 000000000000..0b7b014ed52a
--- /dev/null
+++ b/net-irc/cwirc/cwirc-1.8.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/cwirc-1.8.8.ebuild,v 1.1 2004/08/05 23:10:27 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="An X-chat plugin for sending and receiving raw morse code over IRC"
+HOMEPAGE="http://webperso.easyconnect.fr/om.the/web/cwirc/"
+SRC_URI="http://webperso.easyconnect.fr/om.the/web/cwirc/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+
+ >=net-irc/xchat-2.0.1"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/cwirc-1.7.1-gentoo.patch
+ sed -i -e 's:$(STRIP):echo:' Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -DLINUX" || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ dodoc README RELEASE_NOTES Changelog
+ cp -R schematics/ ${D}/usr/share/doc/${PF}/schematics/
+}