summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-12 23:17:20 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-12 23:17:20 +0000
commit90f6f86ef748af9410bb8847e372324cd7576dda (patch)
treeacea53489f86247948dbd3c5ce0301a994880866 /net-irc/ircii/ircii-20030709-r2.ebuild
parentFixed mandir, closing Bug #28551 (diff)
downloadgentoo-2-90f6f86ef748af9410bb8847e372324cd7576dda.tar.gz
gentoo-2-90f6f86ef748af9410bb8847e372324cd7576dda.tar.bz2
gentoo-2-90f6f86ef748af9410bb8847e372324cd7576dda.zip
Fixed mandir, closing Bug #28551
Diffstat (limited to 'net-irc/ircii/ircii-20030709-r2.ebuild')
-rw-r--r--net-irc/ircii/ircii-20030709-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-irc/ircii/ircii-20030709-r2.ebuild b/net-irc/ircii/ircii-20030709-r2.ebuild
new file mode 100644
index 000000000000..0a989d0b1765
--- /dev/null
+++ b/net-irc/ircii/ircii-20030709-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20030709-r2.ebuild,v 1.1 2003/09/12 23:17:16 usata Exp $
+
+IUSE="ipv6"
+
+DESCRIPTION="ircII is an IRC and ICB client that runs under most UNIX platforms."
+SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2"
+HOMEPAGE="http://www.eterna.com.au/ircii/"
+
+DEPEND="sys-libs/ncurses
+ >=sys-apps/sed-4"
+
+RDEPEND="sys-libs/ncurses"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+
+ # `use_with socks socks5` <- isn't socks5 working?
+ econf `use_enable ipv6` || die
+ emake || die "make failed"
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+ prepalldocs
+ dodoc ChangeLog INSTALL NEWS README
+ dodoc doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}