summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-06-22 22:24:10 +0000
committerSven Wegener <swegener@gentoo.org>2004-06-22 22:24:10 +0000
commit646d4841d180a31e392e7ab5fefca3061139dd85 (patch)
treeb296603412d7f9749b3c14ee1527f86df9ee610f /net-irc/muh/muh-2.2_beta1.ebuild
parentmark stable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-646d4841d180a31e392e7ab5fefca3061139dd85.tar.gz
gentoo-2-646d4841d180a31e392e7ab5fefca3061139dd85.tar.bz2
gentoo-2-646d4841d180a31e392e7ab5fefca3061139dd85.zip
Version bump. Closes bug #54703. Added support for the ipv6 USE flag.
Diffstat (limited to 'net-irc/muh/muh-2.2_beta1.ebuild')
-rw-r--r--net-irc/muh/muh-2.2_beta1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-irc/muh/muh-2.2_beta1.ebuild b/net-irc/muh/muh-2.2_beta1.ebuild
new file mode 100644
index 000000000000..46e930eecfb7
--- /dev/null
+++ b/net-irc/muh/muh-2.2_beta1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/muh/muh-2.2_beta1.ebuild,v 1.1 2004/06/22 22:24:10 swegener Exp $
+
+MY_P=${P/_/}
+
+DESCRIPTION="Persistant IRC bouncer"
+HOMEPAGE="http://mind.riot.org/muh/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips"
+IUSE="ipv6"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You'll need to configure muh before running it."
+ einfo "Put your config in ~/.muh/muhrc"
+ einfo "A sample config is /usr/share/muhrc"
+ einfo "For more information, see the documentation."
+ einfo
+}