summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-23 17:27:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-23 17:27:49 +0000
commit538b5518331b4112a3ec6b74730eac897be8a8e2 (patch)
treed2e4f4727cc81148734264c25dc3603ff7d3fc2e /net-irc/weechat
parentFix compilation with newest pyqt. Per bug #352493 (diff)
downloadgentoo-2-538b5518331b4112a3ec6b74730eac897be8a8e2.tar.gz
gentoo-2-538b5518331b4112a3ec6b74730eac897be8a8e2.tar.bz2
gentoo-2-538b5518331b4112a3ec6b74730eac897be8a8e2.zip
Version bump. Update live ebuild. Per bug #352508.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/weechat')
-rw-r--r--net-irc/weechat/ChangeLog10
-rw-r--r--net-irc/weechat/weechat-0.3.4.ebuild86
-rw-r--r--net-irc/weechat/weechat-9999.ebuild36
3 files changed, 122 insertions, 10 deletions
diff --git a/net-irc/weechat/ChangeLog b/net-irc/weechat/ChangeLog
index d739645e8e42..1fdbf022cd40 100644
--- a/net-irc/weechat/ChangeLog
+++ b/net-irc/weechat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/weechat
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.80 2010/11/28 13:57:20 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.81 2011/01/23 17:27:49 scarabeus Exp $
+
+*weechat-0.3.4 (23 Jan 2011)
+
+ 23 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org> +weechat-0.3.4.ebuild,
+ weechat-9999.ebuild:
+ Version bump. Update live ebuild. Per bug #352508.
28 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> -weechat-0.2.6.1.ebuild:
old
diff --git a/net-irc/weechat/weechat-0.3.4.ebuild b/net-irc/weechat/weechat-0.3.4.ebuild
new file mode 100644
index 000000000000..79d99e06acca
--- /dev/null
+++ b/net-irc/weechat/weechat-0.3.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.4.ebuild,v 1.1 2011/01/23 17:27:49 scarabeus Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+
+EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git"
+inherit python multilib cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Portable and multi-interface IRC client."
+HOMEPAGE="http://weechat.org/"
+[[ ${PV} == "9999" ]] || SRC_URI="http://${PN}.org/files/src/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+fi
+
+NETWORKS="jabber +irc"
+PLUGINS="+alias +charset +fifo +logger +relay +rmodifier +scripts +spell +xfer"
+INTERFACES="+ncurses gtk"
+SCRIPT_LANGS="lua +perl +python ruby tcl"
+IUSE="${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS} +crypt doc nls +ssl"
+
+RDEPEND="
+ charset? ( virtual/libiconv )
+ gtk? ( x11-libs/gtk+:2 )
+ jabber? ( dev-libs/iksemel )
+ lua? ( dev-lang/lua[deprecated] )
+ ncurses? ( sys-libs/ncurses )
+ perl? ( dev-lang/perl )
+ ruby? ( dev-lang/ruby )
+ ssl? ( net-libs/gnutls )
+ spell? ( app-text/aspell )
+ tcl? ( >=dev-lang/tcl-8.4.15 )
+"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.15 )
+"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # fix libdir placement
+ sed -i \
+ -e "s:lib/:$(get_libdir)/:g" \
+ -e "s:lib\":$(get_libdir)\":g" \
+ CMakeLists.txt || die "sed failed"
+}
+
+# alias, rmodifier, xfer
+src_configure() {
+ mycmakeargs=(
+ "-DENABLE_LARGEFILE=ON"
+ "-DENABLE_DEMO=OFF"
+ $(cmake-utils_use_enable ncurses)
+ $(cmake-utils_use_enable gtk)
+ $(cmake-utils_use_enable nls)
+ $(cmake-utils_use_enable crypt GCRYPT)
+ $(cmake-utils_use_enable spell ASPELL)
+ $(cmake-utils_use_enable charset)
+ $(cmake-utils_use_enable fifo)
+ $(cmake-utils_use_enable irc)
+ $(cmake-utils_use_enable logger)
+ $(cmake-utils_use_enable relay)
+ $(cmake-utils_use_enable scripts)
+ $(cmake-utils_use_enable perl)
+ $(cmake-utils_use_enable python)
+ $(cmake-utils_use_enable ruby)
+ $(cmake-utils_use_enable lua)
+ $(cmake-utils_use_enable tcl)
+ $(cmake-utils_use_enable doc)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index a92bc4cc6010..1c9fc8cd7fa1 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -1,17 +1,26 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.2 2010/12/13 22:35:41 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.3 2011/01/23 17:27:49 scarabeus Exp $
-EAPI=2
-inherit cmake-utils git
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+
+EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git"
+inherit python multilib cmake-utils ${GIT_ECLASS}
DESCRIPTION="Portable and multi-interface IRC client."
HOMEPAGE="http://weechat.org/"
-EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
+[[ ${PV} == "9999" ]] || SRC_URI="http://${PN}.org/files/src/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+fi
NETWORKS="jabber +irc"
PLUGINS="+alias +charset +fifo +logger +relay +rmodifier +scripts +spell +xfer"
@@ -26,7 +35,6 @@ RDEPEND="
lua? ( dev-lang/lua[deprecated] )
ncurses? ( sys-libs/ncurses )
perl? ( dev-lang/perl )
- python? ( virtual/python )
ruby? ( dev-lang/ruby )
ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )
@@ -36,7 +44,19 @@ DEPEND="${RDEPEND}
nls? ( >=sys-devel/gettext-0.15 )
"
-DOCS="AUTHORS ChangeLog NEWS README "
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # fix libdir placement
+ sed -i \
+ -e "s:lib/:$(get_libdir)/:g" \
+ -e "s:lib\":$(get_libdir)\":g" \
+ CMakeLists.txt || die "sed failed"
+}
# alias, rmodifier, xfer
src_configure() {