summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-11-03 21:36:10 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-11-03 21:36:10 +0000
commit2087359543c2f691ff0f55689add93ec8141a402 (patch)
treef7c0da3ba2aea5746ce7d9a5be772afb49bdb780 /net-irc/xchat-gnome
parentVersion bump, dropping keywords as status wrt other packages is untested (diff)
downloadgentoo-2-2087359543c2f691ff0f55689add93ec8141a402.tar.gz
gentoo-2-2087359543c2f691ff0f55689add93ec8141a402.tar.bz2
gentoo-2-2087359543c2f691ff0f55689add93ec8141a402.zip
Version bump
(Portage version: 2.1.3.17)
Diffstat (limited to 'net-irc/xchat-gnome')
-rw-r--r--net-irc/xchat-gnome/ChangeLog7
-rw-r--r--net-irc/xchat-gnome/files/digest-xchat-gnome-0.183
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.18.ebuild82
3 files changed, 91 insertions, 1 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index fde222a7fe76..d226728cb677 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.30 2007/04/04 19:25:52 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.31 2007/11/03 21:36:10 jokey Exp $
+
+*xchat-gnome-0.18 (03 Nov 2007)
+
+ 03 Nov 2007; Markus Ullmann <jokey@gentoo.org> +xchat-gnome-0.18.ebuild:
+ Version bump
*xchat-gnome-0.17 (04 Apr 2007)
diff --git a/net-irc/xchat-gnome/files/digest-xchat-gnome-0.18 b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.18
new file mode 100644
index 000000000000..6cfde341e65a
--- /dev/null
+++ b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.18
@@ -0,0 +1,3 @@
+MD5 4976cd34a0e9115c800b5d317e121182 xchat-gnome-0.18.tar.bz2 1540748
+RMD160 5f8aa69e04f8ab540abd83ebb71edf2835f0aba2 xchat-gnome-0.18.tar.bz2 1540748
+SHA256 86e5bb1b9a073c04be1a38ead51284f04268183cfc7cf711cb80543d055e1372 xchat-gnome-0.18.tar.bz2 1540748
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.18.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.18.ebuild
new file mode 100644
index 000000000000..be0c52850f00
--- /dev/null
+++ b/net-irc/xchat-gnome/xchat-gnome-0.18.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.18.ebuild,v 1.1 2007/11/03 21:36:10 jokey Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
+HOMEPAGE="http://xchat-gnome.navi.cx/"
+SRC_URI="http://releases.navi.cx/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="perl tcl python ssl mmx ipv6 nls dbus libnotify spell"
+
+RDEPEND=">=dev-libs/glib-2.12.0
+ >=gnome-base/libgnome-2.16.0
+ >=gnome-base/gconf-2.8.0
+ >=gnome-base/libgnomeui-2.16.0
+ >=gnome-base/libglade-2.3.0
+ >=gnome-base/gnome-vfs-2.9.2
+ >=x11-libs/gtk+-2.10.0
+ spell? ( app-text/gtkspell )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcl? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.60 )
+ >=x11-libs/libsexy-0.1.11
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-util/pkgconfig-0.7
+ >=app-text/gnome-doc-utils-0.3.2
+ nls? ( sys-devel/gettext )"
+
+# gnome-base/gnome-common is temporarily needed for re-creating configure
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/0.17-libnotify-configure.patch
+ epatch "${FILESDIR}"/0.17-segfault-fix.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-gnomefe \
+ --enable-shm \
+ --disable-schemas-install \
+ --disable-scrollkeeper \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libnotify) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ USE_DESTDIR="1" gnome2_src_install || die "gnome2_src_install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat-gnome
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_scrollkeeper_update
+}