summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-07-20 09:32:00 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-07-20 09:32:00 +0000
commit9db65f5cb4696ebd590e033f34dd1e59fda9553f (patch)
tree5e59ec428b41cb9bb61ddc5ab32aadd56ce3f1e3 /net-irc/xchat-gnome
parentversion bump (diff)
downloadgentoo-2-9db65f5cb4696ebd590e033f34dd1e59fda9553f.tar.gz
gentoo-2-9db65f5cb4696ebd590e033f34dd1e59fda9553f.tar.bz2
gentoo-2-9db65f5cb4696ebd590e033f34dd1e59fda9553f.zip
Version bump.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'net-irc/xchat-gnome')
-rw-r--r--net-irc/xchat-gnome/ChangeLog7
-rw-r--r--net-irc/xchat-gnome/files/digest-xchat-gnome-0.133
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.13.ebuild82
3 files changed, 91 insertions, 1 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index e32e16f665ff..dd19e806aa5e 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.22 2006/06/30 13:12:59 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.23 2006/07/20 09:32:00 chainsaw Exp $
+
+*xchat-gnome-0.13 (20 Jul 2006)
+
+ 20 Jul 2006; Tony Vroon <chainsaw@gentoo.org> +xchat-gnome-0.13.ebuild:
+ Version bump.
*xchat-gnome-0.12 (30 Jun 2006)
diff --git a/net-irc/xchat-gnome/files/digest-xchat-gnome-0.13 b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.13
new file mode 100644
index 000000000000..2fd0560d666d
--- /dev/null
+++ b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.13
@@ -0,0 +1,3 @@
+MD5 5614773724afa0c2e617615722e10091 xchat-gnome-0.13.tar.bz2 1495400
+RMD160 8dd134e8a10cb58e66744282504022b7013208e8 xchat-gnome-0.13.tar.bz2 1495400
+SHA256 00ac36202b1b13f1022a33ab5a28fc0c5a75475a3ea4d512e46dc9c1007de2f9 xchat-gnome-0.13.tar.bz2 1495400
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.13.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.13.ebuild
new file mode 100644
index 000000000000..30da4da399b8
--- /dev/null
+++ b/net-irc/xchat-gnome/xchat-gnome-0.13.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.13.ebuild,v 1.1 2006/07/20 09:32:00 chainsaw Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
+HOMEPAGE="http://xchat-gnome.navi.cx/"
+SRC_URI="http://releases.navi.cx/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl tcltk python ssl mmx ipv6 nls dbus libsexy libnotify spell"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=gnome-base/libgnome-2.13
+ >=gnome-base/gconf-2.8.0
+ >=gnome-base/libgnomeui-2.6.0
+ >=gnome-base/libglade-2.3.0
+ >=gnome-base/gnome-vfs-2.9.2
+ >=x11-libs/gtk+-2.8.0
+ spell? ( app-text/gtkspell )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.35 )
+ libsexy? ( >=x11-libs/libsexy-0.1.7 )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-util/pkgconfig-0.7
+ >=app-text/gnome-doc-utils-0.3.2
+ nls? ( sys-devel/gettext )"
+
+# gnome-base/gnome-common is temporarily needed for re-creating configure
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.11-libnotify-libsexy-configure.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-gnomefe \
+ --enable-shm \
+ --disable-schemas-install \
+ --disable-scrollkeeper \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcltk tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libsexy) \
+ $(use_enable libnotify) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ USE_DESTDIR="1" gnome2_src_install || die "gnome2_src_install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat-gnome
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_scrollkeeper_update
+}