summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-04 00:22:27 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-04 00:22:27 +0000
commitcb96d54146b9eb3329fc963c7bda7cb6fcd8120e (patch)
treeef85feb4cbf04eee855226aab116bdc165c3ff79 /net-irc/xchat
parentCloses #10090 and #13052 (diff)
downloadgentoo-2-cb96d54146b9eb3329fc963c7bda7cb6fcd8120e.tar.gz
gentoo-2-cb96d54146b9eb3329fc963c7bda7cb6fcd8120e.tar.bz2
gentoo-2-cb96d54146b9eb3329fc963c7bda7cb6fcd8120e.zip
New version
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/digest-xchat-1.9.81
-rw-r--r--net-irc/xchat/xchat-1.9.8.ebuild85
3 files changed, 92 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 2c94f3da9ef1..9ae0203b8e78 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.36 2002/12/16 23:15:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.37 2003/01/04 00:22:27 foser Exp $
+
+*xchat-1.9.8 (03 Jan 2003)
+
+ 03 Dec 2002; foser <foser@gentoo.org> xchat-1.9.8.ebuild :
+ New version, fixed deps. Removed nls related stuff, pango is default now and should take care of it
16 Dec 2002; Aron Griffis <agriffis@gentoo.org> xchat-1.8.10-r1.ebuild xchat-1.9.7.ebuild:
Added ~alpha to KEYWORDS in both stable and devel versions
diff --git a/net-irc/xchat/files/digest-xchat-1.9.8 b/net-irc/xchat/files/digest-xchat-1.9.8
new file mode 100644
index 000000000000..ee2e444e6452
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.9.8
@@ -0,0 +1 @@
+MD5 f7df856c9fec9d9776738129dec6c063 xchat-1.9.8.tar.bz2 853536
diff --git a/net-irc/xchat/xchat-1.9.8.ebuild b/net-irc/xchat/xchat-1.9.8.ebuild
new file mode 100644
index 000000000000..4ff8b22f39fb
--- /dev/null
+++ b/net-irc/xchat/xchat-1.9.8.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.9.8.ebuild,v 1.1 2003/01/04 00:22:27 foser Exp $
+
+inherit eutils
+
+IUSE="perl gnome ssl gtk python mmx ipv6 nls kde"
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.9/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/gtk+-2.0.3
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=gnome-base/libgnome-2.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_compile() {
+ local myopts myflags
+
+ if [ ! `use perl` ] ; then
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt"
+
+ # use gnome \
+ # && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ # || myopts="${myopts} --disable-gnome"
+ fi
+
+ use gtk \
+ && myopts="${myopts} --enable-gtkfe" \
+ || myopts="${myopts} --disable-gtkfe"
+ use ssl \
+ && myopts="${myopts} --enable-openssl" \
+ || myopts="${myopts} --disable-openssl"
+ use perl \
+ && myopts="${myopts} --enable-perl" \
+ || myopts="${myopts} --disable-perl"
+ use python \
+ && myopts="${myopts} --enable-python" \
+ || myopts="${myopts} --disable-python"
+ use nls \
+ && myopts="${myopts} --enable-nls" \
+ || myopts="${myopts} --disable-nls"
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6" \
+ || myopts="${myopts} --disable-ipv6"
+
+# pango renderer standard now
+# [ -n "${DISABLE_XFT}" ] && myopts="${myopts} --disable-xft"
+
+ econf \
+ --program-suffix=-2 \
+ ${myopts} || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
+
+ einstall install || die "Install failed"
+
+ dodoc AUTHORS COPYING ChangeLog README
+}
+
+#pkg_postinst() {
+# einfo "If you want X-Chat to correctly display Hebrew (bidi) do "
+# einfo "'export DISABLE_XFT=1' and re-emerge xchat"
+#}