summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-03 22:17:13 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-03 22:17:13 +0000
commit58678eee6187e402e4a98f11675d280313b6c933 (patch)
tree04960dbe21c599b670aa1dc5fe08c9bbc6a22651 /net-irc
parentinitial import #85971 (diff)
downloadgentoo-2-58678eee6187e402e4a98f11675d280313b6c933.tar.gz
gentoo-2-58678eee6187e402e4a98f11675d280313b6c933.tar.bz2
gentoo-2-58678eee6187e402e4a98f11675d280313b6c933.zip
Revision bump. Added support for the curl USE flag that allows network-based configuration includes. Closes bug #86307.
(Portage version: 2.0.51.21)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/unrealircd/ChangeLog9
-rw-r--r--net-irc/unrealircd/files/digest-unrealircd-3.2.3-r11
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.3-r1.ebuild133
3 files changed, 142 insertions, 1 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index 25e15daed4b7..41a03cccae02 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/unrealircd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.32 2005/05/01 17:28:57 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.33 2005/05/03 22:17:13 swegener Exp $
+
+*unrealircd-3.2.3-r1 (03 May 2005)
+
+ 03 May 2005; Sven Wegener <swegener@gentoo.org>
+ +unrealircd-3.2.3-r1.ebuild:
+ Revision bump. Added support for the curl USE flag that allows
+ network-based configuration includes. Closes bug #86307.
01 May 2005; Michael Hanselmann <hansmi@gentoo.org>
unrealircd-3.2.3.ebuild:
diff --git a/net-irc/unrealircd/files/digest-unrealircd-3.2.3-r1 b/net-irc/unrealircd/files/digest-unrealircd-3.2.3-r1
new file mode 100644
index 000000000000..f4fd824a986c
--- /dev/null
+++ b/net-irc/unrealircd/files/digest-unrealircd-3.2.3-r1
@@ -0,0 +1 @@
+MD5 b41f09c5999c67dc8e33db777b7397cf Unreal3.2.3.tar.gz 1881275
diff --git a/net-irc/unrealircd/unrealircd-3.2.3-r1.ebuild b/net-irc/unrealircd/unrealircd-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..c5f93a3e157e
--- /dev/null
+++ b/net-irc/unrealircd/unrealircd-3.2.3-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.3-r1.ebuild,v 1.1 2005/05/03 22:17:13 swegener Exp $
+
+inherit eutils ssl-cert versionator
+
+MY_P=Unreal${PV}
+
+DESCRIPTION="aimed to be an advanced (not easy) IRCd"
+HOMEPAGE="http://www.unrealircd.com/"
+SRC_URI="http://unrealircd.funny4chat.de/downloads/${MY_P}.tar.gz
+ http://www1.dnwt.net/unreal/${MY_P}.tar.gz
+ http://www.randumb.org/~unreal/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="hub ipv6 ssl zlib curl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/Unreal$(get_version_component_range 1-2)"
+
+pkg_setup() {
+ if use curl && ! built_with_use net-misc/curl ares
+ then
+ eerror "You need net-misc/curl compiled with the ares USE flag to be able to use"
+ eerror "net-irc/unrealircd with the curl USE flag."
+ die "need net-misc/curl with ares support"
+ fi
+
+ enewuser unrealircd
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:ircd\.pid:/var/run/unrealircd/ircd.pid:" \
+ -e "s:ircd\.log:/var/log/unrealircd/ircd.log:" \
+ -e "s:debug\.log:/var/log/unrealircd/debug.log:" \
+ -e "s:ircd\.tune:/var/lib/unrealircd/ircd.tune:" \
+ include/config.h
+}
+
+src_compile() {
+ local myconf=""
+ use curl && myconf="${myconf} --enable-libcurl=/usr"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ use zlib && myconf="${myconf} --enable-ziplinks"
+ use hub && myconf="${myconf} --enable-hub"
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ econf \
+ --with-listen=5 \
+ --with-dpath=${D}/etc/unrealircd \
+ --with-spath=/usr/bin/unrealircd \
+ --with-nick-history=2000 \
+ --with-sendq=3000000 \
+ --with-bufferpool=18 \
+ --with-hostname=$(hostname -f) \
+ --with-permissions=0600 \
+ --with-fd-setsize=1024 \
+ --enable-dynamic-linking \
+ --enable-prefixaq \
+ ${myconf} \
+ || die "econf failed"
+
+ sed -i \
+ -e "s:${D}::" \
+ include/setup.h \
+ ircdcron/ircdchk
+
+ emake IRCDDIR=/etc/unrealircd || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/{lib,log,run}/unrealircd || die "keepdir failed"
+
+ newbin src/ircd unrealircd || die "newbin failed"
+
+ exeinto /usr/lib/unrealircd/modules
+ doexe src/modules/*.so || die "doexe failed"
+
+ dodir /etc/unrealircd || die "dodir failed"
+ dosym /var/lib/unrealircd /etc/unrealircd/tmp || die "dosym failed"
+
+ insinto /etc/unrealircd
+ doins {badwords.*,help,spamfilter,dccallow}.conf || die "doins failed"
+ newins doc/example.conf unrealircd.conf || die "newins failed"
+
+ use ssl \
+ && docert server.cert \
+ && dosym server.cert.key /etc/unrealircd/server.key.pem
+
+ insinto /etc/unrealircd/aliases
+ doins aliases/*.conf || die "doins failed"
+ insinto /etc/unrealircd/networks
+ doins networks/*.network || die "doins failed"
+
+ sed -i \
+ -e s:src/modules:/usr/lib/unrealircd/modules: \
+ -e s:ircd\\.log:/var/log/unrealircd/ircd.log: \
+ ${D}/etc/unrealircd/unrealircd.conf
+
+ dodoc \
+ Changes Donation Unreal.nfo networks/makenet \
+ ircdcron/{ircd.cron,ircdchk} \
+ || die "dodoc failed"
+ dohtml doc/*.html || die "dohtml failed"
+
+ newinitd ${FILESDIR}/unrealircd.rc unrealircd || die "newinitd failed"
+ newconfd ${FILESDIR}/unrealircd.confd unrealircd || die "newconfd failed"
+
+ fperms 700 /etc/unrealircd
+ chown -R unrealircd ${D}/{etc,var/{lib,log,run}}/unrealircd
+}
+
+pkg_postins() {
+ einfo
+ einfo "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
+ einfo
+ einfo "You can find example cron scripts here:"
+ einfo " /usr/share/doc/${PF}/ircd.cron.gz"
+ einfo " /usr/share/doc/${PF}/ircdchk.gz"
+ einfo
+ einfo "You can also use /etc/init.d/unrealircd to start at boot"
+ einfo
+}