summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-30 04:03:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-30 04:03:30 +0000
commita73329776cd958f96f395a8fbd26115758a323bf (patch)
treed690ae54c8a5a8fdc43ca84b759836f237fb2bf5 /net-irc
parentfixed, all ebuilds use the correct initd bug 507628 (diff)
downloadgentoo-2-a73329776cd958f96f395a8fbd26115758a323bf.tar.gz
gentoo-2-a73329776cd958f96f395a8fbd26115758a323bf.tar.bz2
gentoo-2-a73329776cd958f96f395a8fbd26115758a323bf.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irker/ChangeLog7
-rw-r--r--net-irc/irker/irker-2.11.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-irc/irker/ChangeLog b/net-irc/irker/ChangeLog
index eeeaf545afb6..9157a023aff1 100644
--- a/net-irc/irker/ChangeLog
+++ b/net-irc/irker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/irker
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.15 2014/06/12 03:16:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.16 2014/06/30 04:03:30 patrick Exp $
+
+*irker-2.11 (30 Jun 2014)
+
+ 30 Jun 2014; Patrick Lauer <patrick@gentoo.org> +irker-2.11.ebuild:
+ Bump
*irker-2.9 (12 Jun 2014)
diff --git a/net-irc/irker/irker-2.11.ebuild b/net-irc/irker/irker-2.11.ebuild
new file mode 100644
index 000000000000..92c4d23cca0a
--- /dev/null
+++ b/net-irc/irker/irker-2.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/irker-2.11.ebuild,v 1.1 2014/06/30 04:03:30 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE="ssl"
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="Submission tools for IRC notifications"
+HOMEPAGE="http://www.catb.org/esr/irker/"
+SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto"
+
+src_prepare() {
+ # https://gitorious.org/irker/irker/merge_requests/25
+ epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
+
+ epatch "${FILESDIR}/2.7-irkerhook-Remove-file-listing.patch"
+
+ # Prefix support
+ sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_doscript "${ED}/usr/bin/irkerd"
+ # Not installed with the default Makefile
+ python_doscript irk irkerhook.py
+
+ newinitd "${FILESDIR}/irkerd.initd" irkerd
+ newconfd "${FILESDIR}/irkerd.confd" irkerd
+
+ dodoc NEWS README hacking.txt security.txt
+ dohtml irkerd.html irkerhook.html
+
+ docinto examples
+ dodoc filter-example.py filter-test.py
+}