summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-07-05 07:40:15 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-07-05 07:40:15 +0000
commitd67442087d420aeda677d5767367203407f60ed9 (patch)
tree429d49a20ebbdea312048408ea9f64afaaee7967 /net-irc
parentStable on ppc. (diff)
downloadgentoo-2-d67442087d420aeda677d5767367203407f60ed9.tar.gz
gentoo-2-d67442087d420aeda677d5767367203407f60ed9.tar.bz2
gentoo-2-d67442087d420aeda677d5767367203407f60ed9.zip
Version bump wrt bug #136124
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog9
-rw-r--r--net-irc/xchat/files/digest-xchat-2.6.46
-rw-r--r--net-irc/xchat/files/xchat-2.6.4-fix-cursor.patch19
-rw-r--r--net-irc/xchat/files/xchat-2.6.4-fix-proxy.patch17
-rw-r--r--net-irc/xchat/xchat-2.6.4.ebuild91
5 files changed, 141 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 41e028df03e6..fe0e7e130b37 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.199 2006/06/10 03:06:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.200 2006/07/05 07:40:15 jokey Exp $
+
+*xchat-2.6.4 (05 Jul 2006)
+
+ 05 Jul 2006; Markus Ullmann <jokey@gentoo.org>
+ +files/xchat-2.6.4-fix-cursor.patch, +files/xchat-2.6.4-fix-proxy.patch,
+ +xchat-2.6.4.ebuild:
+ Version bump wrt bug #136124
10 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org> xchat-2.4.3.ebuild,
xchat-2.4.5.ebuild, xchat-2.4.5-r1.ebuild, xchat-2.6.1.ebuild,
diff --git a/net-irc/xchat/files/digest-xchat-2.6.4 b/net-irc/xchat/files/digest-xchat-2.6.4
new file mode 100644
index 000000000000..0563907073f0
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.6.4
@@ -0,0 +1,6 @@
+MD5 358f6cec635eab49fca99d324f76e065 xchat-2.6.4.tar.bz2 1083938
+RMD160 998069aa49e7b26dd98d53173e9dc67f947f95a2 xchat-2.6.4.tar.bz2 1083938
+SHA256 76e67fc03d3318d6159d1f22408c607bfa72e5e7687ddcb8969c95a01bcf4222 xchat-2.6.4.tar.bz2 1083938
+MD5 c0220456a4df8ee54ae02e7704a6e024 xchat-dccserver-0.6.patch.bz2 49320
+RMD160 24cc9bd414b1dd0e7e38ba9a49d12257aeb89e68 xchat-dccserver-0.6.patch.bz2 49320
+SHA256 90a49a8d810380020c507c1a36f02e7d972cf92b5e4802dcd5cc518cba29078f xchat-dccserver-0.6.patch.bz2 49320
diff --git a/net-irc/xchat/files/xchat-2.6.4-fix-cursor.patch b/net-irc/xchat/files/xchat-2.6.4-fix-cursor.patch
new file mode 100644
index 000000000000..342ab77869e5
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.6.4-fix-cursor.patch
@@ -0,0 +1,19 @@
+#
+# Fixes the invisible cursor color when using GTKSpell and a black
+# input box (when "Use the text box font & colors" is ON).
+#
+diff -u -r1.66 fe-gtk.c
+--- xchat-2.6.4/src/fe-gtk/fe-gtk.c 7 Jun 2006 06:16:51 -0000 1.66
++++ xchat-2.6.4p1/src/fe-gtk/fe-gtk.c 12 Jun 2006 03:13:24 -0000
+@@ -225,7 +225,11 @@
+ const char cursor_color_rc[] =
+ "style \"xc-ib-st\""
+ "{"
++#ifdef USE_GTKSPELL
++ "GtkTextView::cursor-color=\"#%02x%02x%02x\""
++#else
+ "GtkEntry::cursor-color=\"#%02x%02x%02x\""
++#endif
+ "}"
+ "widget \"*.xchat-inputbox\" style : application \"xc-ib-st\"";
+
diff --git a/net-irc/xchat/files/xchat-2.6.4-fix-proxy.patch b/net-irc/xchat/files/xchat-2.6.4-fix-proxy.patch
new file mode 100644
index 000000000000..566464c35003
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.6.4-fix-proxy.patch
@@ -0,0 +1,17 @@
+#
+# Fix proxy
+#
+diff -u -r1.71 server.c
+--- xchat-2.6.4/src/common/server.c 29 May 2006 06:53:25 -0000 1.71
++++ xchat-2.6.4p1/src/common/server.c 8 Jun 2006 15:22:07 -0000
+@@ -1534,7 +1534,10 @@
+ if (!serv->dont_use_proxy && (prefs.proxy_type == 5))
+ error = net_connect (ns_server, serv->proxy_sok4, serv->proxy_sok6, &psok);
+ else
++ {
+ error = net_connect (ns_server, serv->sok4, serv->sok6, &sok);
++ psok = sok;
++ }
+
+ if (error != 0)
+ {
diff --git a/net-irc/xchat/xchat-2.6.4.ebuild b/net-irc/xchat/xchat-2.6.4.ebuild
new file mode 100644
index 000000000000..58e8041f4d6a
--- /dev/null
+++ b/net-irc/xchat/xchat-2.6.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.4.ebuild,v 1.1 2006/07/05 07:40:15 jokey Exp $
+
+inherit eutils versionator gnome2
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-dccserver-0.6.patch.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ppc64 ~sparc ~x86"
+IUSE="perl dbus tcltk python ssl mmx ipv6 nls spell xchattext xchatnogtk xchatdccserver"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ !xchatnogtk? ( >=x11-libs/gtk+-2.6.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( >=dev-lang/python-2.2 )
+ tcltk? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.35 )
+ spell? ( app-text/gtkspell )
+ !<net-irc/xchat-gnome-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-fix-cursor.patch
+ epatch "${FILESDIR}"/${P}-fix-proxy.patch
+
+ use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+}
+
+src_compile() {
+ # Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+ if [ ${ARCH} = "sparc" ] ; then
+ replace-flags "-O[3-9]" "-O2"
+ fi
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcltk tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable spell) \
+ $(use_enable xchattext textfe) \
+ $(use_enable !xchatnogtk gtkfe) \
+ --program-suffix=-2 \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ sed -i \
+ -e "s:^Exec=xchat$:Exec=xchat-2:" \
+ -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
+ xchat.desktop
+
+ USE_DESTDIR=1 gnome2_src_install || die "make install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+}