summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-09-13 14:43:41 +0000
committerMichał Górny <mgorny@gentoo.org>2014-09-13 14:43:41 +0000
commit8c479daf1cb11dbe73630b5c64bb912a11e662c6 (patch)
treef40a28d86d863cad3958f49c24d9ce0ae33a3712 /net-libs/ccrtp
parentChanging init script to "use logger" instead of "need logger" - fixing bug #4... (diff)
downloadgentoo-2-8c479daf1cb11dbe73630b5c64bb912a11e662c6.tar.gz
gentoo-2-8c479daf1cb11dbe73630b5c64bb912a11e662c6.tar.bz2
gentoo-2-8c479daf1cb11dbe73630b5c64bb912a11e662c6.zip
Minor version bump. Set subslot to match SONAME.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs/ccrtp')
-rw-r--r--net-libs/ccrtp/ChangeLog7
-rw-r--r--net-libs/ccrtp/ccrtp-2.0.9.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-libs/ccrtp/ChangeLog b/net-libs/ccrtp/ChangeLog
index 5a67c84d523a..0bc99f3d88e8 100644
--- a/net-libs/ccrtp/ChangeLog
+++ b/net-libs/ccrtp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ccrtp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ChangeLog,v 1.32 2014/03/01 22:13:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ChangeLog,v 1.33 2014/09/13 14:43:41 mgorny Exp $
+
+*ccrtp-2.0.9 (13 Sep 2014)
+
+ 13 Sep 2014; Michał Górny <mgorny@gentoo.org> +ccrtp-2.0.9.ebuild:
+ Minor version bump. Set subslot to match SONAME.
01 Mar 2014; Michał Górny <mgorny@gentoo.org> ccrtp-2.0.5.ebuild:
Update libgcrypt dep to use slot :0.
diff --git a/net-libs/ccrtp/ccrtp-2.0.9.ebuild b/net-libs/ccrtp/ccrtp-2.0.9.ebuild
new file mode 100644
index 000000000000..17003f7dc05a
--- /dev/null
+++ b/net-libs/ccrtp/ccrtp-2.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ccrtp-2.0.9.ebuild,v 1.1 2014/09/13 14:43:41 mgorny Exp $
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
+HOMEPAGE="http://www.gnu.org/software/ccrtp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="doc"
+SLOT="0/2"
+
+RDEPEND=">=dev-cpp/commoncpp2-1.3.0:0=
+ dev-libs/libgcrypt:0=
+ >=dev-libs/ucommon-5.0.0:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dohtml -r doc/html/*
+}
+
+pkg_postinst() {
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
+ fi
+}