summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-01-11 07:58:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-01-11 07:58:02 +0000
commit238f7e5a0bb4718eee926e10094309158c2fb6bb (patch)
tree0c8078ab1ef85a17e40eac6e13c5407c7e0d8fa4 /net-libs/daq
parentVersion bump. This is the first release including systemd-journald for logging. (diff)
downloadgentoo-2-238f7e5a0bb4718eee926e10094309158c2fb6bb.tar.gz
gentoo-2-238f7e5a0bb4718eee926e10094309158c2fb6bb.tar.bz2
gentoo-2-238f7e5a0bb4718eee926e10094309158c2fb6bb.zip
Bump
(Portage version: 2.2.0_alpha83/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/daq')
-rw-r--r--net-libs/daq/ChangeLog9
-rw-r--r--net-libs/daq/daq-0.6.2.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/net-libs/daq/ChangeLog b/net-libs/daq/ChangeLog
index f765fe795e15..8161605c3c1b 100644
--- a/net-libs/daq/ChangeLog
+++ b/net-libs/daq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/daq
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.13 2011/09/22 17:45:57 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.14 2012/01/11 07:58:02 patrick Exp $
+
+*daq-0.6.2 (11 Jan 2012)
+
+ 11 Jan 2012; Patrick Lauer <patrick@gentoo.org> +daq-0.6.2.ebuild:
+ Bump
*daq-0.6.1 (22 Sep 2011)
diff --git a/net-libs/daq/daq-0.6.2.ebuild b/net-libs/daq/daq-0.6.2.ebuild
new file mode 100644
index 000000000000..16ea11c0b0b4
--- /dev/null
+++ b/net-libs/daq/daq-0.6.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/daq-0.6.2.ebuild,v 1.1 2012/01/11 07:58:02 patrick Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/1339 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 +afpacket +dump +pcap nfq ipq static-libs"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )
+ nfq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )
+ ipq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ $(use_enable nfq nfq-module) \
+ $(use_enable ipq ipq-module) \
+ $(use_enable static-libs static) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README
+
+ # Remove unneeded .la files
+ for x in pcap afpacket dump nfq ipq; do
+ rm "${D}"usr/lib64/daq/daq_${x}.la
+ done
+ for y in libdaq libdaq_static libdaq_static_modules libsfbpf; do
+ rm "${D}"usr/lib64/${y}.la
+ done
+
+ # If not using static-libs don't install the static libraries
+ # This has been bugged upstream
+ if ! use static-libs; then
+ for z in libdaq_static libdaq_static_modules; do
+ rm "${D}"usr/lib64/${z}.a
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ einfo "calls to PCAP functions with an abstraction layer that facilitates"
+ einfo "operation on a variety of hardware and software interfaces without"
+ einfo "requiring changes to application such as Snort."
+ einfo
+ einfo "Please see the README file for DAQ for information about specific"
+ einfo "DAQ modules."
+}