summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-08-29 15:35:21 +0000
committerPacho Ramos <pacho@gentoo.org>2011-08-29 15:35:21 +0000
commit94976363c24f8674e9754103f2988d5da73f98e6 (patch)
tree48925fbe47b8e382c4486ee9356b79cdc094c168 /net-libs/farsight2/farsight2-0.0.29.ebuild
parentVersion Bump sci-chemistry/aria-2.3.2, 379153 (diff)
downloadgentoo-2-94976363c24f8674e9754103f2988d5da73f98e6.tar.gz
gentoo-2-94976363c24f8674e9754103f2988d5da73f98e6.tar.bz2
gentoo-2-94976363c24f8674e9754103f2988d5da73f98e6.zip
Version bump, remove old.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/farsight2/farsight2-0.0.29.ebuild')
-rw-r--r--net-libs/farsight2/farsight2-0.0.29.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/farsight2/farsight2-0.0.29.ebuild b/net-libs/farsight2/farsight2-0.0.29.ebuild
new file mode 100644
index 000000000000..23f5bb181083
--- /dev/null
+++ b/net-libs/farsight2/farsight2-0.0.29.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/farsight2-0.0.29.ebuild,v 1.1 2011/08/29 15:35:21 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Farsight2 is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE="http://farsight.freedesktop.org/"
+SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="python msn upnp"
+# IUSE="python test msn upnp"
+
+SLOT="0"
+
+# Tests often fail due to races
+RESTRICT="test"
+
+COMMONDEPEND=">=media-libs/gstreamer-0.10.33
+ >=media-libs/gst-plugins-base-0.10.33
+ >=dev-libs/glib-2.26:2
+ >=net-libs/libnice-0.1.0[gstreamer]
+ python? (
+ >=dev-python/pygobject-2.16:2
+ >=dev-python/gst-python-0.10.10 )
+ upnp? ( net-libs/gupnp-igd )"
+
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.17
+ >=media-libs/gst-plugins-bad-0.10.17
+ msn? ( >=media-plugins/gst-plugins-mimic-0.10.17 )"
+
+DEPEND="${COMMONDEPEND}
+ dev-util/pkgconfig"
+# test? ( media-plugins/gst-plugins-vorbis
+# media-plugins/gst-plugins-speex )
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ plugins="fsrtpconference,funnel,rtcpfilter,videoanyrate"
+ use msn && plugins="${plugins},fsmsnconference"
+ econf --disable-static \
+ $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README ChangeLog
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}
+
+src_test() {
+ # FIXME: do an out-of-tree build for tests if USE=-msn
+ if ! use msn; then
+ elog "Tests disabled without msn use flag"
+ return
+ fi
+
+ emake -j1 check
+}