summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-07-16 08:19:25 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-07-16 08:19:25 +0000
commite9b7bb89212b47aa09d1d553b4fb4e9195aff3e9 (patch)
treeb0f1836c6ad93250d0ca2a1af82c5d12927a7d7f /net-libs/farstream
parentVersion bump with various bugfixes. (diff)
downloadgentoo-2-e9b7bb89212b47aa09d1d553b4fb4e9195aff3e9.tar.gz
gentoo-2-e9b7bb89212b47aa09d1d553b4fb4e9195aff3e9.tar.bz2
gentoo-2-e9b7bb89212b47aa09d1d553b4fb4e9195aff3e9.zip
Fix building with gobject-introspection-1.33.x (bug #425096, thanks to Marek Bartosiewicz).
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/farstream')
-rw-r--r--net-libs/farstream/ChangeLog8
-rw-r--r--net-libs/farstream/farstream-0.1.2-r1.ebuild9
-rw-r--r--net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch132
3 files changed, 146 insertions, 3 deletions
diff --git a/net-libs/farstream/ChangeLog b/net-libs/farstream/ChangeLog
index 0f9d71b3b270..d694aaea0626 100644
--- a/net-libs/farstream/ChangeLog
+++ b/net-libs/farstream/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/farstream
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.3 2012/06/25 04:28:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.4 2012/07/16 08:19:25 tetromino Exp $
+
+ 16 Jul 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ farstream-0.1.2-r1.ebuild,
+ +files/farstream-0.1.2-introspection-tag-order.patch:
+ Fix building with gobject-introspection-1.33.x (bug #425096, thanks to Marek
+ Bartosiewicz).
*farstream-0.1.2-r1 (25 Jun 2012)
diff --git a/net-libs/farstream/farstream-0.1.2-r1.ebuild b/net-libs/farstream/farstream-0.1.2-r1.ebuild
index e56b5a7c7718..4e7c864d29fb 100644
--- a/net-libs/farstream/farstream-0.1.2-r1.ebuild
+++ b/net-libs/farstream/farstream-0.1.2-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.1.2-r1.ebuild,v 1.1 2012/06/25 04:28:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.1.2-r1.ebuild,v 1.2 2012/07/16 08:19:25 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="2"
-inherit python
+inherit eutils python
DESCRIPTION="Farsight2 is an audio/video conferencing framework specifically designed for Instant Messengers."
HOMEPAGE="http://farsight.freedesktop.org/"
@@ -47,6 +47,11 @@ pkg_setup() {
python_set_active_version 2
}
+src_prepare() {
+ # Fix building with gobject-introspection-1.33.x, bug #425096
+ epatch "${FILESDIR}/${P}-introspection-tag-order.patch"
+}
+
src_configure() {
plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
use msn && plugins="${plugins},fsmsnconference"
diff --git a/net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch b/net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch
new file mode 100644
index 000000000000..3283e1fd2990
--- /dev/null
+++ b/net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch
@@ -0,0 +1,132 @@
+From 39450457190675716c8e66700e35b05334a6a1a0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Olivier=20Cr=C3=AAte?= <olivier.crete@collabora.com>
+Date: Fri, 25 May 2012 17:06:59 -0400
+Subject: [PATCH] Gtk-doc tags belong after the description
+
+---
+ farstream/fs-session.c | 16 +++++++---------
+ farstream/fs-stream.c | 15 ++++++---------
+ 2 files changed, 13 insertions(+), 18 deletions(-)
+
+diff --git a/farstream/fs-session.c b/farstream/fs-session.c
+index 80794d1..abb1bc3 100644
+--- a/farstream/fs-session.c
++++ b/farstream/fs-session.c
+@@ -270,9 +270,6 @@ fs_session_class_init (FsSessionClass *klass)
+ /**
+ * FsSession:codec-preferences:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the current preferences list for the local codecs. It is
+ * set by the user to specify the codec options and priorities. The user may
+ * change its value with fs_session_set_codec_preferences() at any time
+@@ -283,6 +280,9 @@ fs_session_class_init (FsSessionClass *klass)
+ * or %FS_CODEC_ID_ANY. If the encoding name is "reserve-pt", then the
+ * payload type of the codec will be "reserved" and not be used by any
+ * dynamically assigned payload type.
++ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CODEC_PREFERENCES,
+@@ -296,9 +296,6 @@ fs_session_class_init (FsSessionClass *klass)
+ /**
+ * FsSession:codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of codecs used for this session. It will include the
+ * codecs and payload type used to receive media on this session. It will
+ * also include any configuration parameter that must be transmitted reliably
+@@ -317,6 +314,8 @@ fs_session_class_init (FsSessionClass *klass)
+ * It is a #GList of #FsCodec. User must free this codec list using
+ * fs_codec_list_destroy() when done.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CODECS,
+@@ -329,9 +328,6 @@ fs_session_class_init (FsSessionClass *klass)
+ /**
+ * FsSession:codecs-without-config:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the same list of codecs as #FsSession:codecs without
+ * the configuration information that describes the data sent. It is suitable
+ * for configurations where a list of codecs is shared by many senders.
+@@ -349,6 +345,8 @@ fs_session_class_init (FsSessionClass *klass)
+ * It is a #GList of #FsCodec. User must free this codec list using
+ * fs_codec_list_destroy() when done.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CODECS_WITHOUT_CONFIG,
+diff --git a/farstream/fs-stream.c b/farstream/fs-stream.c
+index b9e1320..110641d 100644
+--- a/farstream/fs-stream.c
++++ b/farstream/fs-stream.c
+@@ -176,13 +176,12 @@ fs_stream_class_init (FsStreamClass *klass)
+ /**
+ * FsStream:remote-codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of remote codecs for this stream. They must be set by the
+ * user as soon as they are known using fs_stream_set_remote_codecs()
+ * (generally through external signaling). It is a #GList of #FsCodec.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_REMOTE_CODECS,
+@@ -195,15 +194,14 @@ fs_stream_class_init (FsStreamClass *klass)
+ /**
+ * FsStream:negotiated-codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of negotiatied codecs, it is the same list as the list
+ * of #FsCodec from the parent #FsSession, except that the codec config data
+ * has been replaced with the data from the remote codecs for this stream.
+ * This is the list of #FsCodec used to receive data from this stream.
+ * It is a #GList of #FsCodec.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_NEGOTIATED_CODECS,
+@@ -216,9 +214,6 @@ fs_stream_class_init (FsStreamClass *klass)
+ /**
+ * FsStream:current-recv-codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of codecs that have been received by this stream.
+ * The user must free the list if fs_codec_list_destroy().
+ * The "farstream-recv-codecs-changed" message is send on the #GstBus
+@@ -228,6 +223,8 @@ fs_stream_class_init (FsStreamClass *klass)
+ * also be emitted if the pad already exists, but the source material that
+ * will come to it is different.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CURRENT_RECV_CODECS,
+--
+1.7.8.6
+