summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-08 09:11:45 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-08 09:11:45 +0000
commit1391c07b57d46d7dc8da90d731e1d8cce7de52e8 (patch)
treed74b0961bdb1efd30a21b65d194b09d56f3d8b36 /net-libs/glib-networking
parentia64 stable wrt bug #506042 (diff)
downloadgentoo-2-1391c07b57d46d7dc8da90d731e1d8cce7de52e8.tar.gz
gentoo-2-1391c07b57d46d7dc8da90d731e1d8cce7de52e8.tar.bz2
gentoo-2-1391c07b57d46d7dc8da90d731e1d8cce7de52e8.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/ChangeLog8
-rw-r--r--net-libs/glib-networking/glib-networking-2.40.1-r1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/net-libs/glib-networking/ChangeLog b/net-libs/glib-networking/ChangeLog
index 4d2dc6f65b26..87832b0595bd 100644
--- a/net-libs/glib-networking/ChangeLog
+++ b/net-libs/glib-networking/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/glib-networking
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/ChangeLog,v 1.82 2014/04/27 22:18:05 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/ChangeLog,v 1.83 2014/06/08 09:11:45 mgorny Exp $
+
+*glib-networking-2.40.1-r1 (08 Jun 2014)
+
+ 08 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +glib-networking-2.40.1-r1.ebuild:
+ Enable multilib support.
27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
glib-networking-2.40.1.ebuild:
diff --git a/net-libs/glib-networking/glib-networking-2.40.1-r1.ebuild b/net-libs/glib-networking/glib-networking-2.40.1-r1.ebuild
new file mode 100644
index 000000000000..bef7148b75bc
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.40.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/glib-networking-2.40.1-r1.ebuild,v 1.1 2014/06/08 09:11:45 mgorny Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="http://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="+gnome +libproxy smartcard +ssl test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.39.1:2[${MULTILIB_USEDEP}]
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+ libproxy? ( >=net-libs/libproxy-0.4.6-r3:=[${MULTILIB_USEDEP}] )
+ smartcard? (
+ >=app-crypt/p11-kit-0.8[${MULTILIB_USEDEP}]
+ >=net-libs/gnutls-2.12.8:=[pkcs11,${MULTILIB_USEDEP}] )
+ ssl? (
+ app-misc/ca-certificates
+ >=net-libs/gnutls-2.12.8:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( sys-apps/dbus[X] )
+"
+# eautoreconf needs >=sys-devel/autoconf-2.65:2.5
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-unittests.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ $(use_with gnome gnome-proxy) \
+ $(use_with libproxy) \
+ $(use_with smartcard pkcs11) \
+ $(use_with ssl gnutls)
+}
+
+multilib_src_test() {
+ # non-native tests fail if glib-networking is already installed.
+ # have no idea what's wrong. would appreciate some help.
+ multilib_is_native_abi || return 0
+
+ Xemake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}