summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-26 23:38:23 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-26 23:38:23 +0000
commit145c7c43c074d563fb8c3952404c05f00f9b8cd8 (patch)
tree2edbee02129233e4034ef1a53ae8806fb4ca9c59 /net-libs/gnutls/files
parentUse virtual/yacc instead of explicit bison dep. (diff)
downloadgentoo-2-145c7c43c074d563fb8c3952404c05f00f9b8cd8.tar.gz
gentoo-2-145c7c43c074d563fb8c3952404c05f00f9b8cd8.tar.bz2
gentoo-2-145c7c43c074d563fb8c3952404c05f00f9b8cd8.zip
Fix build with glibc-2.16 (bug #424988 by Christian Hagau) and link against the built libgnutls library instead of the system version (bug #436146 by Bartosz Brachaczek).
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gnutls/files')
-rw-r--r--net-libs/gnutls/files/gnutls-2.12.20-glibc-2.16.patch26
-rw-r--r--net-libs/gnutls/files/gnutls-2.12.20-libadd.patch36
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/gnutls/files/gnutls-2.12.20-glibc-2.16.patch b/net-libs/gnutls/files/gnutls-2.12.20-glibc-2.16.patch
new file mode 100644
index 000000000000..6b7f5453490c
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-2.12.20-glibc-2.16.patch
@@ -0,0 +1,26 @@
+--- gnutls-2.12.20/gl/stdio.in.h
++++ gnutls-2.12.20/gl/stdio.in.h
+@@ -714,8 +714,10 @@
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
++#ifdef HAVE_RAW_DECL_GETS
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
++#endif
+
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
+--- gnutls-2.12.20/lib/gl/stdio.in.h
++++ gnutls-2.12.20/lib/gl/stdio.in.h
+@@ -714,8 +714,10 @@
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
++#ifdef HAVE_RAW_DECL_GETS
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
++#endif
+
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
diff --git a/net-libs/gnutls/files/gnutls-2.12.20-libadd.patch b/net-libs/gnutls/files/gnutls-2.12.20-libadd.patch
new file mode 100644
index 000000000000..fe5f1964ddda
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-2.12.20-libadd.patch
@@ -0,0 +1,36 @@
+--- gnutls-2.12.20/libextra/Makefile.am
++++ gnutls-2.12.20/libextra/Makefile.am
+@@ -69,7 +69,7 @@
+ if ENABLE_MINITASN1
+ libgnutls_openssl_la_LIBADD += ../lib/minitasn1/libminitasn1.la
+ else
+-libgnutls_openssl_la_LDFLAGS += $(LTLIBTASN1)
++libgnutls_openssl_la_LIBADD += $(LTLIBTASN1)
+ endif
+
+ if HAVE_LD_OUTPUT_DEF
+@@ -89,8 +89,9 @@
+ libgnutls_extra_la_SOURCES += \
+ ext_inner_application.h ext_inner_application.c gnutls_ia.c
+
++cryptolib_ldadd =
+ if !ENABLE_NETTLE
+-libgnutls_extra_la_LIBADD += $(LTLIBGCRYPT)
++cryptolib_ldadd = $(LTLIBGCRYPT)
+ endif
+
+ # Rest
+@@ -104,11 +105,10 @@
+ DISTCLEANFILES += $(defexec_DATA)
+
+ libgnutls_extra_la_LDFLAGS += \
+- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
+- $(LZO_LIBS)
++ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+
+ libgnutls_extra_la_LIBADD += ../lib/gl/liblgnu.la gl/libxgnu.la \
+- ../lib/libgnutls.la
++ ../lib/libgnutls.la $(cryptolib_ldadd) $(LZO_LIBS)
+
+ if HAVE_LD_VERSION_SCRIPT
+ libgnutls_extra_la_LDFLAGS += \