summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-02 22:21:00 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-02 22:21:00 +0000
commitfcd611cf6feedd901db45975ac4234ba780ab490 (patch)
tree694b4f56b3d8c9921c3048a8fa3c8af05e5366d4 /net-libs/gnutls/gnutls-0.8.10.ebuild
parentinitial ebuild (diff)
downloadgentoo-2-fcd611cf6feedd901db45975ac4234ba780ab490.tar.gz
gentoo-2-fcd611cf6feedd901db45975ac4234ba780ab490.tar.bz2
gentoo-2-fcd611cf6feedd901db45975ac4234ba780ab490.zip
initial ebuild
Diffstat (limited to 'net-libs/gnutls/gnutls-0.8.10.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-0.8.10.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/gnutls/gnutls-0.8.10.ebuild b/net-libs/gnutls/gnutls-0.8.10.ebuild
new file mode 100644
index 000000000000..d5476a36659e
--- /dev/null
+++ b/net-libs/gnutls/gnutls-0.8.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-0.8.10.ebuild,v 1.1 2003/09/02 22:19:58 liquidx Exp $
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="ftp://ftp.gnutls.org/pub/gnutls/${P}.tar.gz"
+
+IUSE="zlib doc lzo"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/libgcrypt-1.1.12
+ <app-crypt/opencdk-0.5.0
+ >=dev-libs/libtasn1-0.2
+ zlib? ( >=sys-libs/zlib-1.1 )
+ lzo? ( >=dev-libs/lzo-1.08 )"
+
+src_unpack() {
+ unpack ${A}
+ # allow for custom optimisation levels
+ cd ${S}; sed -i -e "s:\(CFLAGS.*\)-O2:\1:" configure
+}
+
+src_compile() {
+ econf `use_with zlib` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING COPYING.LIB ChangeLog NEWS \
+ README THANKS doc/TODO
+
+ if [ "`use doc`" ] ; then
+ dodoc doc/README.autoconf doc/tex/gnutls.ps
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}