summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-13 01:06:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-13 01:06:06 +0000
commitdee882138be180d2206ad14bdcf2bdd65c887aff (patch)
tree55ce541f1ba0eb5aee2fdd9dd2a3179780af7b62 /net-libs/gnutls
parentVersion bump to latest snapshot. Beware that the new release is not compatibl... (diff)
downloadgentoo-2-dee882138be180d2206ad14bdcf2bdd65c887aff.tar.gz
gentoo-2-dee882138be180d2206ad14bdcf2bdd65c887aff.tar.bz2
gentoo-2-dee882138be180d2206ad14bdcf2bdd65c887aff.zip
Fix reading of memory (bug #281249).
(Portage version: 14014-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/ChangeLog8
-rw-r--r--net-libs/gnutls/files/gnutls-2.8.2-fix_reading_of_memory.patch26
-rw-r--r--net-libs/gnutls/gnutls-2.8.2-r1.ebuild99
3 files changed, 132 insertions, 1 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index 55b6e00f62c3..cfa32a8864c5 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.205 2009/08/10 18:50:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.206 2009/08/13 01:06:06 arfrever Exp $
+
+*gnutls-2.8.2-r1 (13 Aug 2009)
+
+ 13 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +gnutls-2.8.2-r1.ebuild, +files/gnutls-2.8.2-fix_reading_of_memory.patch:
+ Fix reading of memory (bug #281249).
*gnutls-2.8.2 (10 Aug 2009)
diff --git a/net-libs/gnutls/files/gnutls-2.8.2-fix_reading_of_memory.patch b/net-libs/gnutls/files/gnutls-2.8.2-fix_reading_of_memory.patch
new file mode 100644
index 000000000000..99bd1b76cbe6
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-2.8.2-fix_reading_of_memory.patch
@@ -0,0 +1,26 @@
+http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commitdiff;h=c12e7507562d5f168330acf1dd7db7cc2079cdf0
+
+--- lib/x509/common.c
++++ lib/x509/common.c
+@@ -181,7 +181,7 @@ _gnutls_x509_oid_data2string (const char *oid, void *value,
+ {
+ char str[MAX_STRING_LEN], tmpname[128];
+ const char *ANAME = NULL;
+- int CHOICE = -1, len = -1, result, i;
++ int CHOICE = -1, len = -1, result;
+ ASN1_TYPE tmpasn = ASN1_TYPE_EMPTY;
+ char asn1_err[ASN1_MAX_ERROR_DESCRIPTION_SIZE] = "";
+
+@@ -317,12 +317,6 @@ _gnutls_x509_oid_data2string (const char *oid, void *value,
+ }
+ }
+ }
+-
+- /* Convert null char in the name to '?'
+- * to protect applications */
+- for (i=0;i<*res_size;i++) {
+- if (res[i] == 0) res[i]='?';
+- }
+
+ return 0;
+ }
diff --git a/net-libs/gnutls/gnutls-2.8.2-r1.ebuild b/net-libs/gnutls/gnutls-2.8.2-r1.ebuild
new file mode 100644
index 000000000000..13c7e3010059
--- /dev/null
+++ b/net-libs/gnutls/gnutls-2.8.2-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.8.2-r1.ebuild,v 1.1 2009/08/13 01:06:06 arfrever Exp $
+
+EAPI="2"
+
+inherit autotools libtool
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+
+if [[ "${PV}" == *pre* ]]; then
+ SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
+else
+ MINOR_VERSION="${PV#*.}"
+ MINOR_VERSION="${MINOR_VERSION%.*}"
+ if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
+ #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+ else
+ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
+ fi
+ unset MINOR_VERSION
+fi
+
+# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bindist +cxx doc examples guile lzo nls zlib"
+
+RDEPEND="dev-libs/libgpg-error
+ >=dev-libs/libgcrypt-1.4.0
+ >=dev-libs/libtasn1-0.3.4
+ nls? ( virtual/libintl )
+ guile? ( dev-scheme/guile[networking] )
+ zlib? ( >=sys-libs/zlib-1.1 )
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${P%_pre*}"
+
+pkg_setup() {
+ if use lzo && use bindist; then
+ ewarn "lzo support was disabled for binary distribution of gnutls"
+ ewarn "due to licensing issues. See Bug 202381 for details."
+ epause 5
+ fi
+}
+
+src_prepare() {
+ sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
+
+ epatch "${FILESDIR}/${P}-fix_reading_of_memory.patch"
+
+ local dir
+ for dir in m4 lib/m4 libextra/m4; do
+ rm -f "${dir}/lt"* "${dir}/libtool.m4"
+ done
+ find . -name ltmain.sh -exec rm {} \;
+ for dir in . lib libextra; do
+ pushd "${dir}" > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
+
+ elibtoolize # for sane .so versioning on FreeBSD
+}
+
+src_configure() {
+ local myconf
+ use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
+ econf --htmldir=/usr/share/doc/${P}/html \
+ $(use_enable cxx) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable guile) \
+ $(use_enable nls) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
+
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}