summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-04-14 02:58:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-04-14 02:58:15 +0000
commit702bed24a87705c0f39b668e88398cbab4c385cd (patch)
tree0548f5372616d26893f875338d750b3143ad1813 /net-libs/gsoap
parentLinux patch 3.19.4. Add check to saved_root_name for supported filesystem pat... (diff)
downloadgentoo-2-702bed24a87705c0f39b668e88398cbab4c385cd.tar.gz
gentoo-2-702bed24a87705c0f39b668e88398cbab4c385cd.tar.bz2
gentoo-2-702bed24a87705c0f39b668e88398cbab4c385cd.zip
Bump
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog9
-rw-r--r--net-libs/gsoap/gsoap-2.8.22.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 3a493ec8c120..c79bf9a71fd7 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gsoap
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.34 2014/12/15 08:46:04 polynomial-c Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.35 2015/04/14 02:58:15 patrick Exp $
+
+*gsoap-2.8.22 (14 Apr 2015)
+
+ 14 Apr 2015; Patrick Lauer <patrick@gentoo.org> +gsoap-2.8.22.ebuild:
+ Bump
15 Dec 2014; Lars Wendler <polynomial-c@gentoo.org> -gsoap-2.8.17.ebuild,
-gsoap-2.8.18.ebuild:
diff --git a/net-libs/gsoap/gsoap-2.8.22.ebuild b/net-libs/gsoap/gsoap-2.8.22.ebuild
new file mode 100644
index 000000000000..6f3e3aaf8cd8
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.22.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.22.ebuild,v 1.1 2015/04/14 02:58:15 patrick Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}