summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-05-19 13:20:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-05-19 13:20:02 +0000
commitd1aaf8848b98de3879d8a70b5192c1f485a730e8 (patch)
tree8689cae4971c9078f52b0f8dc720fdd80e3f3a15 /net-libs/gsoap
parentLinux 2.6.34 and fbcondecor patch (diff)
downloadgentoo-2-d1aaf8848b98de3879d8a70b5192c1f485a730e8.tar.gz
gentoo-2-d1aaf8848b98de3879d8a70b5192c1f485a730e8.tar.bz2
gentoo-2-d1aaf8848b98de3879d8a70b5192c1f485a730e8.zip
Bump and fixes from dev-zero, closes #306915
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog12
-rw-r--r--net-libs/gsoap/files/gsoap-2.7-fedora-openssl.patch17
-rw-r--r--net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch12
-rw-r--r--net-libs/gsoap/files/gsoap-2.7.15-use_libtool.patch101
-rw-r--r--net-libs/gsoap/gsoap-2.7.15.ebuild70
5 files changed, 210 insertions, 2 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index bb0e645dbf84..18776bd47d48 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/gsoap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.7 2009/11/09 12:47:23 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.8 2010/05/19 13:20:02 patrick Exp $
+
+*gsoap-2.7.15 (19 May 2010)
+
+ 19 May 2010; Patrick Lauer <patrick@gentoo.org>
+ +files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch,
+ +gsoap-2.7.15.ebuild, +files/gsoap-2.7.15-use_libtool.patch,
+ +files/gsoap-2.7-fedora-openssl.patch:
+ Bump and fixes from dev-zero, closes #306915
09 Nov 2009; Markus Meier <maekke@gentoo.org> gsoap-2.7.13.ebuild:
amd64 stable, bug #289618
diff --git a/net-libs/gsoap/files/gsoap-2.7-fedora-openssl.patch b/net-libs/gsoap/files/gsoap-2.7-fedora-openssl.patch
new file mode 100644
index 000000000000..443fb694bbdb
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7-fedora-openssl.patch
@@ -0,0 +1,17 @@
+diff -up gsoap-2.7/gsoap/stdsoap2.cpp.openssl gsoap-2.7/gsoap/stdsoap2.cpp
+--- gsoap-2.7/gsoap/stdsoap2.cpp.openssl 2008-10-02 19:36:28.000000000 +0200
++++ gsoap-2.7/gsoap/stdsoap2.cpp 2009-08-22 22:20:49.000000000 +0200
+@@ -4153,7 +4153,12 @@ again:
+ { X509_EXTENSION *ext = X509_get_ext(peer, i);
+ const char *ext_str = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
+ if (ext_str && !strcmp(ext_str, "subjectAltName"))
+- { X509V3_EXT_METHOD *meth = X509V3_EXT_get(ext);
++ {
++#if (OPENSSL_VERSION_NUMBER >= 0x10000000L)
++ const X509V3_EXT_METHOD *meth = X509V3_EXT_get(ext);
++#else
++ X509V3_EXT_METHOD *meth = X509V3_EXT_get(ext);
++#endif
+ void *ext_data;
+ #if (OPENSSL_VERSION_NUMBER >= 0x0090800fL)
+ const unsigned char *data;
diff --git a/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch b/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch
new file mode 100644
index 000000000000..673deb17c35f
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch
@@ -0,0 +1,12 @@
+--- gsoap-2.7/gsoap/Makefile.am 2008-01-27 15:02:36.000000000 -0600
++++ gsoap-2.7mf/gsoap/Makefile.am 2008-01-28 10:24:26.000000000 -0600
+@@ -12,6 +12,9 @@ CLEANFILES=soapcpp2 stdsoap2_cpp.cpp std
+ AM_CXXFLAGS=$(SOAPCPP2_DEBUG) -D$(platform)
+ AM_CFLAGS=$(SOAPCPP2_DEBUG) -D$(platform)
+
++# Install all soapcpp2 and wsdl2h files into /usr/share/gsoap
++nobase_pkgdata_DATA = import/* plugin/* WS/* custom/* extras/*
++
+ ## we cannot build stdsoap2.o from 2 different sources (stdsoap2.cpp and stdsoap2.c), so we need an intermediate target:
+ stdsoap2_ck.c: stdsoap2.cpp
+ $(LN_S) $(srcdir)/stdsoap2.cpp stdsoap2_ck.c
diff --git a/net-libs/gsoap/files/gsoap-2.7.15-use_libtool.patch b/net-libs/gsoap/files/gsoap-2.7.15-use_libtool.patch
new file mode 100644
index 000000000000..9fde611b81ba
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7.15-use_libtool.patch
@@ -0,0 +1,101 @@
+diff -Naur gsoap-2.7.orig/configure.in gsoap-2.7/configure.in
+--- gsoap-2.7.orig/configure.in 2010-03-04 10:04:10.879898902 +0100
++++ gsoap-2.7/configure.in 2010-03-04 10:04:57.182889612 +0100
+@@ -15,8 +15,8 @@
+ AM_PROG_LEX
+ AC_PROG_YACC
+ AC_PROG_CPP
+-AC_PROG_RANLIB
+-#AC_PROG_LIBTOOL
++#AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+ AC_PROG_LN_S
+ AC_PROG_AWK
+ AC_PROG_INSTALL
+@@ -158,12 +158,12 @@
+ AC_MSG_RESULT(no)
+ WSDL2H_EXTRA_FLAGS="-DWITH_OPENSSL -DWITH_GZIP"
+ WSDL2H_EXTRA_LIBS="-lssl -lcrypto -lz"
+- WSDL2H_SOAP_CPP_LIB="libgsoapssl++.a"
++ WSDL2H_SOAP_CPP_LIB="libgsoapssl++.la"
+ else
+ AC_MSG_RESULT(yes)
+ WSDL2H_EXTRA_FLAGS=
+ WSDL2H_EXTRA_LIBS=
+- WSDL2H_SOAP_CPP_LIB="libgsoap++.a"
++ WSDL2H_SOAP_CPP_LIB="libgsoap++.la"
+ fi
+ AC_SUBST(WSDL2H_EXTRA_FLAGS)
+ AC_SUBST(WSDL2H_EXTRA_LIBS)
+diff -Naur gsoap-2.7.orig/gsoap/Makefile.am gsoap-2.7/gsoap/Makefile.am
+--- gsoap-2.7.orig/gsoap/Makefile.am 2010-03-04 10:04:10.920894818 +0100
++++ gsoap-2.7/gsoap/Makefile.am 2010-03-04 10:06:28.000883644 +0100
+@@ -31,20 +31,20 @@
+ stdsoap2_ssl_cpp.cpp: stdsoap2.cpp
+ $(LN_S) -f $(srcdir)/stdsoap2.cpp stdsoap2_ssl_cpp.cpp
+
+-lib_LIBRARIES = libgsoap.a libgsoap++.a libgsoapck.a libgsoapck++.a libgsoapssl.a libgsoapssl++.a
++lib_LTLIBRARIES = libgsoap.la libgsoap++.la libgsoapck.la libgsoapck++.la libgsoapssl.la libgsoapssl++.la
+
+-libgsoap_a_SOURCES = stdsoap2.c
+-libgsoap_a_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform)
+-libgsoap___a_SOURCES = stdsoap2_cpp.cpp
+-libgsoap___a_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform)
+-libgsoapck_a_SOURCES = stdsoap2_ck.c
+-libgsoapck_a_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_COOKIES
+-libgsoapck___a_SOURCES = stdsoap2_ck_cpp.cpp
+-libgsoapck___a_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_COOKIES
+-libgsoapssl_a_SOURCES = stdsoap2_ssl.c
+-libgsoapssl_a_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP
+-libgsoapssl___a_SOURCES = stdsoap2_ssl_cpp.cpp
+-libgsoapssl___a_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP
++libgsoap_la_SOURCES = stdsoap2.c
++libgsoap_la_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform)
++libgsoap___la_SOURCES = stdsoap2_cpp.cpp
++libgsoap___la_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform)
++libgsoapck_la_SOURCES = stdsoap2_ck.c
++libgsoapck_la_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_COOKIES
++libgsoapck___la_SOURCES = stdsoap2_ck_cpp.cpp
++libgsoapck___la_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_COOKIES
++libgsoapssl_la_SOURCES = stdsoap2_ssl.c
++libgsoapssl_la_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP
++libgsoapssl___la_SOURCES = stdsoap2_ssl_cpp.cpp
++libgsoapssl___la_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP
+
+ BUILT_SOURCES = stdsoap2_cpp.cpp $(lib_LIBRARIES)
+
+diff -Naur gsoap-2.7.orig/gsoap/samples/databinding/Makefile.am gsoap-2.7/gsoap/samples/databinding/Makefile.am
+--- gsoap-2.7.orig/gsoap/samples/databinding/Makefile.am 2010-03-04 10:04:10.945913061 +0100
++++ gsoap-2.7/gsoap/samples/databinding/Makefile.am 2010-03-04 10:13:18.323885257 +0100
+@@ -14,7 +14,7 @@
+ WSDLINPUT=$(srcdir)/address.xsd
+ SOAPHEADER=$(srcdir)/address.h
+ SOAP_CPP_SRC=addressC.cpp
+-SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.a
++SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.la
+
+ $(SOAP_CPP_SRC) : $(WSDLINPUT)
+ $(WSDL) $(WSDL_FLAGS) $(WSDLINPUT)
+diff -Naur gsoap-2.7.orig/gsoap/samples/Makefile.defines gsoap-2.7/gsoap/samples/Makefile.defines
+--- gsoap-2.7.orig/gsoap/samples/Makefile.defines 2010-03-04 10:04:10.933894722 +0100
++++ gsoap-2.7/gsoap/samples/Makefile.defines 2010-03-04 10:11:37.388944663 +0100
+@@ -15,13 +15,13 @@
+ SOAP_C_CORE=soapC.c
+ SOAP_C_CLIENT=soapClient.c $(SOAP_C_CORE)
+ SOAP_C_SERVER=soapServer.c $(SOAP_C_CORE)
+-SOAP_C_LIB=$(top_builddir)/gsoap/libgsoap.a
+-SOAP_C_LIB_CK=$(top_builddir)/gsoap/libgsoapck.a
+-SOAP_C_LIB_SSL=$(top_builddir)/gsoap/libgsoapssl.a
++SOAP_C_LIB=$(top_builddir)/gsoap/libgsoap.la
++SOAP_C_LIB_CK=$(top_builddir)/gsoap/libgsoapck.la
++SOAP_C_LIB_SSL=$(top_builddir)/gsoap/libgsoapssl.la
+
+ SOAP_CPP_CORE=soapC.cpp
+ SOAP_CPP_CLIENT=soapClient.cpp $(SOAP_CPP_CORE)
+ SOAP_CPP_SERVER=soapServer.cpp $(SOAP_CPP_CORE)
+-SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.a
+-SOAP_CPP_LIB_CK=$(top_builddir)/gsoap/libgsoapck++.a
+-SOAP_CPP_LIB_SSL=$(top_builddir)/gsoap/libgsoapssl++.a
++SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.la
++SOAP_CPP_LIB_CK=$(top_builddir)/gsoap/libgsoapck++.la
++SOAP_CPP_LIB_SSL=$(top_builddir)/gsoap/libgsoapssl++.la
diff --git a/net-libs/gsoap/gsoap-2.7.15.ebuild b/net-libs/gsoap/gsoap-2.7.15.ebuild
new file mode 100644
index 000000000000..bf2756d31423
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.7.15.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.15.ebuild,v 1.1 2010/05/19 13:20:02 patrick Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+MY_P="${PN}-2.7"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples +ssl static-libs"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch \
+ "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch" \
+ "${FILESDIR}/${PN}-2.7-fedora-openssl.patch" \
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch" \
+ "${FILESDIR}/${P}-use_libtool.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ $(use_enable examples samples) \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}