summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-13 06:18:49 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-13 06:18:49 +0000
commit5c8288ba8c7196fb0a91f84e55bd08d0c7c67c11 (patch)
tree8be89f168e6eb8a3aa65207febb10ea42b1f11a9 /net-libs/ldns
parentSieve version bump (diff)
downloadgentoo-2-5c8288ba8c7196fb0a91f84e55bd08d0c7c67c11.tar.gz
gentoo-2-5c8288ba8c7196fb0a91f84e55bd08d0c7c67c11.tar.bz2
gentoo-2-5c8288ba8c7196fb0a91f84e55bd08d0c7c67c11.zip
Convert to python-single-r1. Enable multilib support, bug #499384.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/ChangeLog7
-rw-r--r--net-libs/ldns/ldns-1.6.16-r1.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/net-libs/ldns/ChangeLog b/net-libs/ldns/ChangeLog
index dcac1ee2c8f6..9329dec33b57 100644
--- a/net-libs/ldns/ChangeLog
+++ b/net-libs/ldns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ldns
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.56 2014/03/23 09:54:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.57 2014/05/13 06:18:49 mgorny Exp $
+
+*ldns-1.6.16-r1 (13 May 2014)
+
+ 13 May 2014; Michał Górny <mgorny@gentoo.org> +ldns-1.6.16-r1.ebuild:
+ Convert to python-single-r1. Enable multilib support, bug #499384.
23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> ldns-1.6.16.ebuild:
Stable for alpha, wrt bug #505066
diff --git a/net-libs/ldns/ldns-1.6.16-r1.ebuild b/net-libs/ldns/ldns-1.6.16-r1.ebuild
new file mode 100644
index 000000000000..9fd1ee15ac18
--- /dev/null
+++ b/net-libs/ldns/ldns-1.6.16-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.16-r1.ebuild,v 1.1 2014/05/13 06:18:49 mgorny Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib-minimal python-single-r1
+
+DESCRIPTION="a library with the aim to simplify DNS programming in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc gost +ecdsa python +ssl static-libs vim-syntax"
+
+RESTRICT="test" # 1.6.9 has no test directory
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7:0[${MULTILIB_USEDEP}] )
+ ecdsa? ( >=dev-libs/openssl-1.0.1c:0[-bindist,${MULTILIB_USEDEP}] )
+ gost? ( >=dev-libs/openssl-1:0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ doc? ( app-doc/doxygen )"
+
+# configure will die if ecdsa is enabled and ssl is not
+REQUIRED_USE="ecdsa? ( ssl )"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/ldns-config
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable ecdsa) \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $(use_enable static-libs static) \
+ $(use_with ssl ssl "${EPREFIX}"/usr) \
+ $(multilib_native_use_with python pyldns) \
+ $(multilib_native_use_with python pyldnsx) \
+ --without-drill \
+ --without-examples \
+ --disable-rpath
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ dohtml -r doc/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc Changelog README*
+
+ prune_libtool_files --modules
+ use python && python_optimize
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins libdns.vim
+ fi
+
+ einfo
+ elog "Install net-dns/ldns-utils if you want drill and examples"
+ einfo
+}