summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-04-13 18:01:47 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-04-13 18:01:47 +0000
commitb48283bb33680a342cbdda860913ccf6392fe850 (patch)
tree11fc9dd3feed92a08e7923ed94e9011998169963 /net-libs/libecap
parentbump, bugfixes; cleanup (diff)
downloadgentoo-2-b48283bb33680a342cbdda860913ccf6392fe850.tar.gz
gentoo-2-b48283bb33680a342cbdda860913ccf6392fe850.tar.bz2
gentoo-2-b48283bb33680a342cbdda860913ccf6392fe850.zip
Respect AR, reported by Agostino Sarubbo. (bug #457734)
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-libs/libecap')
-rw-r--r--net-libs/libecap/ChangeLog6
-rw-r--r--net-libs/libecap/libecap-0.0.2.ebuild9
-rw-r--r--net-libs/libecap/libecap-0.0.3.ebuild13
-rw-r--r--net-libs/libecap/libecap-0.2.0.ebuild11
4 files changed, 30 insertions, 9 deletions
diff --git a/net-libs/libecap/ChangeLog b/net-libs/libecap/ChangeLog
index 556388ed5036..f5427d1c9f8a 100644
--- a/net-libs/libecap/ChangeLog
+++ b/net-libs/libecap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libecap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/ChangeLog,v 1.33 2013/03/03 18:16:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/ChangeLog,v 1.34 2013/04/13 18:01:47 tomwij Exp $
+
+ 13 Apr 2013; Tom Wijsman <TomWij@gentoo.org> libecap-0.0.2.ebuild,
+ libecap-0.0.3.ebuild, libecap-0.2.0.ebuild:
+ Respect AR, reported by Agostino Sarubbo. (bug #457734)
03 Mar 2013; Agostino Sarubbo <ago@gentoo.org> libecap-0.2.0.ebuild:
Stable for sparc, wrt bug #457664
diff --git a/net-libs/libecap/libecap-0.0.2.ebuild b/net-libs/libecap/libecap-0.0.2.ebuild
index 2818b7c5ee2f..f4c4329b7f9b 100644
--- a/net-libs/libecap/libecap-0.0.2.ebuild
+++ b/net-libs/libecap/libecap-0.0.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/libecap-0.0.2.ebuild,v 1.13 2012/09/04 15:43:17 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/libecap-0.0.2.ebuild,v 1.14 2013/04/13 18:01:47 tomwij Exp $
EAPI="2"
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="API for implementing ICAP content analysis and adaptation"
HOMEPAGE="http://www.e-cap.org/"
@@ -20,6 +20,9 @@ RDEPEND="!net-libs/libecap:2"
src_prepare() {
epatch "${FILESDIR}/${PN}-limits.patch"
+
+ # Respect AR. (bug #457734)
+ tc-export AR
}
src_install() {
diff --git a/net-libs/libecap/libecap-0.0.3.ebuild b/net-libs/libecap/libecap-0.0.3.ebuild
index 744c78edd564..b68f2c716dea 100644
--- a/net-libs/libecap/libecap-0.0.3.ebuild
+++ b/net-libs/libecap/libecap-0.0.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/libecap-0.0.3.ebuild,v 1.10 2012/09/04 15:43:17 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/libecap-0.0.3.ebuild,v 1.11 2013/04/13 18:01:47 tomwij Exp $
EAPI="4"
-inherit autotools-utils eutils
+inherit autotools-utils eutils toolchain-funcs
DESCRIPTION="API for implementing ICAP content analysis and adaptation"
HOMEPAGE="http://www.e-cap.org/"
@@ -18,3 +18,10 @@ IUSE="static-libs"
RDEPEND="!net-libs/libecap:2"
DOCS=( CREDITS NOTICE README change.log )
+
+src_prepare() {
+ default
+
+ # Respect AR. (bug #457734)
+ tc-export AR
+}
diff --git a/net-libs/libecap/libecap-0.2.0.ebuild b/net-libs/libecap/libecap-0.2.0.ebuild
index 5070cb92b44d..d21160169992 100644
--- a/net-libs/libecap/libecap-0.2.0.ebuild
+++ b/net-libs/libecap/libecap-0.2.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/libecap-0.2.0.ebuild,v 1.13 2013/03/03 18:16:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libecap/libecap-0.2.0.ebuild,v 1.14 2013/04/13 18:01:47 tomwij Exp $
EAPI="4"
-inherit autotools-utils eutils
+inherit autotools-utils eutils toolchain-funcs
DESCRIPTION="API for implementing ICAP content analysis and adaptation"
HOMEPAGE="http://www.e-cap.org/"
@@ -18,3 +18,10 @@ IUSE="static-libs"
RDEPEND="!net-libs/libecap:0"
DOCS=( CREDITS NOTICE README change.log )
+
+src_prepare() {
+ default
+
+ # Respect AR. (bug #457734)
+ tc-export AR
+}