summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-09-03 01:14:59 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-09-03 01:14:59 +0000
commit9ecdd6b70787556d2f00aec2a55bfe8bc1300db7 (patch)
treec6ecd108657a25225a641008e44ba99c967ce9c7 /net-libs/libesmtp/libesmtp-1.0.3.ebuild
parent (Manifest recommit) (Manifest recommit) (diff)
downloadgentoo-2-9ecdd6b70787556d2f00aec2a55bfe8bc1300db7.tar.gz
gentoo-2-9ecdd6b70787556d2f00aec2a55bfe8bc1300db7.tar.bz2
gentoo-2-9ecdd6b70787556d2f00aec2a55bfe8bc1300db7.zip
Version bump, closes #57194. Use ${PN} in SRC_URI and HOMEPAGE for all ebuilds.
Diffstat (limited to 'net-libs/libesmtp/libesmtp-1.0.3.ebuild')
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/libesmtp/libesmtp-1.0.3.ebuild b/net-libs/libesmtp/libesmtp-1.0.3.ebuild
new file mode 100644
index 000000000000..a77da7b98783
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-1.0.3.ebuild,v 1.1 2004/09/03 01:14:59 ticho Exp $
+
+inherit gcc eutils gnuconfig libtool
+
+MY_P="${P}r1"
+DESCRIPTION="libESMTP is a library that implements the client side of the SMTP protocol"
+SRC_URI="http://www.stafford.uklinux.net/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.stafford.uklinux.net/${PN}/"
+LICENSE="LGPL-2.1 GPL-2"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1
+ >=sys-apps/sed-4"
+
+IUSE="ssl"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ gnuconfig_update
+
+ elibtoolize
+
+ local myconf
+
+ use ssl || myconf="${myconf} --without-openssl"
+
+ if [ "`gcc-major-version`" -eq "2" ]; then
+ myconf="${myconf} --disable-isoc"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --enable-all \
+ --enable-threads \
+ ${myconf} || die "configure failed"
+
+ if [ "`gcc-major-version`" -eq "3" ] && [ "`gcc-minor-version`" -ge "3" ]; then
+ sed -i "s:-Wsign-promo::g" Makefile
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die "make install failed"
+ dodoc AUTHORS COPYING COPYING.GPL INSTALL ChangeLog NEWS Notes README TODO
+ dohtml doc/api.xml
+
+}