summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-18 13:34:18 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-18 13:34:18 +0000
commit24fd914e0463cca6dd46c9c55e1e84a1ab1ad649 (patch)
tree44518190b53d1c592288f01bf10e810f657fd771 /net-libs/libkpeople
parentbump (diff)
downloadgentoo-2-24fd914e0463cca6dd46c9c55e1e84a1ab1ad649.tar.gz
gentoo-2-24fd914e0463cca6dd46c9c55e1e84a1ab1ad649.tar.bz2
gentoo-2-24fd914e0463cca6dd46c9c55e1e84a1ab1ad649.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs/libkpeople')
-rw-r--r--net-libs/libkpeople/ChangeLog10
-rw-r--r--net-libs/libkpeople/libkpeople-0.2.0.ebuild38
2 files changed, 45 insertions, 3 deletions
diff --git a/net-libs/libkpeople/ChangeLog b/net-libs/libkpeople/ChangeLog
index 9c3ebf1e0b62..928e9170d2c5 100644
--- a/net-libs/libkpeople/ChangeLog
+++ b/net-libs/libkpeople/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for net-libs/libkpeople
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/ChangeLog,v 1.1 2013/10/29 19:04:09 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/ChangeLog,v 1.2 2014/02/18 13:34:18 mrueg Exp $
+
+*libkpeople-0.2.0 (18 Feb 2014)
+
+ 18 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +libkpeople-0.2.0.ebuild:
+ Version bump.
*libkpeople-0.1.0 (29 Oct 2013)
29 Oct 2013; Johannes Huber <johu@gentoo.org> +libkpeople-0.1.0.ebuild,
+metadata.xml:
New package. Import from kde overlay. Will be required for KDE Telepathy 0.7.
-
diff --git a/net-libs/libkpeople/libkpeople-0.2.0.ebuild b/net-libs/libkpeople/libkpeople-0.2.0.ebuild
new file mode 100644
index 000000000000..e683435e896c
--- /dev/null
+++ b/net-libs/libkpeople/libkpeople-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/libkpeople-0.2.0.ebuild,v 1.1 2014/02/18 13:34:17 mrueg Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+KDE_LINGUAS="bs cs da de el fr hu lt nl pt pt_BR sk sl sv uk"
+inherit kde4-base
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+else
+ KEYWORDS=""
+fi
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://projects.kde.org/projects/playground/network/libkpeople"
+
+LICENSE="LGPL-2.1"
+SLOT="4"
+IUSE="debug examples test"
+
+DEPEND="
+ dev-libs/shared-desktop-ontologies
+ dev-libs/soprano
+ $(add_kdebase_dep nepomuk-core)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with examples)
+ )
+
+ kde4-base_src_configure
+}