summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-07 12:27:26 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-07 12:27:26 +0000
commitd965b9426aec5aa54d9d28a49678e01c9784fd09 (patch)
tree236df86f19c9e6a74fd5f093d6df989a4793cc01 /net-libs/libnice
parentVersion bump, drop old (diff)
downloadgentoo-2-d965b9426aec5aa54d9d28a49678e01c9784fd09.tar.gz
gentoo-2-d965b9426aec5aa54d9d28a49678e01c9784fd09.tar.bz2
gentoo-2-d965b9426aec5aa54d9d28a49678e01c9784fd09.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/libnice')
-rw-r--r--net-libs/libnice/ChangeLog8
-rw-r--r--net-libs/libnice/files/libnice-0.1.13-gstreamer.patch40
-rw-r--r--net-libs/libnice/libnice-0.1.13.ebuild56
-rw-r--r--net-libs/libnice/metadata.xml2
4 files changed, 104 insertions, 2 deletions
diff --git a/net-libs/libnice/ChangeLog b/net-libs/libnice/ChangeLog
index 4de05a51df3e..1c7be1fffa80 100644
--- a/net-libs/libnice/ChangeLog
+++ b/net-libs/libnice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libnice
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.95 2015/06/07 10:40:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.96 2015/06/07 12:27:25 pacho Exp $
+
+*libnice-0.1.13 (07 Jun 2015)
+
+ 07 Jun 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/libnice-0.1.13-gstreamer.patch, +libnice-0.1.13.ebuild, metadata.xml:
+ Version bump
07 Jun 2015; Markus Meier <maekke@gentoo.org> libnice-0.1.10.ebuild:
arm stable, bug #534012
diff --git a/net-libs/libnice/files/libnice-0.1.13-gstreamer.patch b/net-libs/libnice/files/libnice-0.1.13-gstreamer.patch
new file mode 100644
index 000000000000..136d85456c40
--- /dev/null
+++ b/net-libs/libnice/files/libnice-0.1.13-gstreamer.patch
@@ -0,0 +1,40 @@
+From 76ff4aee9fe963842dd17748d14c68552c5dcda3 Mon Sep 17 00:00:00 2001
+From: Timo Gurr <timo.gurr@gmail.com>
+Date: Mon, 1 Jun 2015 16:10:16 +0200
+Subject: [PATCH] configure: Fix configure failure when building without
+ gstreamer support
+
+Error introduced in 20ea22e0a11a9bdfe4d8125b68083249b694338a, resulting in a
+configure/build error when building without gstreamer:
+
+configure: error: conditional "HAVE_GST_CHECK" was never defined.
+Usually this means the macro was only invoked conditionally.
+---
+ configure.ac | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6031cec..64a571f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -231,9 +231,6 @@ AS_IF([test "$with_gstreamer" != no], [
+ [
+ have_gst_check=no
+ ])
+-
+- AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
+-
+ ])
+
+ AS_IF([test "$with_gstreamer010" != no], [
+@@ -260,6 +257,7 @@ AC_SUBST(gstplugindir)
+ AC_SUBST(gstplugin010dir)
+
+ AM_CONDITIONAL(WITH_GSTREAMER, test "$with_gstreamer" = yes)
++AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
+ AM_CONDITIONAL(WITH_GSTREAMER010, test "$with_gstreamer010" = yes)
+
+ GUPNP_IGD_REQUIRED=0.2.4
+--
+2.4.1
+
diff --git a/net-libs/libnice/libnice-0.1.13.ebuild b/net-libs/libnice/libnice-0.1.13.ebuild
new file mode 100644
index 000000000000..9d61479446dc
--- /dev/null
+++ b/net-libs/libnice/libnice-0.1.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.13.ebuild,v 1.1 2015/06/07 12:27:25 pacho Exp $
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
+HOMEPAGE="http://nice.freedesktop.org/wiki/"
+SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+introspection +upnp"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ upnp? ( >=net-libs/gupnp-igd-0.2.4:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+# Many tests fail from time to time, for example:
+# https://bugs.freedesktop.org/show_bug.cgi?id=81691
+RESTRICT="test"
+
+src_prepare() {
+ # https://bugs.freedesktop.org/show_bug.cgi?id=90801
+ epatch "${FILESDIR}"/${P}-gstreamer.patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # gstreamer plugin split off into media-plugins/gst-plugins-libnice
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static \
+ --disable-static-plugins \
+ --without-gstreamer \
+ --without-gstreamer-0.10 \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable upnp gupnp)
+
+ if multilib_is_native_abi; then
+ ln -s {"${S}"/,}docs/reference/libnice/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/net-libs/libnice/metadata.xml b/net-libs/libnice/metadata.xml
index dad9001338dc..da6fd63d0085 100644
--- a/net-libs/libnice/metadata.xml
+++ b/net-libs/libnice/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>gnome</herd>
+<herd>gnome</herd>
</pkgmetadata>