summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-03-11 08:58:46 +0000
committerJeroen Roovers <jer@gentoo.org>2015-03-11 08:58:46 +0000
commitc276913b8b5c943cc5425209e1f4a8ac6e5c33d2 (patch)
tree9cf1aa34cb374b31b848b64461d31cbdbd49b09f /net-libs/libpcap
parentBump pango to 0.13.0.5 (diff)
downloadgentoo-2-c276913b8b5c943cc5425209e1f4a8ac6e5c33d2.tar.gz
gentoo-2-c276913b8b5c943cc5425209e1f4a8ac6e5c33d2.tar.bz2
gentoo-2-c276913b8b5c943cc5425209e1f4a8ac6e5c33d2.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/ChangeLog9
-rw-r--r--net-libs/libpcap/files/libpcap-1.7.2-libnl.patch22
-rw-r--r--net-libs/libpcap/files/libpcap-1.7.2-scanner.patch11
-rw-r--r--net-libs/libpcap/libpcap-1.7.2.ebuild71
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild4
5 files changed, 115 insertions, 2 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index fd0634f5dfb0..cb55d88ffff1 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.217 2015/03/02 09:29:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.218 2015/03/11 08:58:46 jer Exp $
+
+*libpcap-1.7.2 (11 Mar 2015)
+
+ 11 Mar 2015; Jeroen Roovers <jer@gentoo.org> +libpcap-1.7.2.ebuild,
+ libpcap-9999.ebuild, +files/libpcap-1.7.2-libnl.patch,
+ +files/libpcap-1.7.2-scanner.patch:
+ Version bump.
02 Mar 2015; Agostino Sarubbo <ago@gentoo.org> libpcap-1.6.2-r1.ebuild:
Stable for ppc, wrt bug #526030
diff --git a/net-libs/libpcap/files/libpcap-1.7.2-libnl.patch b/net-libs/libpcap/files/libpcap-1.7.2-libnl.patch
new file mode 100644
index 000000000000..685453958762
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.7.2-libnl.patch
@@ -0,0 +1,22 @@
+--- a/configure.in
++++ b/configure.in
+@@ -453,10 +453,6 @@
+
+ incdir=-I/usr/include/libnl3
+ libnldir=
+- if test x$withval != x ; then
+- libnldir=-L${withval}/lib/.libs
+- incdir=-I${withval}/include
+- fi
+
+ #
+ # Try libnl 3.x first.
+@@ -471,7 +467,7 @@
+ AC_DEFINE(HAVE_LIBNL_3_x,1,[if libnl exists and is version 3.x])
+ AC_DEFINE(HAVE_LIBNL_NLE,1,[libnl has NLE_FAILURE])
+ AC_DEFINE(HAVE_LIBNL_SOCKETS,1,[libnl has new-style socket api])
+- V_INCLS="$V_INCLS ${incdir}"
++ V_INCLS="${incdir} $V_INCLS"
+ have_any_nl="yes"
+ ],[], ${incdir} ${libnldir} -lnl-genl-3 -lnl-3 )
+
diff --git a/net-libs/libpcap/files/libpcap-1.7.2-scanner.patch b/net-libs/libpcap/files/libpcap-1.7.2-scanner.patch
new file mode 100644
index 000000000000..4c8fb4ecb5bd
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.7.2-scanner.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -447,7 +447,7 @@
+ @rm -f $@ $@.bottom
+ $(srcdir)/runlex.sh $(LEX) -o$@ $<
+ mv $@ $@.bottom
+- cat $@.top $@.bottom > $@
++ cat ${srcdir}/$@.top $@.bottom > $@
+ @rm $@.bottom
+
+ scanner.o: scanner.c tokdefs.h
diff --git a/net-libs/libpcap/libpcap-1.7.2.ebuild b/net-libs/libpcap/libpcap-1.7.2.ebuild
new file mode 100644
index 000000000000..d30da72d7a60
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.7.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.7.2.ebuild,v 1.1 2015/03/11 08:58:46 jer Exp $
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth dbus ipv6 netlink static-libs canusb"
+
+RDEPEND="
+ bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
+ canusb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ dbus? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
+ epatch "${FILESDIR}"/${PN}-1.6.1-configure.patch
+ epatch "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ epatch "${FILESDIR}"/${PN}-1.7.2-libnl.patch
+ epatch "${FILESDIR}"/${PN}-1.7.2-scanner.patch
+
+ mkdir bluetooth || die
+ cp "${FILESDIR}"/mgmt.h bluetooth/ || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable ipv6) \
+ $(use_enable canusb) \
+ $(use_enable dbus) \
+ $(use_with netlink libnl)
+}
+
+multilib_src_compile() {
+ emake all shared
+}
+
+multilib_src_install_all() {
+ dodoc CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel}
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+ prune_libtool_files
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h
+ fi
+}
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index 668c921cee94..410643bd7f9a 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-9999.ebuild,v 1.1 2015/01/07 16:10:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-9999.ebuild,v 1.2 2015/03/11 08:58:46 jer Exp $
EAPI=5
inherit autotools eutils git-r3 multilib-minimal
@@ -30,6 +30,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
epatch "${FILESDIR}"/${PN}-1.6.1-configure.patch
epatch "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ epatch "${FILESDIR}"/${PN}-1.7.2-libnl.patch
+ epatch "${FILESDIR}"/${PN}-1.7.2-scanner.patch
mkdir bluetooth || die
cp "${FILESDIR}"/mgmt.h bluetooth/ || die