summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-11-15 20:14:41 +0000
committerPacho Ramos <pacho@gentoo.org>2013-11-15 20:14:41 +0000
commit2dda17643ff637a4120dfa9b4a1848d145869f6e (patch)
tree3f13f0114ec7d773e07d09fd58a256de1c43b1d7 /net-libs/libsoup-gnome
parentVersion bump (diff)
downloadgentoo-2-2dda17643ff637a4120dfa9b4a1848d145869f6e.tar.gz
gentoo-2-2dda17643ff637a4120dfa9b4a1848d145869f6e.tar.bz2
gentoo-2-2dda17643ff637a4120dfa9b4a1848d145869f6e.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/libsoup-gnome')
-rw-r--r--net-libs/libsoup-gnome/ChangeLog7
-rw-r--r--net-libs/libsoup-gnome/libsoup-gnome-2.42.3.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-libs/libsoup-gnome/ChangeLog b/net-libs/libsoup-gnome/ChangeLog
index a398aeb47680..21fe960bda81 100644
--- a/net-libs/libsoup-gnome/ChangeLog
+++ b/net-libs/libsoup-gnome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libsoup-gnome
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.90 2013/10/17 20:38:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.91 2013/11/15 20:14:41 pacho Exp $
+
+*libsoup-gnome-2.42.3.1 (15 Nov 2013)
+
+ 15 Nov 2013; Pacho Ramos <pacho@gentoo.org> +libsoup-gnome-2.42.3.1.ebuild:
+ Version bump
17 Oct 2013; Markus Meier <maekke@gentoo.org> libsoup-gnome-2.40.3.ebuild:
arm stable, bug #476364
diff --git a/net-libs/libsoup-gnome/libsoup-gnome-2.42.3.1.ebuild b/net-libs/libsoup-gnome/libsoup-gnome-2.42.3.1.ebuild
new file mode 100644
index 000000000000..a7056bc32fcc
--- /dev/null
+++ b/net-libs/libsoup-gnome/libsoup-gnome-2.42.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.42.3.1.ebuild,v 1.1 2013/11/15 20:14:41 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+MY_PN=${PN/-gnome}
+MY_P=${MY_PN}-${PV}
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="GNOME plugin for libsoup"
+HOMEPAGE="https://wiki.gnome.org/LibSoup"
+SRC_URI="${SRC_URI//-gnome}"
+
+LICENSE="LGPL-2+"
+SLOT="2.4"
+IUSE="debug +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ ~net-libs/libsoup-${PV}[introspection?]
+ dev-db/sqlite:3=
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ >=net-libs/libsoup-2.42.2-r1
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Use lib present on the system
+ epatch "${FILESDIR}"/${PN}-2.42.2-system-lib.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ gnome2_src_configure \
+ --disable-more-warnings \
+ --disable-static \
+ --disable-tls-check \
+ $(use_enable introspection) \
+ --with-libsoup-system \
+ --with-gnome \
+ --without-apache-httpd
+}