summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-29 12:00:03 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-29 12:00:03 +0000
commit4d8769d16103fbb2d633f0c4513a171b102995fe (patch)
tree952367df6566355091ed1e972b3d0c2bc3f76048 /net-libs/libsoup/libsoup-2.24.2.1.ebuild
parentAdd dev-python/pyxml dep. back, as our dev-python/4suite depends on it anyway... (diff)
downloadgentoo-2-4d8769d16103fbb2d633f0c4513a171b102995fe.tar.gz
gentoo-2-4d8769d16103fbb2d633f0c4513a171b102995fe.tar.bz2
gentoo-2-4d8769d16103fbb2d633f0c4513a171b102995fe.zip
Bump to 2.24.2.1. Fixes a crash in the cookie code.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'net-libs/libsoup/libsoup-2.24.2.1.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-2.24.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/libsoup/libsoup-2.24.2.1.ebuild b/net-libs/libsoup/libsoup-2.24.2.1.ebuild
new file mode 100644
index 000000000000..1f26804e16b7
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.24.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.24.2.1.ebuild,v 1.1 2008/11/29 12:00:03 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc ssl"
+
+RDEPEND=">=dev-libs/glib-2.15.3
+ >=dev-libs/libxml2-2
+ ssl? ( >=net-libs/gnutls-1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # Do NOT build with --disable-debug/--enable-debug=no
+ if use debug ; then
+ G2CONF="${G2CONF} --enable-debug=yes"
+ fi
+
+ G2CONF="${G2CONF} $(use_enable ssl)"
+}