summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-29 08:58:19 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-29 08:58:19 +0000
commitb66b7cab0c067967bb9f0fa439dff12ccfd1b33d (patch)
treef1bf86c949285a4218510e0328573fbad0e50579 /net-libs/libtirpc/libtirpc-0.1.7.ebuild
parentAdd patches to fix hppa. (diff)
downloadgentoo-2-b66b7cab0c067967bb9f0fa439dff12ccfd1b33d.tar.gz
gentoo-2-b66b7cab0c067967bb9f0fa439dff12ccfd1b33d.tar.bz2
gentoo-2-b66b7cab0c067967bb9f0fa439dff12ccfd1b33d.zip
Initial ebuild by me.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'net-libs/libtirpc/libtirpc-0.1.7.ebuild')
-rw-r--r--net-libs/libtirpc/libtirpc-0.1.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libtirpc/libtirpc-0.1.7.ebuild b/net-libs/libtirpc/libtirpc-0.1.7.ebuild
new file mode 100644
index 000000000000..a380ddfb89c5
--- /dev/null
+++ b/net-libs/libtirpc/libtirpc-0.1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtirpc/libtirpc-0.1.7.ebuild,v 1.1 2007/12/29 08:58:18 vapier Exp $
+
+DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
+HOMEPAGE="http://libtirpc.sourceforge.net/"
+SRC_URI="http://nfsv4.bullopensource.org/tarballs/tirpc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:/etc/netconfig:$(DESTDIR)/etc/netconfig:' \
+ Makefile.in
+ emake -s distclean || die
+}
+
+src_compile() {
+ # gss stuff needs updating to latest API
+ econf --disable-gss || die
+ emake || die
+}
+
+src_install() {
+ dodir /etc
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}