summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 14:33:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 14:33:40 +0000
commitd0c8da5ca5092224093e42d3cdec0b60479d910b (patch)
tree6e8786767a91fddaed570e2e14dc165594172a43 /net-libs/libtorrent
parentFixed pkgconfig dep in old version. (diff)
downloadgentoo-2-d0c8da5ca5092224093e42d3cdec0b60479d910b.tar.gz
gentoo-2-d0c8da5ca5092224093e42d3cdec0b60479d910b.tar.bz2
gentoo-2-d0c8da5ca5092224093e42d3cdec0b60479d910b.zip
Add patch to fix building with GCC 4.3 (taken from Debian). Closes bug #212824.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog7
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.11.9+gcc-4.3.patch72
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.0.ebuild10
3 files changed, 87 insertions, 2 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 3a7ddb95c804..1e702ead097c 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.111 2008/03/01 11:12:42 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.112 2008/04/21 14:33:39 flameeyes Exp $
+
+ 21 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libtorrent-0.11.9+gcc-4.3.patch, libtorrent-0.12.0.ebuild:
+ Add patch to fix building with GCC 4.3 (taken from Debian). Closes bug
+ #212824.
*libtorrent-0.12.0 (01 Mar 2008)
diff --git a/net-libs/libtorrent/files/libtorrent-0.11.9+gcc-4.3.patch b/net-libs/libtorrent/files/libtorrent-0.11.9+gcc-4.3.patch
new file mode 100644
index 000000000000..d7343c81ab03
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.11.9+gcc-4.3.patch
@@ -0,0 +1,72 @@
+--- libtorrent-0.11.9.orig/src/data/chunk.cc
++++ libtorrent-0.11.9/src/data/chunk.cc
+@@ -38,6 +38,7 @@
+
+ #include <algorithm>
+ #include <functional>
++#include <cstring>
+
+ #include "torrent/exceptions.h"
+
+--- libtorrent-0.11.9.orig/src/data/chunk_list.h
++++ libtorrent-0.11.9/src/data/chunk_list.h
+@@ -38,6 +38,7 @@
+ #define LIBTORRENT_DATA_CHUNK_LIST_H
+
+ #include <vector>
++#include <string>
+ #include <rak/error_number.h>
+ #include <rak/functional.h>
+
+--- libtorrent-0.11.9.orig/src/net/address_list.cc
++++ libtorrent-0.11.9/src/net/address_list.cc
+@@ -38,6 +38,8 @@
+
+ #include <rak/functional.h>
+
++#include <algorithm>
++
+ #include "download/download_info.h" // for SocketAddressCompact
+
+ #include "address_list.h"
+--- libtorrent-0.11.9.orig/src/torrent/exceptions.cc
++++ libtorrent-0.11.9/src/torrent/exceptions.cc
+@@ -37,6 +37,7 @@
+ #include "config.h"
+
+ #include <cerrno>
++#include <cstring>
+
+ #include "exceptions.h"
+
+--- libtorrent-0.11.9.orig/src/torrent/data/file_list_iterator.h
++++ libtorrent-0.11.9/src/torrent/data/file_list_iterator.h
+@@ -40,6 +40,8 @@
+ #include <torrent/common.h>
+ #include <torrent/data/file_list.h>
+
++#include <cstdlib>
++
+ namespace torrent {
+
+ class File;
+--- libtorrent-0.11.9.orig/src/utils/diffie_hellman.cc
++++ libtorrent-0.11.9/src/utils/diffie_hellman.cc
+@@ -37,6 +37,7 @@
+ #include "config.h"
+
+ #include <string>
++#include <cstring>
+
+ #ifdef USE_OPENSSL
+ #include <openssl/bn.h>
+--- libtorrent-0.11.9.orig/rak/functional.h
++++ libtorrent-0.11.9/rak/functional.h
+@@ -37,6 +37,7 @@
+ #ifndef RAK_FUNCTIONAL_H
+ #define RAK_FUNCTIONAL_H
+
++#include <cstdlib>
+ #include <functional>
+
+ namespace rak {
diff --git a/net-libs/libtorrent/libtorrent-0.12.0.ebuild b/net-libs/libtorrent/libtorrent-0.12.0.ebuild
index 5cf019a725b7..0bdcea74eae2 100644
--- a/net-libs/libtorrent/libtorrent-0.12.0.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.0.ebuild,v 1.1 2008/03/01 11:12:42 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.0.ebuild,v 1.2 2008/04/21 14:33:39 flameeyes Exp $
inherit eutils toolchain-funcs flag-o-matic libtool
@@ -18,6 +18,14 @@ RDEPEND=">=dev-libs/libsigc++-2"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.11"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch taken from Debian.
+ epatch "${FILESDIR}/${PN}-0.11.9+gcc-4.3.patch"
+}
+
src_compile() {
replace-flags -Os -O2