summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-06-11 20:14:11 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-06-11 20:14:11 +0000
commit1e8cbd7b7d751baa81b600b37210971591052424 (patch)
treecd12e86a619d44344ed9dfd3220b822ae00c4ff8 /net-libs/obby/obby-0.1.0.ebuild
parentnet-libs:howl - zero conf (diff)
downloadgentoo-2-1e8cbd7b7d751baa81b600b37210971591052424.tar.gz
gentoo-2-1e8cbd7b7d751baa81b600b37210971591052424.tar.bz2
gentoo-2-1e8cbd7b7d751baa81b600b37210971591052424.zip
initial import
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-libs/obby/obby-0.1.0.ebuild')
-rw-r--r--net-libs/obby/obby-0.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/obby/obby-0.1.0.ebuild b/net-libs/obby/obby-0.1.0.ebuild
new file mode 100644
index 000000000000..f86545259e83
--- /dev/null
+++ b/net-libs/obby/obby-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/obby-0.1.0.ebuild,v 1.1 2005/06/11 20:14:11 humpback Exp $
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://darcs.0x539.de/libobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="howl"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+DEPEND=">=net-libs/net6-1.0
+ >=dev-libs/libsigc++-2.0
+ howl? ( >=net-misc/howl-0.9.8 )"
+
+RDEPEND=""
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --disable-tests"
+ use howl && myconf="${myconf} --with-howl"
+
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+