summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-02-06 18:04:44 +0000
committerThomas Sachau <tommy@gentoo.org>2013-02-06 18:04:44 +0000
commit5f843f99bc61d5821d430dccfd961d068f59dfd0 (patch)
treed0d7eb999620a20bac52c73f96880c991de3320d /net-libs/polarssl
parentVersion bump. Removed old (diff)
downloadgentoo-2-5f843f99bc61d5821d430dccfd961d068f59dfd0.tar.gz
gentoo-2-5f843f99bc61d5821d430dccfd961d068f59dfd0.tar.bz2
gentoo-2-5f843f99bc61d5821d430dccfd961d068f59dfd0.zip
Version bump for bug 455562
(Portage version: 2.2.0_alpha161-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'net-libs/polarssl')
-rw-r--r--net-libs/polarssl/ChangeLog10
-rw-r--r--net-libs/polarssl/polarssl-1.2.5.ebuild68
2 files changed, 76 insertions, 2 deletions
diff --git a/net-libs/polarssl/ChangeLog b/net-libs/polarssl/ChangeLog
index 62fc8f68018d..54a85943d831 100644
--- a/net-libs/polarssl/ChangeLog
+++ b/net-libs/polarssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/polarssl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.35 2012/11/17 18:26:11 tommy Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.36 2013/02/06 18:04:44 tommy Exp $
+
+*polarssl-1.2.5 (06 Feb 2013)
+
+ 06 Feb 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +polarssl-1.2.5.ebuild:
+ Version bump for bug 455562
*polarssl-1.2.0 (17 Nov 2012)
diff --git a/net-libs/polarssl/polarssl-1.2.5.ebuild b/net-libs/polarssl/polarssl-1.2.5.ebuild
new file mode 100644
index 000000000000..2d35a773ebca
--- /dev/null
+++ b/net-libs/polarssl/polarssl-1.2.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.2.5.ebuild,v 1.1 2013/02/06 18:04:44 tommy Exp $
+
+EAPI=2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Cryptographic library for embedded systems"
+HOMEPAGE="http://polarssl.org/"
+#https://polarssl.org/download/polarssl-1.2.0-gpl.tgz
+SRC_URI="http://polarssl.org/download/${P}-gpl.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples sse2"
+
+src_prepare() {
+ sed -i '/.SILENT:/d' Makefile */Makefile
+ epatch "${FILESDIR}"/${PN}-1.2.0-makefile.patch
+ cd library
+ if use sse2 ; then
+ sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
+ else
+ sed -i '15iCFLAGS += -fPIC' Makefile
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake -C library libpolarssl.so || die "emake failed"
+
+ if use examples ; then
+ emake -C programs all || die "emake failed"
+ fi
+ ln -s libpolarssl.so library/libpolarssl.so.0
+}
+
+src_test() {
+ cd programs
+ emake test/selftest || die "emake selftest failed"
+ LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" ./test/selftest || die "selftest failed"
+ cd "${S}"
+ LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" emake check || die
+}
+
+src_install() {
+ insinto /usr/include/polarssl
+ doins include/polarssl/*.h || die
+ dolib.so library/libpolarssl.so || die
+ ln -s libpolarssl.so "${D}"usr/$(get_libdir)/libpolarssl.so.0
+ dolib.a library/libpolarssl.a || die
+
+ if use examples ; then
+ for p in programs/*/* ; do
+ if [[ -x "${p}" && ! -d "${p}" ]] ; then
+ f=polarssl_`basename "${p}"`
+ newbin "${p}" "${f}" || die
+ fi
+ done
+ for e in aes hash pkey ssl test ; do
+ docinto "${e}"
+ dodoc programs/"${e}"/*.c || die
+ dodoc programs/"${e}"/*.txt || die
+ done
+ fi
+}