summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-29 07:58:15 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-29 07:58:15 +0000
commit82d2807743ae34d54aa66db5eeb7230ee139828f (patch)
tree916626ee36a4677b97e209d482890a461322bb1e /net-libs/ptlib
parentAdjusted mask for net-libs/ptlib and net-libs/opal so newer versions get cove... (diff)
downloadgentoo-2-82d2807743ae34d54aa66db5eeb7230ee139828f.tar.gz
gentoo-2-82d2807743ae34d54aa66db5eeb7230ee139828f.tar.bz2
gentoo-2-82d2807743ae34d54aa66db5eeb7230ee139828f.zip
Version bumps to fix build with >=sys-devel/bison-3.0 (bug #485842)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-libs/ptlib')
-rw-r--r--net-libs/ptlib/ChangeLog11
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch39
-rw-r--r--net-libs/ptlib/ptlib-2.10.11.ebuild229
-rw-r--r--net-libs/ptlib/ptlib-2.12.9.ebuild223
4 files changed, 500 insertions, 2 deletions
diff --git a/net-libs/ptlib/ChangeLog b/net-libs/ptlib/ChangeLog
index 21a6241c6ed6..1b600becf82b 100644
--- a/net-libs/ptlib/ChangeLog
+++ b/net-libs/ptlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/ptlib
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.50 2013/10/27 09:45:21 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.51 2014/04/29 07:58:15 polynomial-c Exp $
+
+*ptlib-2.12.9 (29 Apr 2014)
+*ptlib-2.10.11 (29 Apr 2014)
+
+ 29 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> +ptlib-2.10.11.ebuild,
+ +ptlib-2.12.9.ebuild, +files/ptlib-2.10.10-mga-bison-parameter.patch:
+ Version bumps to fix build with >=sys-devel/bison-3.0 (bug #485842).
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Voip herd is removed: http://article.gmane.org/gmane.linux.gentoo.devel/88434
diff --git a/net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch b/net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch
new file mode 100644
index 000000000000..fcc8d0d2e7a8
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch
@@ -0,0 +1,39 @@
+--- ptlib-2.10.11/./src/ptlib/common/getdate.y 2013-08-15 01:20:26.000000000 +0200
++++ /mnt/chroot/cauldron/home/dan/rpm/BUILD/ptlib-2.10.11/src/ptlib/common/getdate.y 2013-12-15 00:24:27.866481490 +0100
+@@ -121,9 +121,9 @@
+ static int yylex();
+
+ #ifdef __GNUC__
+-static int yyerror(char const *msg);
++static int yyerror(void *, char const *msg);
+ #else
+-static void yyerror(char const *msg);
++static void yyerror(void *, char const *msg);
+ #endif
+
+
+@@ -132,7 +132,8 @@
+
+ %}
+
+-%pure_parser
++%pure-parser
++%parse-param {void *parseParam}
+
+ %union {
+ time_t Number;
+@@ -1018,12 +1019,12 @@
+ #endif
+
+ #ifdef __GNUC__
+-int yyerror(const char * s)
++int yyerror(void *var, const char * s)
+ {
+ return 0;
+ }
+ #else
+-static void yyerror(const char * s)
++static void yyerror(void *var, const char * s)
+ {
+ }
+ #endif
diff --git a/net-libs/ptlib/ptlib-2.10.11.ebuild b/net-libs/ptlib/ptlib-2.10.11.ebuild
new file mode 100644
index 000000000000..f3ebfce86906
--- /dev/null
+++ b/net-libs/ptlib/ptlib-2.10.11.ebuild
@@ -0,0 +1,229 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.11.ebuild,v 1.1 2014/04/29 07:58:15 polynomial-c Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Network focused portable C++ class library providing high level functions"
+HOMEPAGE="http://www.opalvoip.org/"
+SRC_URI="mirror://sourceforge/opalvoip/${P}.tar.bz2
+ doc? ( mirror://sourceforge/opalvoip/${PN}-2.10.10-htmldoc.tar.bz2 )"
+
+LICENSE="MPL-1.0"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# default enabled are features from 'minsize', the most used according to ptlib
+IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+jabber ldap lua mail odbc oss pch pulseaudio qos remote sasl sdl serial
+shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+vxml wav xml xmlrpc"
+
+CDEPEND="
+ audio? ( alsa? ( media-libs/alsa-lib ) )
+ ldap? ( net-nds/openldap )
+ lua? ( dev-lang/lua )
+ odbc? ( dev-db/unixODBC )
+ pulseaudio? ( media-sound/pulseaudio )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ sdl? ( media-libs/libsdl )
+ ssl? ( dev-libs/openssl )
+ video? ( v4l? ( media-libs/libv4l ) )
+ xml? ( dev-libs/expat )
+ !!dev-libs/pwlib"
+RDEPEND="${CDEPEND}
+ ffmpeg? ( virtual/ffmpeg )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ sys-devel/bison
+ sys-devel/flex
+ video? ( v4l? ( sys-kernel/linux-headers ) )"
+
+# NOTES:
+# media-libs/libdc1394:2 should be supported but headers location have changed
+# tools/ directory is ignored
+# avc plugin is disabled to fix bug 276514, see upstream bug 2821744
+
+conditional_use_warn_msg() {
+ ewarn "To enable ${1} USE flag, you need ${2} USE flag to be enabled"
+ ewarn "Please, enable ${2} or disable ${1}"
+}
+
+REQUIRED_USE="sdl? ( video )
+ jabber? ( xml )
+ vxml? ( http tts xml )
+ xmlrpc? ( http xml )
+ soap? ( http xml )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.10.9-svn_revision_override.patch" \
+ "${FILESDIR}/${PN}-2.10.9-pkgconfig_ldflags.patch" \
+ "${FILESDIR}/${PN}-2.10.9-respect_cxxflags.patch" \
+ "${FILESDIR}/${PN}-2.10.10-mga-bison-parameter.patch"
+
+ if ! use telnet; then
+ epatch "${FILESDIR}/${PN}-2.10.9-disable-telnet-symbols.patch"
+ fi
+
+ # remove visual studio related files from samples/
+ if use examples; then
+ rm -f samples/*/*.vcproj
+ rm -f samples/*/*.sln
+ rm -f samples/*/*.dsp
+ rm -f samples/*/*.dsw
+ fi
+
+ if [[ ! -z ${TARGET+set} ]]; then
+ ewarn "TARGET variable is set. Removing as it would break the build, bug #465722."
+ unset TARGET
+ fi
+}
+
+src_configure() {
+ local myconf=""
+
+ # plugins are disabled only if ! audio and ! video
+ if ! use audio && ! use video; then
+ myconf="${myconf} --disable-plugins"
+ else
+ myconf="${myconf} --enable-plugins"
+ fi
+
+ # minsize: presets of features (overwritten by use flags)
+ # ansi-bool, atomicity: there is no reason to disable those features
+ # internalregex: we want to use system one
+ # sunaudio and bsdvideo are respectively for SunOS and BSD's
+ # appshare, vfw: only for windows
+ # samples: no need to build samples
+ # avc: disabled, bug 276514, upstream bug 2821744
+ # mlib: SUN mediaLibs. Not in tree.
+ # pipechan, configfile, resolver, url: force enabling
+ econf ${myconf} \
+ --disable-minsize \
+ --enable-ansi-bool \
+ --enable-atomicity \
+ --disable-internalregex \
+ --disable-sunaudio \
+ --disable-bsdvideo \
+ --disable-appshare \
+ --disable-vfw \
+ --disable-samples \
+ --disable-avc \
+ --disable-mlib \
+ --enable-configfile \
+ --enable-pipechan \
+ --enable-resolver \
+ --enable-url \
+ $(use_enable audio) \
+ $(use_enable alsa) \
+ $(use_enable asn) \
+ $(use_enable debug exceptions) \
+ $(use_enable debug memcheck) \
+ $(use_enable debug tracing) \
+ $(use_enable dtmf) \
+ --disable-esd \
+ $(use_enable ffmpeg ffvdev) \
+ $(use_enable ftp) \
+ $(use_enable http) \
+ $(use_enable http httpforms) \
+ $(use_enable http httpsvc) \
+ --disable-dc \
+ $(use_enable ipv6) \
+ $(use_enable jabber) \
+ $(use_enable ldap openldap) \
+ $(use_enable lua) \
+ $(use_enable mail pop3smtp) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable odbc) \
+ $(use_enable oss) \
+ $(use_enable pch) \
+ $(use_enable qos) \
+ $(use_enable remote remconn) \
+ $(use_enable sasl) \
+ $(use_enable sdl) \
+ $(use_enable serial) \
+ $(use_enable shmvideo) \
+ $(use_enable snmp) \
+ $(use_enable soap) \
+ $(use_enable socks) \
+ $(use_enable ssl openssl) \
+ $(use_enable stun) \
+ $(use_enable telnet) \
+ $(use_enable tts) \
+ --disable-v4l \
+ $(use_enable v4l v4l2) \
+ $(use_enable video) $(use_enable video vidfile) \
+ $(use_enable vxml) \
+ $(use_enable wav wavfile) \
+ $(use_enable xml expat) \
+ $(use_enable xmlrpc)
+}
+
+src_compile() {
+ local makeopts=""
+ tc-env_build
+
+ use debug && makeopts="debug"
+
+ emake ${makeopts} || die "emake failed"
+}
+
+src_install() {
+ local makeopts=""
+
+ use debug && makeopts="DEBUG=1"
+
+ emake DESTDIR="${D}" ${makeopts} install || die "emake install failed"
+
+ # Get rid of static libraries if not requested
+ # There seems to be no easy way to disable this in the build system
+ if ! use static-libs; then
+ rm -v "${D}"/usr/lib*/*.a || die
+ fi
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/html/* || die "dohtml failed"
+ fi
+
+ dodoc History.txt ReadMe.txt ReadMe_QOS.txt || die "dodoc failed"
+
+ if use audio || use video; then
+ newdoc plugins/ReadMe.txt ReadMe-Plugins.txt || die "newdoc failed"
+ fi
+
+ if use examples; then
+ local exampledir="/usr/share/doc/${PF}/examples"
+ local basedir="samples"
+ local sampledirs="`ls samples --hide=Makefile`"
+
+ # first, install Makefile
+ insinto ${exampledir}/
+ doins ${basedir}/Makefile || die "doins failed"
+
+ # now, all examples
+ for x in ${sampledirs}; do
+ insinto ${exampledir}/${x}/
+ doins ${basedir}/${x}/* || die "doins failed"
+ done
+ fi
+}
+
+pkg_postinst() {
+ if use examples; then
+ ewarn "All examples have been installed, some of them will not work on your system"
+ ewarn "it will depend of the enabled USE flags."
+ ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
+ fi
+
+ if ! use audio || ! use video; then
+ ewarn "You have disabled audio or video USE flags."
+ ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
+ ewarn "Having a feature enabled via use flag but disabled can lead to issues."
+ fi
+
+ ewarn "If you've just removed pwlib to install ptlib, some packages will be broken."
+ ewarn "Please use 'revdep-rebuild' from app-portage/gentoolkit to check."
+ ewarn "If some packages need pwlib, consider removing ptlib and re-installing pwlib"
+ ewarn "or help us to make them live together."
+}
diff --git a/net-libs/ptlib/ptlib-2.12.9.ebuild b/net-libs/ptlib/ptlib-2.12.9.ebuild
new file mode 100644
index 000000000000..0fd8e7a30704
--- /dev/null
+++ b/net-libs/ptlib/ptlib-2.12.9.ebuild
@@ -0,0 +1,223 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.9.ebuild,v 1.1 2014/04/29 07:58:15 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Network focused portable C++ class library providing high level functions"
+HOMEPAGE="http://www.opalvoip.org/"
+SRC_URI="mirror://sourceforge/opalvoip/${P}.tar.bz2
+ doc? ( mirror://sourceforge/opalvoip/${P}-htmldoc.tar.bz2 )"
+
+LICENSE="MPL-1.0"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# default enabled are features from 'minsize', the most used according to ptlib
+IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+jabber ldap lua mail odbc oss pch pulseaudio remote sasl sdl serial
+shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+vxml wav xml xmlrpc"
+
+CDEPEND="
+ audio? ( alsa? ( media-libs/alsa-lib ) )
+ ldap? ( net-nds/openldap )
+ lua? ( dev-lang/lua )
+ odbc? ( dev-db/unixODBC )
+ pulseaudio? ( media-sound/pulseaudio )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ sdl? ( media-libs/libsdl )
+ ssl? ( dev-libs/openssl )
+ video? ( v4l? ( media-libs/libv4l ) )
+ xml? ( dev-libs/expat )
+ !!dev-libs/pwlib"
+RDEPEND="${CDEPEND}
+ ffmpeg? ( virtual/ffmpeg )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ sys-devel/bison
+ sys-devel/flex
+ video? ( v4l? ( sys-kernel/linux-headers ) )"
+
+# NOTES:
+# media-libs/libdc1394:2 should be supported but headers location have changed
+# tools/ directory is ignored
+# avc plugin is disabled to fix bug 276514, see upstream bug 2821744
+
+REQUIRED_USE="sdl? ( video )
+ jabber? ( xml )
+ vxml? ( http tts xml )
+ xmlrpc? ( http xml )
+ soap? ( http xml )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.10.9-svn_revision_override.patch" \
+ "${FILESDIR}/${PN}-2.10.9-pkgconfig_ldflags.patch" \
+ "${FILESDIR}/${PN}-2.12.4-respect_cxxflags.patch" \
+ "${FILESDIR}/${PN}-2.12.4-sdl-linking.patch"
+
+ if ! use telnet; then
+ epatch "${FILESDIR}/${PN}-2.10.9-disable-telnet-symbols.patch"
+ fi
+
+ # remove visual studio related files from samples/
+ if use examples; then
+ rm -f samples/*/*.vcproj
+ rm -f samples/*/*.sln
+ rm -f samples/*/*.dsp
+ rm -f samples/*/*.dsw
+ fi
+
+ if [[ ! -z ${TARGET+set} ]]; then
+ ewarn "TARGET variable is set. Removing as it would break the build, bug #465722."
+ unset TARGET
+ fi
+}
+
+src_configure() {
+ local myconf=""
+
+ # plugins are disabled only if ! audio and ! video
+ if ! use audio && ! use video; then
+ myconf+=" --disable-plugins"
+ else
+ myconf+=" --enable-plugins"
+ fi
+
+ # minsize: presets of features (overwritten by use flags)
+ # ansi-bool, atomicity: there is no reason to disable those features
+ # internalregex: we want to use system one
+ # sunaudio and bsdvideo are respectively for SunOS and BSD's
+ # appshare, vfw: only for windows
+ # samples: no need to build samples
+ # avc: disabled, bug 276514, upstream bug 2821744
+ # mlib: SUN mediaLibs. Not in tree.
+ # pipechan, configfile, resolver, url: force enabling
+ econf ${myconf} \
+ --disable-minsize \
+ --enable-ansi-bool \
+ --enable-atomicity \
+ --disable-internalregex \
+ --disable-sunaudio \
+ --disable-bsdvideo \
+ --disable-appshare \
+ --disable-vfw \
+ --disable-samples \
+ --disable-avc \
+ --disable-mlib \
+ --enable-configfile \
+ --enable-pipechan \
+ --enable-resolver \
+ --enable-url \
+ $(use_enable audio) \
+ $(use_enable alsa) \
+ $(use_enable asn) \
+ $(use_enable debug exceptions) \
+ $(use_enable debug memcheck) \
+ $(use_enable debug tracing) \
+ $(use_enable dtmf) \
+ --disable-esd \
+ $(use_enable ffmpeg ffvdev) \
+ $(use_enable ftp) \
+ $(use_enable http) \
+ $(use_enable http httpforms) \
+ $(use_enable http httpsvc) \
+ --disable-dc \
+ $(use_enable ipv6) \
+ $(use_enable jabber) \
+ $(use_enable ldap openldap) \
+ $(use_enable lua) \
+ $(use_enable mail pop3smtp) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable odbc) \
+ $(use_enable oss) \
+ $(use_enable pch) \
+ $(use_enable remote remconn) \
+ $(use_enable sasl) \
+ $(use_enable sdl) \
+ $(use_enable serial) \
+ $(use_enable shmvideo) \
+ $(use_enable snmp) \
+ $(use_enable soap) \
+ $(use_enable socks) \
+ $(use_enable ssl openssl) \
+ $(use_enable stun) \
+ $(use_enable telnet) \
+ $(use_enable tts) \
+ --disable-v4l \
+ $(use_enable v4l v4l2) \
+ $(use_enable video) $(use_enable video vidfile) \
+ $(use_enable vxml) \
+ $(use_enable wav wavfile) \
+ $(use_enable xml expat) \
+ $(use_enable xmlrpc)
+}
+
+src_compile() {
+ local makeopts=""
+ tc-env_build
+
+ use debug && makeopts="debug"
+
+ emake ${makeopts}
+}
+
+src_install() {
+ local makeopts=""
+
+ use debug && makeopts="DEBUG=1"
+
+ emake DESTDIR="${D}" ${makeopts} install
+
+ # Get rid of static libraries if not requested
+ # There seems to be no easy way to disable this in the build system
+ if ! use static-libs; then
+ rm -v "${D}"/usr/lib*/*.a || die
+ fi
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/html/*
+ fi
+
+ dodoc History.txt ReadMe.txt ReadMe_QOS.txt
+
+ if use audio || use video; then
+ newdoc plugins/ReadMe.txt ReadMe-Plugins.txt
+ fi
+
+ if use examples; then
+ local exampledir="/usr/share/doc/${PF}/examples"
+ local basedir="samples"
+ local sampledirs="`ls samples --hide=Makefile`"
+
+ # first, install Makefile
+ insinto ${exampledir}/
+ doins ${basedir}/Makefile || die "doins failed"
+
+ # now, all examples
+ for x in ${sampledirs}; do
+ insinto ${exampledir}/${x}/
+ doins ${basedir}/${x}/* || die "doins failed"
+ done
+ fi
+}
+
+pkg_postinst() {
+ if use examples; then
+ ewarn "All examples have been installed, some of them will not work on your system"
+ ewarn "it will depend of the enabled USE flags."
+ ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
+ fi
+
+ if ! use audio || ! use video; then
+ ewarn "You have disabled audio or video USE flags."
+ ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
+ ewarn "Having a feature enabled via use flag but disabled can lead to issues."
+ fi
+
+ ewarn "If you've just removed pwlib to install ptlib, some packages will be broken."
+ ewarn "Please use 'revdep-rebuild' from app-portage/gentoolkit to check."
+ ewarn "If some packages need pwlib, consider removing ptlib and re-installing pwlib"
+ ewarn "or help us to make them live together."
+}