summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-04-10 23:38:34 +0000
committerOlivier Crête <tester@gentoo.org>2008-04-10 23:38:34 +0000
commitce3321d0125356e9b69488a9734fca0bf42d35bf (patch)
treecb701f725e0a577eb9f5f3f9bdeff054cd56dbd4 /net-libs/sofia-sip/sofia-sip-1.12.8.ebuild
parentBump to 2.22.2. Fix CVE-2008-0887, add a limit to the password field. (diff)
downloadgentoo-2-ce3321d0125356e9b69488a9734fca0bf42d35bf.tar.gz
gentoo-2-ce3321d0125356e9b69488a9734fca0bf42d35bf.tar.bz2
gentoo-2-ce3321d0125356e9b69488a9734fca0bf42d35bf.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs/sofia-sip/sofia-sip-1.12.8.ebuild')
-rw-r--r--net-libs/sofia-sip/sofia-sip-1.12.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/sofia-sip/sofia-sip-1.12.8.ebuild b/net-libs/sofia-sip/sofia-sip-1.12.8.ebuild
new file mode 100644
index 000000000000..526f3344c3cc
--- /dev/null
+++ b/net-libs/sofia-sip/sofia-sip-1.12.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/sofia-sip/sofia-sip-1.12.8.ebuild,v 1.1 2008/04/10 23:38:34 tester Exp $
+
+DESCRIPTION="RFC3261 compliant SIP User-Agent library"
+HOMEPAGE="http://sofia-sip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="dev-libs/glib
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf $(use_with ssl openssl) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog COPYRIGHTS README TODO
+}