summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-09 12:18:09 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-09 12:18:09 +0000
commit2e63d883de84505948b6dff444a43d2843796cf2 (patch)
tree8843c4d6b77640643d60f9eab335570ab25af509 /net-libs/soup/soup-0.7.4-r1.ebuild
parentnew version (diff)
downloadgentoo-2-2e63d883de84505948b6dff444a43d2843796cf2.tar.gz
gentoo-2-2e63d883de84505948b6dff444a43d2843796cf2.tar.bz2
gentoo-2-2e63d883de84505948b6dff444a43d2843796cf2.zip
link to libxml1 for evo-1.[12]
Diffstat (limited to 'net-libs/soup/soup-0.7.4-r1.ebuild')
-rw-r--r--net-libs/soup/soup-0.7.4-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/soup/soup-0.7.4-r1.ebuild b/net-libs/soup/soup-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..86d7cdc3912e
--- /dev/null
+++ b/net-libs/soup/soup-0.7.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.4-r1.ebuild,v 1.1 2002/11/09 12:18:09 azarah Exp $
+
+IUSE="ssl doc"
+
+inherit gnome.org libtool
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Soup is a SOAP implementation"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ =dev-libs/glib-1.2*
+ >=dev-libs/libxml2-2.4.16
+ dev-libs/popt
+ ssl? ( dev-libs/openssl )
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64 ppc"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use ssl \
+ && myconf="--enable-ssl" \
+ || myconf="--disable-ssl"
+
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ # there is a --enable-apache here.....
+
+ econf \
+ ${myconf} \
+ --with-libxml=1 || die
+ # Evolution 1.1 and 1.2 need it with libxml1
+
+ # dont always work with -j4 -- <azarah@gentoo.org> 9 Nov 2002
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ABOUT-NLS COPYING* ChangeLog README* INSTALL NEWS TODO
+}
+