summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-09-01 15:19:24 +0000
committerPacho Ramos <pacho@gentoo.org>2014-09-01 15:19:24 +0000
commit971beafbb180c085743831d8890355ef0380749c (patch)
tree9754d31e0e525136ea1af74020faa7f92a7aca21 /net-libs/telepathy-farstream
parentNew beta, import of Emil Karlson's ebuild from the x11 overlay. (diff)
downloadgentoo-2-971beafbb180c085743831d8890355ef0380749c.tar.gz
gentoo-2-971beafbb180c085743831d8890355ef0380749c.tar.bz2
gentoo-2-971beafbb180c085743831d8890355ef0380749c.zip
Version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/telepathy-farstream')
-rw-r--r--net-libs/telepathy-farstream/ChangeLog7
-rw-r--r--net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/telepathy-farstream/ChangeLog b/net-libs/telepathy-farstream/ChangeLog
index 23b925e29377..94ecfbff5326 100644
--- a/net-libs/telepathy-farstream/ChangeLog
+++ b/net-libs/telepathy-farstream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-farstream
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.26 2014/04/27 08:30:06 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.27 2014/09/01 15:19:24 pacho Exp $
+
+*telepathy-farstream-0.6.2 (01 Sep 2014)
+
+ 01 Sep 2014; Pacho Ramos <pacho@gentoo.org> +telepathy-farstream-0.6.2.ebuild:
+ Version bump
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -telepathy-farstream-0.6.0.ebuild:
drop old
diff --git a/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild b/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild
new file mode 100644
index 000000000000..31fb31ca3110
--- /dev/null
+++ b/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild,v 1.1 2014/09/01 15:19:24 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Telepathy client library that uses Farstream to handle Call channels"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-0.60
+ >=dev-libs/dbus-glib-0.60
+ media-libs/gstreamer:1.0[introspection?]
+ >=net-libs/telepathy-glib-0.21[introspection?]
+ net-libs/farstream:0.2[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-Werror \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ insinto /usr/share/doc/${PF}/examples/python
+ doins examples/python/*.py
+ fi
+}