summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-04 16:07:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-04 16:07:38 +0000
commitfcf38d2885ea144e0f5e7b288376b2ba9f1beb8c (patch)
tree128bfd0e06a8443e66e7996b11b68607be161071 /net-libs/wvstreams
parentVersion bumped. (diff)
downloadgentoo-2-fcf38d2885ea144e0f5e7b288376b2ba9f1beb8c.tar.gz
gentoo-2-fcf38d2885ea144e0f5e7b288376b2ba9f1beb8c.tar.bz2
gentoo-2-fcf38d2885ea144e0f5e7b288376b2ba9f1beb8c.zip
Version bump wrt #274620, thanks to Fabian Fingerle for reporting.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/ChangeLog10
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch58
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1.ebuild89
3 files changed, 155 insertions, 2 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 30245943765a..782e672d1f94 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/wvstreams
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.128 2009/06/28 08:58:12 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.129 2010/01/04 16:07:38 ssuominen Exp $
+
+*wvstreams-4.6.1 (04 Jan 2010)
+
+ 04 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +wvstreams-4.6.1.ebuild, +files/wvstreams-4.6.1-parallel-make.patch:
+ Version bump wrt #274620, thanks to Fabian Fingerle for reporting.
28 Jun 2009; Patrick Lauer <patrick@gentoo.org> wvstreams-4.5.ebuild,
+files/wvstreams-4.5-glibc.patch:
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch
new file mode 100644
index 000000000000..5ad79fd7a9a6
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch
@@ -0,0 +1,58 @@
+diff -ur wvstreams-4.6.1.orig/Makefile wvstreams-4.6.1/Makefile
+--- wvstreams-4.6.1.orig/Makefile 2009-09-16 00:26:50.000000000 +0300
++++ wvstreams-4.6.1/Makefile 2010-01-04 18:06:15.000000000 +0200
+@@ -131,12 +131,19 @@
+ # libwvstreams: stream/event handling library
+ #
+ TARGETS += libwvstreams.so
+-TARGETS += crypto/tests/ssltest ipstreams/tests/unixtest
++TARGETS += crypto/tests/ssltest
++crypto/tests/ssltest: $(LIBWVSTREAMS)
++
++TARGETS += ipstreams/tests/unixtest
++ipstreams/tests/unixtest: $(LIBWVSTREAMS)
++
+ TARGETS += crypto/tests/printcert
++crypto/tests/printcert: $(LIBWVSTREAMS)
+
+ ifndef _MACOS
+ ifneq ("$(with_readline)", "no")
+ TARGETS += ipstreams/tests/wsd
++ ipstreams/tests/wsd: $(LIBWVSTREAMS)
+ ipstreams/tests/wsd-LIBS += -lreadline
+ else
+ TEST_SKIP_OBJS += ipstreams/tests/wsd
+@@ -179,7 +186,11 @@
+ #
+ ifneq ("$(with_dbus)", "no")
+ TARGETS += libwvdbus.so
+- TARGETS += dbus/tests/wvdbus dbus/tests/wvdbusd
++ TARGETS += dbus/tests/wvdbus
++ dbus/tests/wvdbus: $(LIBWVDBUS)
++
++ TARGETS += dbus/tests/wvdbusd
++ dbus/tests/wvdbusd: $(LIBWVDBUS)
+ TESTS += $(call tests_cc,dbus/tests)
+ libwvdbus_OBJS += $(call objects,dbus)
+ libwvdbus.so: $(libwvdbus_OBJS) $(LIBWVSTREAMS)
+diff -ur wvstreams-4.6.1.orig/wvrules-posix.mk wvstreams-4.6.1/wvrules-posix.mk
+--- wvstreams-4.6.1.orig/wvrules-posix.mk 2008-10-21 18:31:58.000000000 +0300
++++ wvstreams-4.6.1/wvrules-posix.mk 2010-01-04 18:04:00.000000000 +0200
+@@ -85,12 +85,15 @@
+ $(AR) s $1
+ endef
+
+-CC: FORCE
++CC:
+ @CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS)/gen-cc CC c
+
+-CXX: FORCE
++CXX:
+ @CC="$(CXX)" CFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS)/gen-cc CXX cc
+
++#All files must depend on the above two rules. This is a godawful hack.
++$(shell find -type f '(' -name '*.c' -o -name '*.cc' ')' ): CC CXX
++
+ wvlink=$(LINK_MSG)$(WVLINK_CC) $(LDFLAGS) $($1-LDFLAGS) -o $1 $(filter %.o %.a %.so, $2) $($1-LIBS) $(XX_LIBS) $(LDLIBS) $(PRELIBS) $(LIBS)
diff --git a/net-libs/wvstreams/wvstreams-4.6.1.ebuild b/net-libs/wvstreams/wvstreams-4.6.1.ebuild
new file mode 100644
index 000000000000..8048ce4897bf
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.6.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1.ebuild,v 1.1 2010/01/04 16:07:38 ssuominen Exp $
+
+EAPI=2
+inherit autotools toolchain-funcs versionator
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
+SRC_URI="http://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="pam doc +ssl +dbus debug"
+
+#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
+RESTRICT="test"
+
+#QA Fail: xplc is compiled as a part of wvstreams.
+#It'll take a larger patching effort to get it extracted, since upstream integrated it
+#more tightly this time. Probably for the better since upstream xplc seems dead.
+
+RDEPEND="sys-libs/readline
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ dev-libs/openssl
+ pam? ( sys-libs/pam )
+ virtual/c++-tr1-functional"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ if has_version '>=sys-devel/gcc-4.1' && ! has_version '>=dev-libs/boost-1.34.1'
+ then
+ if ! version_is_at_least 4.1 "$(gcc-fullversion)"
+ then
+ eerror "This package requires the active gcc to be at least version 4.1"
+ eerror "or >=dev-libs/boost-1.34.1 must be installed."
+ die "Please activate >=sys-devel/gcc-4.1 with gcc-config."
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+ eautoreconf
+ cd argp
+ eautoreconf
+}
+
+src_configure() {
+ export CXX="$(tc-getCXX)"
+
+ econf \
+ $(use_enable debug) \
+ --disable-optimization \
+ $(use_with dbus) \
+ --with-openssl \
+ $(use_with pam) \
+ --without-tcl \
+ --without-qt \
+ --with-zlib \
+ --without-valgrind
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_test() {
+ emake test || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README*
+
+ if use doc; then
+ #the list of files is too big for dohtml -r Docs/doxy-html/*
+ cd Docs/doxy-html
+ dohtml -r *
+ fi
+}