summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-20 19:54:14 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-20 19:54:14 +0000
commitbcf17705ac524875bfcb60eba36ec24accc2aa77 (patch)
tree481e8e58e09575c901a4642d5d559bc3c9e86223 /net-libs/xulrunner
parentApplied patch to prevent URI address bar spoofing, should solve bug 185603. (diff)
downloadgentoo-2-bcf17705ac524875bfcb60eba36ec24accc2aa77.tar.gz
gentoo-2-bcf17705ac524875bfcb60eba36ec24accc2aa77.tar.bz2
gentoo-2-bcf17705ac524875bfcb60eba36ec24accc2aa77.zip
Version bump wrt security #185737
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-libs/xulrunner')
-rw-r--r--net-libs/xulrunner/ChangeLog7
-rw-r--r--net-libs/xulrunner/files/digest-xulrunner-1.8.1.56
-rw-r--r--net-libs/xulrunner/xulrunner-1.8.1.5.ebuild153
3 files changed, 165 insertions, 1 deletions
diff --git a/net-libs/xulrunner/ChangeLog b/net-libs/xulrunner/ChangeLog
index f3ea2db18256..709d38327161 100644
--- a/net-libs/xulrunner/ChangeLog
+++ b/net-libs/xulrunner/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/xulrunner
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.37 2007/07/10 20:19:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.38 2007/07/20 19:54:14 armin76 Exp $
+
+*xulrunner-1.8.1.5 (20 Jul 2007)
+
+ 20 Jul 2007; Raúl Porcel <armin76@gentoo.org> +xulrunner-1.8.1.5.ebuild:
+ Version bump wrt security #185737
10 Jul 2007; Raúl Porcel <armin76@gentoo.org> xulrunner-1.8.1.4.ebuild:
alpha stable
diff --git a/net-libs/xulrunner/files/digest-xulrunner-1.8.1.5 b/net-libs/xulrunner/files/digest-xulrunner-1.8.1.5
new file mode 100644
index 000000000000..5c401003681d
--- /dev/null
+++ b/net-libs/xulrunner/files/digest-xulrunner-1.8.1.5
@@ -0,0 +1,6 @@
+MD5 413a2455ae80629fbe89a1f9f86c3f92 xulrunner-1.8.1.4-patches-0.2.tar.bz2 61239
+RMD160 8866fc8b1464613310bd1a34526237f5e58c315d xulrunner-1.8.1.4-patches-0.2.tar.bz2 61239
+SHA256 8f6d24d607352c9c138d7dc984d2e8e670b054a0b87c50c281cb4fc3d3e7c86f xulrunner-1.8.1.4-patches-0.2.tar.bz2 61239
+MD5 36d695002944f9e0873998597b746460 xulrunner-1.8.1.5-source.tar.bz2 35366483
+RMD160 01bbc021aa532780f981c18656401b032ddae066 xulrunner-1.8.1.5-source.tar.bz2 35366483
+SHA256 e9a503de19eef9839e1773a38d731ff61b231ff1ed0fe219816fb9d4e0d3ac7f xulrunner-1.8.1.5-source.tar.bz2 35366483
diff --git a/net-libs/xulrunner/xulrunner-1.8.1.5.ebuild b/net-libs/xulrunner/xulrunner-1.8.1.5.ebuild
new file mode 100644
index 000000000000..bc240ae08dcc
--- /dev/null
+++ b/net-libs/xulrunner/xulrunner-1.8.1.5.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.8.1.5.ebuild,v 1.1 2007/07/20 19:54:14 armin76 Exp $
+
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils makeedit multilib autotools mozconfig-2 java-pkg-opt-2
+PATCH="${PN}-1.8.1.4-patches-0.2"
+
+DESCRIPTION="Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications"
+HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
+SRC_URI="mirror://gentoo/${P}-source.tar.bz2
+ mirror://gentoo/${PATCH}.tar.bz2"
+
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.11.5
+ >=dev-libs/nspr-4.6.5-r1
+ java? ( >=virtual/jre-1.4 )"
+
+DEPEND="java? ( >=virtual/jdk-1.4 )
+ ${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/mozilla"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_CO_PROJECT=xulrunner
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+
+src_unpack() {
+ unpack ${P}-source.tar.bz2 ${PATCH}.tar.bz2
+
+ # Apply our patches
+ cd "${S}" || die "cd failed"
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patch
+
+ eautoreconf || die "failed running eautoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ mozconfig_annotate '' --enable-extensions="default,cookie,permissions,spellcheck"
+ mozconfig_annotate '' --enable-native-uconv
+ mozconfig_annotate '' --enable-image-encoder=all
+ mozconfig_annotate '' --enable-canvas
+ #mozconfig_annotate '' --enable-js-binary
+ mozconfig_annotate '' --enable-embedding-tests
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --with-system-bz2
+ mozconfig_annotate '' --enable-jsd
+ mozconfig_annotate '' --enable-xpctools
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.
+ mozconfig_annotate '' --enable-oji --enable-mathml
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+
+ #disable java
+ if ! use java ; then
+ mozconfig_annotate '-java' --disable-javaxpcom
+ fi
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # -fstack-protector breaks us
+ if gcc-version ge 4 1; then
+ gcc-specs-ssp && append-flags -fno-stack-protector
+ else
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ fi
+ filter-flags -fstack-protector -fstack-protector-all
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
+ ${S}/config/autoconf.mk \
+ ${S}/xpfe/global/buildconfig.html
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ X_DATE=`date +%Y%m%d`
+
+ # Add Gentoo package version to preferences - copied from debian rules
+ echo // Gentoo package version \
+ > ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+ echo "pref(\"general.useragent.product\",\"Gecko\");" \
+ >> ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+ echo "pref(\"general.useragent.productSub\",\"${X_DATE}\");" \
+ >> ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+ echo "pref(\"general.useragent.productComment\",\"Gentoo\");" \
+ >> ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+
+ if use java ; then
+ java-pkg_dojar ${D}${MOZILLA_FIVE_HOME}/javaxpcom.jar
+ rm -f ${D}${MOZILLA_FIVE_HOME}/javaxpcom.jar
+ fi
+
+ # xulrunner registration, the gentoo way
+ insinto /etc/gre.d
+ newins ${FILESDIR}/${PN}.conf ${PV}.conf
+ sed -i -e \
+ "s|version|${PV}|
+ s|instpath|${MOZILLA_FIVE_HOME}|" \
+ ${D}/etc/gre.d/${PV}.conf
+}
+
+pkg_postinst() {
+ elog "Please remember to rebuild any packages that you have built"
+ elog "against xulrunner. Some packages might be broken by the upgrade; if this"
+ elog "is the case, please search at http://bugs.gentoo.org and open a new bug"
+ elog "if one does not exist."
+}