summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-06-22 19:28:34 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-06-22 19:28:34 +0000
commit2f00656d690c30379fb5973b40913ce58380ac3f (patch)
treeae4e3b65adc8449f20aa965a2d9fd64bb6e43ebf /net-libs
parentVersion bump to latest ptlib, prep for opal bump needed for libav9. (diff)
downloadgentoo-2-2f00656d690c30379fb5973b40913ce58380ac3f.tar.gz
gentoo-2-2f00656d690c30379fb5973b40913ce58380ac3f.tar.bz2
gentoo-2-2f00656d690c30379fb5973b40913ce58380ac3f.zip
Version bump to 3.12.4 to build with libav9. Fixes bug#443206.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/opal/ChangeLog9
-rw-r--r--net-libs/opal/files/opal-3.12.4-avoid_cflags_mixup.patch132
-rw-r--r--net-libs/opal/files/opal-3.12.4-java-ruby-swig-fix.patch28
-rw-r--r--net-libs/opal/opal-3.12.4.ebuild235
4 files changed, 403 insertions, 1 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index a0f3be0a91fc..796fe78cfd15 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.93 2013/04/05 18:12:12 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.94 2013/06/22 19:28:34 scarabeus Exp $
+
+*opal-3.12.4 (22 Jun 2013)
+
+ 22 Jun 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/opal-3.12.4-avoid_cflags_mixup.patch,
+ +files/opal-3.12.4-java-ruby-swig-fix.patch, +opal-3.12.4.ebuild:
+ Version bump to 3.12.4 to build with libav9. Fixes bug#443206.
05 Apr 2013; Agostino Sarubbo <ago@gentoo.org> opal-3.10.10.ebuild:
Stable for ppc64, wrt bug #461842
diff --git a/net-libs/opal/files/opal-3.12.4-avoid_cflags_mixup.patch b/net-libs/opal/files/opal-3.12.4-avoid_cflags_mixup.patch
new file mode 100644
index 000000000000..24686110a42e
--- /dev/null
+++ b/net-libs/opal/files/opal-3.12.4-avoid_cflags_mixup.patch
@@ -0,0 +1,132 @@
+diff -urN opal-3.12.4.old/plugins/plugin-inc.mak.in opal-3.12.4/plugins/plugin-inc.mak.in
+--- opal-3.12.4.old/plugins/plugin-inc.mak.in 2013-06-22 21:14:01.528580888 +0200
++++ opal-3.12.4/plugins/plugin-inc.mak.in 2013-06-22 21:14:42.652579425 +0200
+@@ -32,11 +32,13 @@
+ CXX := @CXX@
+ INSTALL := @INSTALL@
+ CFLAGS += @CFLAGS@ -I@prefix@/include -I$(PLUGINDIR)/../include -I$(PLUGINDIR)
++CXXFLAGS += @CXXFLAGS@ -I@prefix@/include -I$(PLUGINDIR)/../include -I$(PLUGINDIR)
+ LDFLAGS += @LDFLAGS@ @LDSO@
+ PLUGINEXT :=@PLUGINEXT@
+
+ ifneq ($(DEBUG),)
+ CFLAGS += -g
++CXXFLAGS += -g
+ endif
+
+ OBJDIR := $(PLUGINDIR)/../lib_@target@/plugins/$(BASENAME)
+@@ -65,11 +67,11 @@
+
+ $(OBJDIR)/%.o : %.cxx
+ @mkdir -p $(OBJDIR) >/dev/null 2>&1
+- $(Q_CC)$(CXX) -c $(CXXFLAGS) $(CFLAGS) -o $@ $<
++ $(Q_CC)$(CXX) -c $(CXXFLAGS) -o $@ $<
+
+ $(OBJDIR)/%.o : %.cpp
+ @mkdir -p $(OBJDIR) >/dev/null 2>&1
+- $(Q_CC)$(CXX) -c $(CXXFLAGS) $(CFLAGS) -o $@ $<
++ $(Q_CC)$(CXX) -c $(CXXFLAGS) -o $@ $<
+
+ OBJECTS = $(addprefix $(OBJDIR)/,$(patsubst %.cxx,%.o,$(patsubst %.cpp,%.o,$(patsubst %.c,%.o,$(notdir $(SRCS))))))
+
+diff -urN opal-3.12.4.old/plugins/video/H.261-vic/Makefile.in opal-3.12.4/plugins/video/H.261-vic/Makefile.in
+--- opal-3.12.4.old/plugins/video/H.261-vic/Makefile.in 2013-06-22 21:14:01.503580889 +0200
++++ opal-3.12.4/plugins/video/H.261-vic/Makefile.in 2013-06-22 21:14:42.652579425 +0200
+@@ -39,7 +39,7 @@
+ $(SRCDIR)/bv.c \
+
+
+-CFLAGS += -I$(COMMONDIR)
++CXXFLAGS += -I$(COMMONDIR)
+
+ INSTALL_DIR := @VC_PLUGIN_DIR@
+ PLUGINDIR := @PLUGINDIR@
+diff -urN opal-3.12.4.old/plugins/video/H.263-1998/Makefile.in opal-3.12.4/plugins/video/H.263-1998/Makefile.in
+--- opal-3.12.4.old/plugins/video/H.263-1998/Makefile.in 2013-06-22 21:14:01.499580889 +0200
++++ opal-3.12.4/plugins/video/H.263-1998/Makefile.in 2013-06-22 21:16:18.196576026 +0200
+@@ -34,12 +34,12 @@
+ $(COMMONDIR)/ffmpeg.cxx \
+ $(COMMONDIR)/dyna.cxx
+
+-CFLAGS += @LIBAVCODEC_CFLAGS@ -I$(COMMONDIR)
++CXXFLAGS += @LIBAVCODEC_CFLAGS@ -I$(COMMONDIR)
+ LIBS += @LIBAVCODEC_LIBS@ @LIBAVUTIL_LIBS@
+
+ HAVE_LIBAVCODEC_RTP_MODE=@HAVE_LIBAVCODEC_RTP_MODE@
+ ifeq ($(HAVE_LIBAVCODEC_RTP_MODE),yes)
+-CFLAGS += -DLIBAVCODEC_RTP_MODE=1
++CXXFLAGS += -DLIBAVCODEC_RTP_MODE=1
+ endif
+
+ vpath %.cxx $(COMMONDIR)
+diff -urN opal-3.12.4.old/plugins/video/H.264/gpl/Makefile.in opal-3.12.4/plugins/video/H.264/gpl/Makefile.in
+--- opal-3.12.4.old/plugins/video/H.264/gpl/Makefile.in 2013-06-22 21:14:01.500580889 +0200
++++ opal-3.12.4/plugins/video/H.264/gpl/Makefile.in 2013-06-22 21:16:35.515575410 +0200
+@@ -48,7 +48,7 @@
+
+ CC =@CC@
+ CXX =@CXX@
+-CFLAGS =@X264_CFLAGS@ @LIBAVCODEC_CFLAGS@ -I.. -I$(PLUGINDIR) -I$(OPALDIR)/include -DGPL_HELPER_APP -DPLUGINCODEC_TRACING
++CXXFLAGS =@X264_CFLAGS@ @LIBAVCODEC_CFLAGS@ -I.. -I$(PLUGINDIR) -I$(OPALDIR)/include -DGPL_HELPER_APP -DPLUGINCODEC_TRACING
+ LDFLAGS = @X264_LIBS@ @LIBAVCODEC_LIBS@ @LIBAVUTIL_LIBS@ @DL_LIBS@ @LDFLAGS@
+
+
+@@ -61,7 +61,7 @@
+
+ $(OBJDIR)/%.o : %.cxx
+ @mkdir -p $(OBJDIR) >/dev/null 2>&1
+- $(Q_CC)$(CXX) $(CFLAGS) -c $< -o $@
++ $(Q_CC)$(CXX) $(CXXFLAGS) -c $< -o $@
+
+ $(OBJDIR)/%.o : %.c
+ @mkdir -p $(OBJDIR) >/dev/null 2>&1
+diff -urN opal-3.12.4.old/plugins/video/H.264/Makefile.in opal-3.12.4/plugins/video/H.264/Makefile.in
+--- opal-3.12.4.old/plugins/video/H.264/Makefile.in 2013-06-22 21:14:01.500580889 +0200
++++ opal-3.12.4/plugins/video/H.264/Makefile.in 2013-06-22 21:16:52.874574792 +0200
+@@ -35,12 +35,12 @@
+ $(COMMONDIR)/ffmpeg.cxx \
+ $(COMMONDIR)/dyna.cxx
+
+-CFLAGS += @LIBAVCODEC_CFLAGS@ -I$(COMMONDIR) -DLIB_DIR='"$(libdir)"' -DVC_PLUGIN_DIR='"@VC_PLUGIN_DIR@"'
++CXXFLAGS += @LIBAVCODEC_CFLAGS@ -I$(COMMONDIR) -DLIB_DIR='"$(libdir)"' -DVC_PLUGIN_DIR='"@VC_PLUGIN_DIR@"'
+ LIBS += @LIBAVCODEC_LIBS@ @LIBAVUTIL_LIBS@
+
+ IS_H264_LICENSED:=@IS_H264_LICENSED@
+ ifeq ($(IS_H264_LICENSED),yes)
+- CFLAGS += @X264_CFLAGS@ -DX264_LICENSED
++ CXXFLAGS += @X264_CFLAGS@ -DX264_LICENSED
+ LIBS += @X264_LIBS@
+ else
+ SUBDIRS := gpl
+diff -urN opal-3.12.4.old/plugins/video/MPEG4-ffmpeg/Makefile.in opal-3.12.4/plugins/video/MPEG4-ffmpeg/Makefile.in
+--- opal-3.12.4.old/plugins/video/MPEG4-ffmpeg/Makefile.in 2013-06-22 21:14:01.499580889 +0200
++++ opal-3.12.4/plugins/video/MPEG4-ffmpeg/Makefile.in 2013-06-22 21:15:53.183576916 +0200
+@@ -32,14 +32,14 @@
+ $(COMMONDIR)/ffmpeg.cxx \
+ $(COMMONDIR)/dyna.cxx
+
+-CFLAGS += @LIBAVCODEC_CFLAGS@ -I$(COMMONDIR)
++CXXFLAGS += @LIBAVCODEC_CFLAGS@ -I$(COMMONDIR)
+ LIBS += @LIBAVCODEC_LIBS@ @LIBAVUTIL_LIBS@
+
+ # Add LIBAVCODEC_SOURCE_DIR to the include path so we can #include <libavcodec/...h>
+ # Also add libavutil, so ffmpeg headers can #include "log.h".
+ LIBAVCODEC_SOURCE_DIR := @LIBAVCODEC_SOURCE_DIR@
+ ifneq (,$(LIBAVCODEC_SOURCE_DIR))
+-CFLAGS += -I$(LIBAVCODEC_SOURCE_DIR) -I$(LIBAVCODEC_SOURCE_DIR)/libavutil
++CXXFLAGS += -I$(LIBAVCODEC_SOURCE_DIR) -I$(LIBAVCODEC_SOURCE_DIR)/libavutil
+ endif
+
+ vpath %.cxx $(COMMONDIR)
+diff -urN opal-3.12.4.old/plugins/video/THEORA/Makefile.in opal-3.12.4/plugins/video/THEORA/Makefile.in
+--- opal-3.12.4.old/plugins/video/THEORA/Makefile.in 2013-06-22 21:14:01.503580889 +0200
++++ opal-3.12.4/plugins/video/THEORA/Makefile.in 2013-06-22 21:14:42.654579425 +0200
+@@ -30,7 +30,7 @@
+ SRCDIR := .
+ SRCS := theora_frame.cxx theora_plugin.cxx
+
+-CFLAGS += @THEORA_CFLAGS@ -I$(COMMONDIR)
++CXXFLAGS += @THEORA_CFLAGS@ -I$(COMMONDIR)
+ LIBS += @THEORA_LIBS@
+
+ INSTALL_DIR := @VC_PLUGIN_DIR@
diff --git a/net-libs/opal/files/opal-3.12.4-java-ruby-swig-fix.patch b/net-libs/opal/files/opal-3.12.4-java-ruby-swig-fix.patch
new file mode 100644
index 000000000000..616468ea5772
--- /dev/null
+++ b/net-libs/opal/files/opal-3.12.4-java-ruby-swig-fix.patch
@@ -0,0 +1,28 @@
+--- opal-3.12.4.old/make/toplevel.mak.in 2013-06-22 21:14:01.536580887 +0200
++++ opal-3.12.4/make/toplevel.mak.in 2013-06-22 21:21:08.342565703 +0200
+@@ -407,9 +407,9 @@
+ ifeq ($(OPAL_JAVA), yes)
+
+ JAVA_SRCDIR = $(OPAL_SRCDIR)/java
+-JAVA_WRAPPER = $(JAVA_SRCDIR)/java_swig_wrapper.c
++JAVA_WRAPPER = $(JAVA_SRCDIR)/java_swig_wrapper.cxx
+
+-VPATH_C += $(JAVA_SRCDIR)
++VPATH_CXX += $(JAVA_SRCDIR)
+ SOURCES += $(JAVA_WRAPPER)
+
+ endif
+@@ -420,10 +420,10 @@
+
+ ifeq ($(OPAL_RUBY), yes)
+
+-RUBY_SRCDIR = $(OPAL_SRCDIR)/ruby
+-RUBY_WRAPPER = $(JAVA_SRCDIR)/ruby_swig_wrapper.c
++RUBY_SRCDIR = $(OPAL_SRCDIR)/Ruby
++RUBY_WRAPPER = $(JAVA_SRCDIR)/ruby_swig_wrapper.cxx
+
+-VPATH_C += $(RUBY_SRCDIR)
++VPATH_CXX += $(RUBY_SRCDIR)
+ SOURCES += $(RUBY_WRAPPER)
+
+ endif
diff --git a/net-libs/opal/opal-3.12.4.ebuild b/net-libs/opal/opal-3.12.4.ebuild
new file mode 100644
index 000000000000..b4a214f6404a
--- /dev/null
+++ b/net-libs/opal/opal-3.12.4.ebuild
@@ -0,0 +1,235 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-3.12.4.ebuild,v 1.1 2013/06/22 19:28:34 scarabeus Exp $
+
+EAPI=5
+
+inherit eutils autotools toolchain-funcs java-pkg-opt-2 flag-o-matic
+
+DESCRIPTION="C++ class library normalising numerous telephony protocols"
+HOMEPAGE="http://www.opalvoip.org/"
+SRC_URI="mirror://sourceforge/opalvoip/${P}.tar.bz2
+ doc? ( mirror://sourceforge/opalvoip/${P}-htmldoc.tar.bz2 )"
+
+LICENSE="MPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+audio capi celt debug doc +dtmf examples fax ffmpeg h224 h281 h323 iax
+ilbc ipv6 ivr ixj java ldap lid +plugins sbc sip sipim srtp ssl static-libs
+stats swig theora +video vpb vxml wav x264 x264-static xml"
+
+REQUIRED_USE="x264-static? ( x264 )
+ h281? ( h224 )
+ sip? ( sipim )"
+
+RDEPEND=">=net-libs/ptlib-2.12.4:=[stun,debug=,audio?,dtmf,http,ipv6?,ldap?,ssl?,video?,vxml?,wav?,xml?]
+ >=media-libs/speex-1.2_beta
+ fax? ( net-libs/ptlib[asn] )
+ h323? ( net-libs/ptlib[asn] )
+ ivr? ( net-libs/ptlib[http,xml,vxml] )
+ java? ( >=virtual/jre-1.4 )
+ plugins? (
+ media-sound/gsm
+ capi? ( net-dialup/capi4k-utils )
+ celt? ( media-libs/celt )
+ ffmpeg? ( virtual/ffmpeg[encode] )
+ ixj? ( sys-kernel/linux-headers )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ sbc? ( media-libs/libsamplerate )
+ theora? ( media-libs/libtheora )
+ x264? ( virtual/ffmpeg
+ media-libs/x264 ) )
+ srtp? ( net-libs/libsrtp )
+ vxml? ( net-libs/ptlib[http,vxml] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/gcc-3
+ java? ( swig? ( dev-lang/swig )
+ >=virtual/jdk-1.4 )"
+
+# NOTES:
+# ffmpeg[encode] is for h263 and mpeg4
+# ssl, xml, vxml, ipv6, ldap, audio, wav, and video are use flags
+# herited from ptlib: feature is enabled if ptlib has enabled it
+# however, disabling it if ptlib has it looks hard (coz of buildopts.h)
+# forcing ptlib to disable it for opal is not a solution too
+# atm, accepting the "auto-feature" looks like a good solution
+# (asn is used for fax and config _only_ for examples)
+# OPALDIR should not be used anymore but if a package still need it, create it
+
+pkg_setup() {
+ # workaround for bug 282838
+ append-cxxflags "-fno-visibility-inlines-hidden"
+ append-cxxflags "-fno-strict-aliasing"
+
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ # remove visual studio related files from samples/
+ if use examples; then
+ rm -f samples/*/*.vcproj
+ rm -f samples/*/*.sln
+ rm -f samples/*/*.dsp
+ rm -f samples/*/*.dsw
+ fi
+
+ epatch "${FILESDIR}/${PN}-3.10.9-svn_revision_override.patch"
+ epatch "${FILESDIR}/${PN}-3.10.9-labs_is_in_stdlib.patch"
+ epatch "${FILESDIR}/${PN}-3.12.4-avoid_cflags_mixup.patch"
+
+ if ! use h323; then
+ # Without this patch, ekiga wont compile, even with
+ # USE=-h323.
+ epatch "${FILESDIR}/${PN}-3.10.9-disable-h323-workaround.patch"
+ fi
+
+ epatch "${FILESDIR}/${PN}-3.12.4-java-ruby-swig-fix.patch"
+
+ sed -i -e "s:\(.*HAS_H224.*\), \[OPAL_H323\]:\1:" configure.ac \
+ || die "sed failed"
+
+ eaclocal
+ eautoconf
+
+ # in plugins
+ cd plugins/
+ eaclocal
+ eautoconf
+ cd ..
+
+ # disable celt if celt is not enabled (prevent auto magic dep)
+ # already in repository
+ if ! use celt; then
+ sed -i -e "s/HAVE_CELT=yes/HAVE_CELT=no/" plugins/configure \
+ || die "sed failed"
+ fi
+
+ # fix automatic swig detection, upstream bug 2712521 (upstream reject it)
+ if ! use swig; then
+ sed -i -e "/^SWIG=/d" configure || die "patching configure failed"
+ fi
+
+ use ilbc || { rm -r plugins/audio/iLBC/ || die "removing iLBC failed"; }
+
+ java-pkg-opt-2_src_prepare
+}
+
+src_configure() {
+ # --with-libavcodec-source-dir should _not_ be set, it's for trunk sources
+ # versioncheck: check for ptlib version
+ # shared: should always be enabled for a lib
+ # localspeex, localspeexdsp, localgsm, localilbc: never use bundled libs
+ # samples: only build some samples, useless
+ # libavcodec-stackalign-hack: prevent hack (default disable by upstream)
+ # default-to-full-capabilties: default enable by upstream
+ # aec: atm, only used when bundled speex, so it's painless for us
+ # zrtp doesn't depend on net-libs/libzrtpcpp but on libzrtp from
+ # http://zfoneproject.com/ wich is not in portage
+ # msrp: highly experimental
+ # spandsp: doesn't work with newest spandsp, upstream bug 2796047
+ # g711plc: force enable
+ # rfc4103: not really used, upstream bug 2795831
+ # t38, spandsp: merged in fax
+ # h450, h460, h501: merged in h323 (they are additional features of h323)
+ econf \
+ --enable-versioncheck \
+ --enable-shared \
+ --disable-zrtp \
+ --disable-localspeex \
+ --disable-localspeexdsp \
+ --disable-localgsm \
+ --disable-localilbc \
+ --disable-samples \
+ --disable-libavcodec-stackalign-hack \
+ --enable-default-to-full-capabilties \
+ --enable-aec \
+ --disable-msrp \
+ --disable-spandsp \
+ --enable-g711plc \
+ --enable-rfc4103 \
+ $(use_enable debug) \
+ $(use_enable capi) \
+ $(use_enable fax) \
+ $(use_enable fax t38) \
+ $(use_enable h224) \
+ $(use_enable h281) \
+ $(use_enable h323) \
+ $(use_enable h323 h450) \
+ $(use_enable h323 h460) \
+ $(use_enable h323 h501) \
+ $(use_enable iax) \
+ $(use_enable ivr) \
+ $(use_enable ixj) \
+ $(use_enable java) \
+ $(use_enable lid) \
+ $(use_enable plugins) \
+ $(use_enable sbc) \
+ $(use_enable sip) \
+ $(use_enable sipim) \
+ $(use_enable stats statistics) \
+ $(use_enable video) $(use_enable video rfc4175) \
+ $(use_enable vpb) \
+ $(use_enable x264 h264) \
+ $(use_enable x264-static x264-link-static)
+}
+
+src_compile() {
+ local makeopts=""
+
+ use debug && makeopts="debug"
+
+ emake ${makeopts}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Get rid of static libraries if not requested
+ # There seems to be no easy way to disable this in the build system
+ if ! use static-libs; then
+ rm -v "${D}"/usr/lib*/*.a || die
+ fi
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/html/* docs/*
+ fi
+
+ # ChangeLog is not standard and does not exist on 3.10.10
+# dodoc ChangeLog-${PN}-v${PV//./_}.txt || die "dodoc failed"
+
+ if use examples; then
+ local exampledir="/usr/share/doc/${PF}/examples"
+ local basedir="samples"
+ local sampledirs="`ls ${basedir} --hide=configure* \
+ --hide=opal_samples.mak.in`"
+
+ # first, install files
+ insinto ${exampledir}/
+ doins ${basedir}/{configure*,opal_samples*}
+
+ # now, all examples
+ for x in ${sampledirs}; do
+ insinto ${exampledir}/${x}/
+ doins ${basedir}/${x}/*
+ done
+
+ # some examples need version.h
+ insinto "/usr/share/doc/${PF}/"
+ doins version.h
+ fi
+}
+
+pkg_postinst() {
+ if use examples; then
+ ewarn "All examples have been installed, some of them will not work on your system"
+ ewarn "it will depend of the enabled USE flags in ptlib and opal"
+ fi
+
+ if ! use plugins || ! use audio || ! use video; then
+ ewarn "You have disabled audio, video or plugins USE flags."
+ ewarn "Most audio/video features or plugins have been disabled silently"
+ ewarn "even if enabled via USE flags."
+ ewarn "Having a feature enabled via USE flag but disabled can lead to issues."
+ fi
+}