summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-29 22:26:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-29 22:26:24 +0000
commit3f6678245f9f9bcb31c6b68fe93d7fcb144eec40 (patch)
tree9c90712cb656f6843605515cccac53433a9b10d7 /net-libs
parentStable on amd64. (diff)
downloadgentoo-2-3f6678245f9f9bcb31c6b68fe93d7fcb144eec40.tar.gz
gentoo-2-3f6678245f9f9bcb31c6b68fe93d7fcb144eec40.tar.bz2
gentoo-2-3f6678245f9f9bcb31c6b68fe93d7fcb144eec40.zip
Added patch to fix warnings (errors) about integer/pointer mismatch.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog6
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch24
-rw-r--r--net-libs/libtorrent/libtorrent-0.6.2.ebuild7
3 files changed, 33 insertions, 4 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index c910f25274d5..eff86b3e4a96 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.8 2005/05/25 11:57:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.9 2005/05/29 22:26:24 flameeyes Exp $
+
+ 29 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libtorrent-0.6.2-warns.patch, libtorrent-0.6.2.ebuild:
+ Added patch to fix warnings (errors) about integer/pointer mismatch.
25 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+files/libtorrent-0.6.2-fbsd.patch, libtorrent-0.6.2.ebuild:
diff --git a/net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch b/net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch
new file mode 100644
index 000000000000..a87ac23cff64
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch
@@ -0,0 +1,24 @@
+diff -x '*~' -ur libtorrent-0.6.2/src/data/file.cc libtorrent-0.6.2-gcc4/src/data/file.cc
+--- libtorrent-0.6.2/src/data/file.cc 2005-04-21 20:39:39.000000000 +0200
++++ libtorrent-0.6.2-gcc4/src/data/file.cc 2005-05-30 00:08:45.358865976 +0200
+@@ -102,7 +102,7 @@
+
+ if (((prot & MemoryChunk::prot_read) && !is_readable()) ||
+ ((prot & MemoryChunk::prot_write) && !is_writable())) {
+- int buf = get_size();
++ off_t buf = get_size();
+
+ throw internal_error(std::string((char*)buf, 4));
+ // throw internal_error("File::get_chunk() permission denied");
+diff -x '*~' -ur libtorrent-0.6.2/src/data/memory_chunk.cc libtorrent-0.6.2-gcc4/src/data/memory_chunk.cc
+--- libtorrent-0.6.2/src/data/memory_chunk.cc 2005-04-14 21:45:04.000000000 +0200
++++ libtorrent-0.6.2-gcc4/src/data/memory_chunk.cc 2005-05-29 23:51:27.853590752 +0200
+@@ -53,7 +53,7 @@
+ if (page_align() >= m_pagesize)
+ throw internal_error("MemoryChunk::MemoryChunk(...) received an page alignment >= page size");
+
+- if ((uint32_t)ptr % m_pagesize)
++ if ((ptrdiff_t)ptr % m_pagesize)
+ throw internal_error("MemoryChunk::MemoryChunk(...) is not aligned to a page");
+ }
+
diff --git a/net-libs/libtorrent/libtorrent-0.6.2.ebuild b/net-libs/libtorrent/libtorrent-0.6.2.ebuild
index cba52dccfbec..e028f95a826e 100644
--- a/net-libs/libtorrent/libtorrent-0.6.2.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.6.2.ebuild,v 1.2 2005/05/25 11:57:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.6.2.ebuild,v 1.3 2005/05/29 22:26:24 flameeyes Exp $
inherit eutils
@@ -23,6 +23,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-fbsd.patch
+ epatch ${FILESDIR}/${P}-warns.patch
./autogen.sh
}
@@ -31,8 +32,8 @@ src_compile() {
econf \
$(use_enable debug) \
--disable-dependency-tracking \
- || die
- emake || die
+ || die "econf failed"
+ emake || die "emake failed"
}
src_install() {