summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-02 18:49:36 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-02 18:49:36 +0000
commit5727b5bfb775082011bb554b4988333ad64b772f (patch)
tree678cf96796300258336d79ac61407ad7d185b2e5 /net-libs
parentDummy commit to sign manifest. (diff)
downloadgentoo-2-5727b5bfb775082011bb554b4988333ad64b772f.tar.gz
gentoo-2-5727b5bfb775082011bb554b4988333ad64b772f.tar.bz2
gentoo-2-5727b5bfb775082011bb554b4988333ad64b772f.zip
Drop old and add a comment to last 0.5 version to check in next bump with parallel installation again as upstream thinks 0.5.x could fix it.
(Portage version: 2.1.11.3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/ChangeLog8
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild131
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.5.0-r1.ebuild4
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild162
4 files changed, 8 insertions, 297 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index 2c9029b25790..19947cf2414a 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.90 2012/05/24 14:06:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.91 2012/07/02 18:49:36 pacho Exp $
+
+ 02 Jul 2012; Pacho Ramos <pacho@gentoo.org> -gtk-vnc-0.4.3-r1.ebuild,
+ -gtk-vnc-0.5.0.ebuild, gtk-vnc-0.5.0-r1.ebuild:
+ Drop old and add a comment to last 0.5 version to check in next bump with
+ parallel installation again as upstream thinks 0.5.x could fix it.
24 May 2012; Samuli Suominen <ssuominen@gentoo.org> gtk-vnc-0.5.0-r1.ebuild:
ppc stable wrt #410611
@@ -366,4 +371,3 @@
+gtk-vnc-0.2.0.ebuild:
(#189824) Add VNC widget for GTK+, based on the work of Jiri Tyr. This is a
dep of new virt-manager.
-
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild
deleted file mode 100644
index 6ad337ecbf93..000000000000
--- a/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild,v 1.10 2012/05/05 02:54:31 jdhore Exp $
-
-EAPI="3"
-
-inherit eutils base gnome.org python
-
-DESCRIPTION="VNC viewer widget for GTK"
-HOMEPAGE="http://live.gnome.org/gtk-vnc"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="examples gtk3 +introspection python sasl"
-
-# libview is used in examples/gvncviewer -- no need
-# TODO: review nsplugin when it will be considered less experimental
-
-COMMON_DEPEND=">=dev-libs/glib-2.10:2
- >=dev-libs/libgcrypt-1.4.2
- dev-libs/libgpg-error
- >=net-libs/gnutls-1.4
- >=x11-libs/cairo-1.2
- >=x11-libs/gtk+-2.18:2
- x11-libs/libX11
- gtk3? ( >=x11-libs/gtk+-2.91.3:3 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.4 )
- python? ( >=dev-python/pygtk-2:2 )
- sasl? ( dev-libs/cyrus-sasl )"
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${COMMON_DEPEND}
- >=dev-lang/perl-5
- virtual/pkgconfig
- sys-devel/gettext
- >=dev-util/intltool-0.40"
-
-GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
-GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- python_convert_shebangs -r 2 .
- mkdir "${GTK2_BUILDDIR}" || die
- mkdir "${GTK3_BUILDDIR}" || die
-
- # Remove a few files that were autogenerated during distcheck.
- # Having these around in srcdir breaks out of tree build since they're
- # expected to be in builddir, which is correct for trunk builds since
- # they're generated files, not source files. Funny false dichotomy.
- rm -vf "${S}"/src/{vncconnectionenums.[ch],vncdisplayenums.[ch]}
-
- # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk
- sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
- -i src/Makefile.* || die
-}
-
-src_configure() {
- local myconf
- myconf="
- $(use_with examples) \
- $(use_enable introspection) \
- $(use_with sasl) \
- --with-coroutine=gthread \
- --without-libview \
- --disable-static"
-
- cd ${GTK2_BUILDDIR}
- einfo "Running configure in ${GTK2_BUILDDIR}"
- ECONF_SOURCE="${S}" econf ${myconf} \
- $(use_with python) \
- --with-gtk=2.0
-
- if use gtk3; then
- cd ${GTK3_BUILDDIR}
- einfo "Running configure in ${GTK3_BUILDDIR}"
- # Python support is via gobject-introspection
- # Ex: from gi.repository import GtkVnc
- ECONF_SOURCE="${S}" econf ${myconf} \
- --with-python=no \
- --with-gtk=3.0
- fi
-}
-
-src_compile() {
- cd ${GTK2_BUILDDIR}
- einfo "Running make in ${GTK2_BUILDDIR}"
- emake || die
-
- if use gtk3; then
- cd ${GTK3_BUILDDIR}
- einfo "Running make in ${GTK3_BUILDDIR}"
- emake || die
- fi
-}
-
-src_test() {
- cd ${GTK2_BUILDDIR}
- einfo "Running make check in ${GTK2_BUILDDIR}"
- emake check || die
-
- if use gtk3; then
- cd ${GTK3_BUILDDIR}
- einfo "Running make check in ${GTK3_BUILDDIR}"
- emake check || die
- fi
-}
-
-src_install() {
- dodoc AUTHORS ChangeLog NEWS README || die
-
- cd ${GTK2_BUILDDIR}
- einfo "Running make install in ${GTK2_BUILDDIR}"
- # bug #328273
- MAKEOPTS="${MAKEOPTS} -j1" base_src_install
-
- if use gtk3; then
- cd ${GTK3_BUILDDIR}
- einfo "Running make install in ${GTK3_BUILDDIR}"
- # bug #328273
- MAKEOPTS="${MAKEOPTS} -j1" base_src_install
- fi
-
- python_clean_installation_image
-
- # Remove .la files
- find "${ED}" -name '*.la' -exec rm -f '{}' + || die
-}
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.5.0-r1.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.5.0-r1.ebuild
index bed40a2a114e..9d6c17bf735d 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.5.0-r1.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.0-r1.ebuild,v 1.6 2012/05/24 14:06:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.0-r1.ebuild,v 1.7 2012/07/02 18:49:36 pacho Exp $
EAPI="4"
@@ -156,7 +156,7 @@ src_install() {
cd ${GTK2_BUILDDIR}
einfo "Running make install in ${GTK2_BUILDDIR}"
- # bug #328273
+ # bug #328273, try again parallel installation in next testing version
MAKEOPTS="${MAKEOPTS} -j1" base_src_install
if use gtk3; then
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild
deleted file mode 100644
index 64efe71e50d9..000000000000
--- a/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild,v 1.6 2012/05/05 02:54:31 jdhore Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="python? 2"
-
-inherit base eutils gnome.org python
-
-DESCRIPTION="VNC viewer widget for GTK"
-HOMEPAGE="http://live.gnome.org/gtk-vnc"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="examples gtk3 +introspection python sasl vala"
-
-# libview is used in examples/gvncviewer -- no need
-# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129)
-# TODO: review nsplugin when it will be considered less experimental
-# XXX: automagic pulseaudio. Is it worth patching?
-COMMON_DEPEND=">=dev-libs/glib-2.30.1:2
- >=dev-libs/libgcrypt-1.4.2
- dev-libs/libgpg-error
- media-sound/pulseaudio
- >=net-libs/gnutls-1.4
- >=x11-libs/cairo-1.2
- >=x11-libs/gtk+-2.18:2
- x11-libs/libX11
- gtk3? ( >=x11-libs/gtk+-2.91.3:3 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.4 )
- python? ( >=dev-python/pygtk-2:2 )
- sasl? ( dev-libs/cyrus-sasl )"
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${COMMON_DEPEND}
- >=dev-lang/perl-5
- virtual/pkgconfig
- sys-devel/gettext
- >=dev-util/intltool-0.40
- vala? (
- dev-lang/vala:0.14[vapigen]
- >=dev-libs/gobject-introspection-0.9.4 )
-"
-
-GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
-GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-
- if use vala && ! use gtk3; then
- ewarn "You must set USE=gtk3 to enable vala bindings support."
- fi
-}
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=667943
- epatch "${FILESDIR}/${PN}-0.5.0-pod.patch"
-
- python_convert_shebangs -r 2 .
- mkdir "${GTK2_BUILDDIR}" || die
- mkdir "${GTK3_BUILDDIR}" || die
-
- # Remove a few files that were autogenerated during distcheck.
- # Having these around in srcdir breaks out of tree build since they're
- # expected to be in builddir, which is correct for trunk builds since
- # they're generated files, not source files. Funny false dichotomy.
- rm -vf "${S}"/src/{vncconnectionenums.[ch],vncdisplayenums.[ch]}
-
- # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk
- sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
- -i src/Makefile.* || die
-
- # Work around https://bugzilla.gnome.org/show_bug.cgi?id=667941
- [[ -e GNUmakefile ]] || touch GNUmakefile
-}
-
-src_configure() {
- local myconf
- myconf="
- $(use_with examples) \
- $(use_enable introspection) \
- $(use_with sasl) \
- --with-coroutine=gthread \
- --without-libview \
- --disable-static \
- --disable-vala"
-
- cd ${GTK2_BUILDDIR}
- einfo "Running configure in ${GTK2_BUILDDIR}"
- ECONF_SOURCE="${S}" econf ${myconf} \
- $(use_with python) \
- --with-gtk=2.0
-
- if use gtk3; then
- if use vala; then
- myconf="${myconf} \
- --enable-introspection \
- --enable-vala \
- VAPIGEN=$(type -p vapigen-0.14)"
- fi
-
- cd ${GTK3_BUILDDIR}
- einfo "Running configure in ${GTK3_BUILDDIR}"
- # Python support is via gobject-introspection
- # Ex: from gi.repository import GtkVnc
- ECONF_SOURCE="${S}" econf ${myconf} \
- --with-python=no \
- --with-gtk=3.0
- fi
-}
-
-src_compile() {
- cd ${GTK2_BUILDDIR}
- einfo "Running make in ${GTK2_BUILDDIR}"
- # Work around https://bugzilla.gnome.org/show_bug.cgi?id=667941
- rm GNUmakefile
- emake
-
- if use gtk3; then
- cd ${GTK3_BUILDDIR}
- einfo "Running make in ${GTK3_BUILDDIR}"
- # Work around https://bugzilla.gnome.org/show_bug.cgi?id=667941
- rm GNUmakefile
- emake
- fi
-}
-
-src_test() {
- cd ${GTK2_BUILDDIR}
- einfo "Running make check in ${GTK2_BUILDDIR}"
- emake check
-
- if use gtk3; then
- cd ${GTK3_BUILDDIR}
- einfo "Running make check in ${GTK3_BUILDDIR}"
- emake check
- fi
-}
-
-src_install() {
- dodoc AUTHORS ChangeLog NEWS README
-
- cd ${GTK2_BUILDDIR}
- einfo "Running make install in ${GTK2_BUILDDIR}"
- # bug #328273
- MAKEOPTS="${MAKEOPTS} -j1" base_src_install
-
- if use gtk3; then
- cd ${GTK3_BUILDDIR}
- einfo "Running make install in ${GTK3_BUILDDIR}"
- # bug #328273
- MAKEOPTS="${MAKEOPTS} -j1" base_src_install
- fi
-
- python_clean_installation_image
-
- # Remove .la files
- find "${ED}" -name '*.la' -exec rm -f '{}' + || die
-}