summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2010-01-23 09:21:26 +0000
committerDawid Węgliński <cla@gentoo.org>2010-01-23 09:21:26 +0000
commit754ae896ea3ebb65af66d3f3f76c73bdcabad8a0 (patch)
tree75420c96fb508b0efc79b9467e34893d735e3505 /net-libs
parentwebrat has no task to build documentation. (diff)
downloadgentoo-2-754ae896ea3ebb65af66d3f3f76c73bdcabad8a0.tar.gz
gentoo-2-754ae896ea3ebb65af66d3f3f76c73bdcabad8a0.tar.bz2
gentoo-2-754ae896ea3ebb65af66d3f3f76c73bdcabad8a0.zip
Respect user CFLAGS (bug #241036), fix install phase if USE="examples"
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/polarssl/ChangeLog8
-rw-r--r--net-libs/polarssl/files/polarssl-0.12.0-makefile.patch13
-rw-r--r--net-libs/polarssl/polarssl-0.12.0.ebuild9
3 files changed, 25 insertions, 5 deletions
diff --git a/net-libs/polarssl/ChangeLog b/net-libs/polarssl/ChangeLog
index a0450f762842..dfee96051c7f 100644
--- a/net-libs/polarssl/ChangeLog
+++ b/net-libs/polarssl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/polarssl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.2 2009/09/23 18:50:54 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.3 2010/01/23 09:21:25 cla Exp $
+
+ 23 Jan 2010; Dawid Węgliński <cla@gentoo.org> polarssl-0.12.0.ebuild,
+ +files/polarssl-0.12.0-makefile.patch:
+ Respect user CFLAGS (bug #241036), fix install phase if USE="examples"
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> polarssl-0.12.0.ebuild:
Remove virtual/libc
diff --git a/net-libs/polarssl/files/polarssl-0.12.0-makefile.patch b/net-libs/polarssl/files/polarssl-0.12.0-makefile.patch
new file mode 100644
index 000000000000..807a27d3535e
--- /dev/null
+++ b/net-libs/polarssl/files/polarssl-0.12.0-makefile.patch
@@ -0,0 +1,13 @@
+diff -Naur polarssl-0.12.0.old/library/Makefile polarssl-0.12.0/library/Makefile
+--- polarssl-0.12.0.old/library/Makefile 2009-03-28 18:53:03.000000000 +0100
++++ polarssl-0.12.0/library/Makefile 2010-01-23 10:12:03.000000000 +0100
+@@ -1,8 +1,7 @@
+
+ # Also see "include/polarssl/config.h"
+
+-CFLAGS = -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement
+-OFLAGS = -O
++CFLAGS += -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement
+
+ # MicroBlaze specific options:
+ # CFLAGS += -mno-xl-soft-mul -mxl-barrel-shift
diff --git a/net-libs/polarssl/polarssl-0.12.0.ebuild b/net-libs/polarssl/polarssl-0.12.0.ebuild
index 57e0831b717e..351196012fa1 100644
--- a/net-libs/polarssl/polarssl-0.12.0.ebuild
+++ b/net-libs/polarssl/polarssl-0.12.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-0.12.0.ebuild,v 1.2 2009/09/23 18:50:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-0.12.0.ebuild,v 1.3 2010/01/23 09:21:25 cla Exp $
+
+inherit eutils
DESCRIPTION="Cryptographic library for embedded systems"
HOMEPAGE="http://polarssl.org/"
@@ -21,6 +23,7 @@ src_compile() {
else
sed -i '15iCFLAGS += -fPIC' Makefile
fi
+ epatch "${FILESDIR}"/${P}-makefile.patch
emake libpolarssl.a || die "emake failed"
emake libpolarssl.so || die "emake failed"
@@ -44,7 +47,7 @@ src_install() {
if use examples ; then
for p in programs/*/* ; do
- if [ -x "${p}" ] ; then
+ if [[ -x "${p}" && ! -d "${p}" ]] ; then
f=polarssl_`basename "${p}"`
newbin "${p}" "${f}" || die
fi