summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-01-10 12:15:44 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-01-10 12:15:44 +0000
commit77789b7b2c30e22bf15e0f81a035fd787d2a2ae0 (patch)
tree6cbd6c92e1753fdaa6a002e45decca0912ea61b0 /net-libs
parentVersion bump KDE SC 4.5.5 (diff)
downloadgentoo-2-77789b7b2c30e22bf15e0f81a035fd787d2a2ae0.tar.gz
gentoo-2-77789b7b2c30e22bf15e0f81a035fd787d2a2ae0.tar.bz2
gentoo-2-77789b7b2c30e22bf15e0f81a035fd787d2a2ae0.zip
Bump to 0.14.1 - latest stable, bunch of bug fixes.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp/ChangeLog9
-rw-r--r--net-libs/gupnp/gupnp-0.14.1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-libs/gupnp/ChangeLog b/net-libs/gupnp/ChangeLog
index 95741c8a2fbf..3f1edc95015e 100644
--- a/net-libs/gupnp/ChangeLog
+++ b/net-libs/gupnp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.31 2010/11/20 12:21:40 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.32 2011/01/10 12:15:44 ford_prefect Exp $
+
+*gupnp-0.14.1 (10 Jan 2011)
+
+ 10 Jan 2011; Arun Raghavan <ford_prefect@gentoo.org> +gupnp-0.14.1.ebuild:
+ Bump to 0.14.1 - latest stable, bunch of bug fixes.
20 Nov 2010; Michael Weber <xmw@gentoo.org> gupnp-0.13.4.ebuild:
Added ~arm keyword (bug 343505)
diff --git a/net-libs/gupnp/gupnp-0.14.1.ebuild b/net-libs/gupnp/gupnp-0.14.1.ebuild
new file mode 100644
index 000000000000..6037e93eff80
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.14.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/gupnp-0.14.1.ebuild,v 1.1 2011/01/10 12:15:44 ford_prefect Exp $
+
+EAPI=2
+
+DESCRIPTION="an object-oriented framework for creating UPnP devs and control points."
+HOMEPAGE="http://gupnp.org/"
+SRC_URI="http://gupnp.org/sites/all/files/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection networkmanager"
+
+RDEPEND=">=net-libs/gssdp-0.7.1[introspection?]
+ >=net-libs/libsoup-2.4.1:2.4[introspection?]
+ >=dev-libs/glib-2.18:2
+ dev-libs/libxml2
+ || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ networkmanager? ( >=dev-libs/dbus-glib-0.76 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ local backend=unix
+ use networkmanager && backend=network-manager
+
+ econf \
+ $(use_enable introspection) \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ --with-context-manager=${backend} \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}