summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-06-23 12:21:44 +0000
committerThomas Sachau <tommy@gentoo.org>2013-06-23 12:21:44 +0000
commit7d96e5bc032ba9801197823a4318ce3fee1b2d8b (patch)
tree5e9420c6d9196d796cbc864184076b7f2a4c6ba8 /net-libs
parentbump, py2.5 support dropped (upstream) (diff)
downloadgentoo-2-7d96e5bc032ba9801197823a4318ce3fee1b2d8b.tar.gz
gentoo-2-7d96e5bc032ba9801197823a4318ce3fee1b2d8b.tar.bz2
gentoo-2-7d96e5bc032ba9801197823a4318ce3fee1b2d8b.zip
Version bump, drop old, also fixes bug 473984
(Portage version: 2.2.0_alpha177-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/polarssl/ChangeLog9
-rw-r--r--net-libs/polarssl/polarssl-1.0.0.ebuild63
-rw-r--r--net-libs/polarssl/polarssl-1.1.3.ebuild67
-rw-r--r--net-libs/polarssl/polarssl-1.2.8.ebuild (renamed from net-libs/polarssl/polarssl-1.2.0.ebuild)7
4 files changed, 11 insertions, 135 deletions
diff --git a/net-libs/polarssl/ChangeLog b/net-libs/polarssl/ChangeLog
index cc92b11c2571..a3b749a451f5 100644
--- a/net-libs/polarssl/ChangeLog
+++ b/net-libs/polarssl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/polarssl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.44 2013/03/03 09:37:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.45 2013/06/23 12:21:44 tommy Exp $
+
+*polarssl-1.2.8 (23 Jun 2013)
+
+ 23 Jun 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -polarssl-1.0.0.ebuild, -polarssl-1.1.3.ebuild, -polarssl-1.2.0.ebuild,
+ +polarssl-1.2.8.ebuild:
+ Version bump, drop old, also fixes bug 473984
03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polarssl-1.2.5.ebuild:
Add s390 love.
diff --git a/net-libs/polarssl/polarssl-1.0.0.ebuild b/net-libs/polarssl/polarssl-1.0.0.ebuild
deleted file mode 100644
index f4914cc514a5..000000000000
--- a/net-libs/polarssl/polarssl-1.0.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.0.0.ebuild,v 1.1 2011/11/19 14:45:31 tommy Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="Cryptographic library for embedded systems"
-HOMEPAGE="http://polarssl.org/"
-SRC_URI="http://polarssl.org/code/download/${P}-gpl.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="examples sse2"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- cd library
- if use sse2 ; then
- sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
- else
- sed -i '15iCFLAGS += -fPIC' Makefile
- fi
-}
-
-src_compile() {
- emake -C library libpolarssl.so || die "emake failed"
-
- if use examples ; then
- emake -C programs all || die "emake failed"
- fi
-}
-
-src_test() {
- cd programs
- emake test/selftest || die "emake selftest failed"
- LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" ./test/selftest || die "selftest failed"
- cd "${S}"
- emake check || die
-}
-
-src_install() {
- insinto /usr/include/polarssl
- doins include/polarssl/*.h || die
- dolib.so library/libpolarssl.so || die
- dolib.a library/libpolarssl.a || die
-
- if use examples ; then
- for p in programs/*/* ; do
- if [[ -x "${p}" && ! -d "${p}" ]] ; then
- f=polarssl_`basename "${p}"`
- newbin "${p}" "${f}" || die
- fi
- done
- for e in aes hash pkey ssl test ; do
- docinto "${e}"
- dodoc programs/"${e}"/*.c || die
- dodoc programs/"${e}"/*.txt || die
- done
- fi
-}
diff --git a/net-libs/polarssl/polarssl-1.1.3.ebuild b/net-libs/polarssl/polarssl-1.1.3.ebuild
deleted file mode 100644
index 9e11100b3faa..000000000000
--- a/net-libs/polarssl/polarssl-1.1.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.1.3.ebuild,v 1.8 2012/11/17 18:26:11 tommy Exp $
-
-EAPI=2
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Cryptographic library for embedded systems"
-HOMEPAGE="http://polarssl.org/"
-SRC_URI="http://polarssl.org/code/download/${P}-gpl.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="examples sse2"
-
-src_prepare() {
-# sed -i '/.SILENT:/d' Makefile */Makefile
- epatch "${FILESDIR}"/${PN}-1.0.0-makefile.patch
- cd library
- if use sse2 ; then
- sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
- else
- sed -i '15iCFLAGS += -fPIC' Makefile
- fi
-}
-
-src_compile() {
- tc-export CC
- emake -C library libpolarssl.so || die "emake failed"
-
- if use examples ; then
- emake -C programs all || die "emake failed"
- fi
- ln -s libpolarssl.so library/libpolarssl.so.0
-}
-
-src_test() {
- cd programs
- emake test/selftest || die "emake selftest failed"
- LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" ./test/selftest || die "selftest failed"
- cd "${S}"
- LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" emake check || die
-}
-
-src_install() {
- insinto /usr/include/polarssl
- doins include/polarssl/*.h || die
- dolib.so library/libpolarssl.so || die
- ln -s libpolarssl.so "${D}"usr/$(get_libdir)/libpolarssl.so.0
- dolib.a library/libpolarssl.a || die
-
- if use examples ; then
- for p in programs/*/* ; do
- if [[ -x "${p}" && ! -d "${p}" ]] ; then
- f=polarssl_`basename "${p}"`
- newbin "${p}" "${f}" || die
- fi
- done
- for e in aes hash pkey ssl test ; do
- docinto "${e}"
- dodoc programs/"${e}"/*.c || die
- dodoc programs/"${e}"/*.txt || die
- done
- fi
-}
diff --git a/net-libs/polarssl/polarssl-1.2.0.ebuild b/net-libs/polarssl/polarssl-1.2.8.ebuild
index 9c32626c6ee0..791dc132265a 100644
--- a/net-libs/polarssl/polarssl-1.2.0.ebuild
+++ b/net-libs/polarssl/polarssl-1.2.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.2.0.ebuild,v 1.1 2012/11/17 18:26:12 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.2.8.ebuild,v 1.1 2013/06/23 12:21:44 tommy Exp $
EAPI=2
@@ -8,12 +8,11 @@ inherit eutils multilib toolchain-funcs
DESCRIPTION="Cryptographic library for embedded systems"
HOMEPAGE="http://polarssl.org/"
-#https://polarssl.org/download/polarssl-1.2.0-gpl.tgz
SRC_URI="http://polarssl.org/download/${P}-gpl.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="examples sse2"
src_prepare() {