summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-11-06 18:31:20 +0000
committerMichael Weber <xmw@gentoo.org>2014-11-06 18:31:20 +0000
commitaa92f03d0179c370dec86abcbfa39dd728b9342a (patch)
tree01cddf1bc84fb200b243a34fb78bb2776e8a27cd /net-libs
parentFix security vulnerability. (diff)
downloadgentoo-2-aa92f03d0179c370dec86abcbfa39dd728b9342a.tar.gz
gentoo-2-aa92f03d0179c370dec86abcbfa39dd728b9342a.tar.bz2
gentoo-2-aa92f03d0179c370dec86abcbfa39dd728b9342a.zip
fix for glibc-2.20 (bug 527360)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/hubbub/ChangeLog11
-rw-r--r--net-libs/hubbub/files/hubbub-0.1.2-glibc-2.20.patch17
-rw-r--r--net-libs/hubbub/hubbub-0.1.2-r1.ebuild36
-rw-r--r--net-libs/hubbub/hubbub-0.1.2.ebuild7
4 files changed, 66 insertions, 5 deletions
diff --git a/net-libs/hubbub/ChangeLog b/net-libs/hubbub/ChangeLog
index 7d16d6927566..4718221fc1f5 100644
--- a/net-libs/hubbub/ChangeLog
+++ b/net-libs/hubbub/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/hubbub
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/hubbub/ChangeLog,v 1.4 2013/02/28 07:28:03 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/hubbub/ChangeLog,v 1.5 2014/11/06 18:31:20 xmw Exp $
+
+*hubbub-0.1.2-r1 (06 Nov 2014)
+
+ 06 Nov 2014; Michael Weber <xmw@gentoo.org>
+ +files/hubbub-0.1.2-glibc-2.20.patch, +hubbub-0.1.2-r1.ebuild,
+ hubbub-0.1.2.ebuild:
+ fix for glibc-2.20 (bug 527360)
28 Feb 2013; Michael Weber <xmw@gentoo.org> hubbub-0.1.2.ebuild,
+files/hubbub-0.1.2-error.patch:
diff --git a/net-libs/hubbub/files/hubbub-0.1.2-glibc-2.20.patch b/net-libs/hubbub/files/hubbub-0.1.2-glibc-2.20.patch
new file mode 100644
index 000000000000..55c38ffddff6
--- /dev/null
+++ b/net-libs/hubbub/files/hubbub-0.1.2-glibc-2.20.patch
@@ -0,0 +1,17 @@
+--- work/hubbub-0.1.2/Makefile
++++ work/hubbub-0.1.2/Makefile
+@@ -13,13 +13,7 @@
+ WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wnested-externs -pedantic
+-# BeOS/Haiku/AmigaOS have standard library errors that issue warnings.
+-ifneq ($(TARGET),beos)
+- ifneq ($(TARGET),amiga)
+- WARNFLAGS := $(WARNFLAGS) -Werror
+- endif
+-endif
+-CFLAGS := -D_BSD_SOURCE -I$(CURDIR)/include/ \
++CFLAGS := -D_DEFAULT -I$(CURDIR)/include/ \
+ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+ ifneq ($(GCCVER),2)
+ CFLAGS := $(CFLAGS) -std=c99
diff --git a/net-libs/hubbub/hubbub-0.1.2-r1.ebuild b/net-libs/hubbub/hubbub-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..c12b6d2dafb8
--- /dev/null
+++ b/net-libs/hubbub/hubbub-0.1.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/hubbub/hubbub-0.1.2-r1.ebuild,v 1.1 2014/11/06 18:31:20 xmw Exp $
+
+EAPI=5
+
+inherit netsurf
+
+DESCRIPTION="HTML5 compliant parsing library, written in C"
+HOMEPAGE="http://www.netsurf-browser.org/projects/hubbub/"
+SRC_URI="http://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="debug doc static-libs test"
+
+RDEPEND="<dev-libs/libparserutils-0.2
+ !net-libs/libhubbub"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ virtual/libiconv
+ doc? ( app-doc/doxygen )
+ test? ( dev-lang/perl
+ dev-libs/json-c )"
+
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}"/${P}-glibc-2.20.patch )
+
+src_install() {
+ netsurf_src_install
+
+ dodoc README docs/{Architecture,Macros,Todo,Treebuilder,Updated}
+ use doc && dohtml build/docs/html/*
+}
diff --git a/net-libs/hubbub/hubbub-0.1.2.ebuild b/net-libs/hubbub/hubbub-0.1.2.ebuild
index a36f6e48cdc0..8e13f537889b 100644
--- a/net-libs/hubbub/hubbub-0.1.2.ebuild
+++ b/net-libs/hubbub/hubbub-0.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/hubbub/hubbub-0.1.2.ebuild,v 1.4 2013/02/28 07:28:03 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/hubbub/hubbub-0.1.2.ebuild,v 1.5 2014/11/06 18:31:20 xmw Exp $
EAPI=5
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm"
IUSE="debug doc static-libs test"
-RDEPEND="dev-libs/libparserutils"
+RDEPEND="<dev-libs/libparserutils-0.2
+ !net-libs/libhubbub"
DEPEND="${RDEPEND}
virtual/pkgconfig
virtual/libiconv